The NetBSD Project

CVS log for pkgsrc/devel/hs-versions/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / hs-versions

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.12: download - view: text, markup, annotated - select for diffs
Wed Mar 5 03:39:36 2025 UTC (2 weeks, 1 day ago) by pho
Branches: MAIN
CVS tags: HEAD
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +2 -2 lines
recursive revbump after patching lang/ghc910

Revision 1.11: download - view: text, markup, annotated - select for diffs
Sun Feb 2 13:05:31 2025 UTC (6 weeks, 3 days ago) by pho
Branches: MAIN
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +2 -1 lines
Bump all Haskell packages after switching the default compiler.

Revision 1.10: download - view: text, markup, annotated - select for diffs
Sat Feb 1 10:02:17 2025 UTC (6 weeks, 5 days ago) by pho
Branches: MAIN
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +3 -4 lines
devel/hs-versions: update to versions-6.0.7

## 6.0.7 (2024-06-03)

#### Changed

- Bumped upper bound on `base`.

Revision 1.9: download - view: text, markup, annotated - select for diffs
Thu May 9 01:32:19 2024 UTC (10 months, 1 week ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4, pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +2 -1 lines
Recursive revbump after changing the default Haskell compiler

Revision 1.8: download - view: text, markup, annotated - select for diffs
Thu May 2 03:37:54 2024 UTC (10 months, 2 weeks ago) by pho
Branches: MAIN
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -3 lines
devel/hs-versions: Update to 6.0.6

6.0.6 (2024-03-08)
Fixed
    Account for large numbers when parsing on 32-bit (or smaller) systems.

6.0.5 (2024-01-24)
Fixed
    Certain illegal versions were parsing as PVP.

6.0.4 (2023-12-29)
Changed
    Bump dependencies to support GHC 9.8.

Revision 1.7: download - view: text, markup, annotated - select for diffs
Thu Nov 2 06:37:04 2023 UTC (16 months, 2 weeks ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +2 -1 lines
Revbump all Haskell after updating lang/ghc96

Revision 1.6: download - view: text, markup, annotated - select for diffs
Mon Oct 30 03:13:10 2023 UTC (16 months, 2 weeks ago) by pho
Branches: MAIN
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -3 lines
devel/hs-versions: Update to 6.0.3

6.0.3 (2023-10-23)
Added
* Data instances for the various data types.
* Simple conversion types between the main version types.
* Compile-time constructors via Template Haskell, like versioningQ.

6.0.2 (2023-10-12)
Added
* Lift instances for the various types, which allows parsing version
  numbers at compile time within Template Haskell quotes. Currently there
  is no exported function that supports this directly, but you could write
  one like:

-- | Parse a `Versioning` at compile time.
thVer :: Text -> Q Exp
thVer nm =
  case versioning nm of
    Left err -> fail (errorBundlePretty err)
    Right v  -> lift v

Changed
* Due to the new dependency on template-haskell, GHC 8.8 is now the lowest
  supported compiler version.

6.0.1 (2023-05-08)
Fixed
* Restored the ability to compile with GHC versions earlier than 9.

6.0.0 (2023-04-29)

A number of type changes have been made to improve parsing and comparison
logic. Doing so fixed several bugs and made the code cleaner overall.

If you're just doing basic parsing and comparisons and not actually
inspecting the types themselves, you shouldn't notice a difference.

Added
* New types Release, Chunks, and Chunk.

Changed
* Both SemVer and Version now contain a better-behaving Release type for
  their prerelease info.
* Similarly, Version now also has a better-behaving Chunks type for its
  main version number sections.
* The release traversal now yields a Maybe Release.
* Versions with ~ in their metadata will now parse as a Mess. Example:
  12.0.0-3ubuntu1~20.04.5

Removed
* The various Semigroup instances. Adding version numbers together is a
  nonsensical operation and should never have been added in the first
  place.
* The VChunk and VUnit types and their associated functions.

Fixed
* Leading zeroes are handled a little better in SemVer pre-release data.

5.0.5 (2023-03-23)
Changed
* Bumped base bound to support GHC 9.6.

Revision 1.5: download - view: text, markup, annotated - select for diffs
Mon Oct 9 04:54:35 2023 UTC (17 months, 1 week ago) by pho
Branches: MAIN
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -2 lines
Bump Haskell packages after updating lang/ghc94

Revision 1.4: download - view: text, markup, annotated - select for diffs
Tue Feb 7 01:40:55 2023 UTC (2 years, 1 month ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -1 lines
revbump all the Haskell packages after modifying the runtime system of lang/ghc94

Revision 1.3: download - view: text, markup, annotated - select for diffs
Wed Jan 25 18:48:52 2023 UTC (2 years, 1 month ago) by pho
Branches: MAIN
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -3 lines
devel/hs-versions: Update to 5.0.4

5.0.4 (2022-10-18)
Changed
* Bumped base bound to support GHC 9.4.

5.0.3 (2022-02-25)
Fixed
* A bug in prettyVer that flipped the order of the preRel and meta fields.

Revision 1.2: download - view: text, markup, annotated - select for diffs
Sat Feb 26 03:58:12 2022 UTC (3 years ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -1 lines
Bump all Haskell packages after enabling "split sections" in mk/haskell.mk

Revision 1.1: download - view: text, markup, annotated - select for diffs
Thu Feb 24 01:23:25 2022 UTC (3 years ago) by pho
Branches: MAIN
devel/hs-versions: import hs-versions-5.0.2

A library for parsing and comparing software version numbers. We like to
give version numbers to our software in a myriad of ways. Some ways follow
strict guidelines for incrementing and comparison. Some follow conventional
wisdom and are generally self-consistent. Some are just plain asinine. This
library provides a means of parsing and comparing any style of versioning,
be it a nice Semantic Version like this:

  1.2.3-r1+git123

...or a monstrosity like this:

  2:10.2+0.0093r3+1-1

Please switch to Semantic Versioning if you aren't currently using it. It
provides consistency in version incrementing and has the best constraints
on comparisons.

This library implements version 2.0.0 of the SemVer spec.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>