Up to [cvs.NetBSD.org] / pkgsrc / devel / hs-vector
Request diff between arbitrary revisions
Default branch: MAIN
Revision 1.13 / (download) - annotate - [select for diffs], Fri Aug 19 12:30:14 2022 UTC (13 months, 1 week ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base,
pkgsrc-2023Q3,
pkgsrc-2023Q2-base,
pkgsrc-2023Q2,
pkgsrc-2023Q1-base,
pkgsrc-2023Q1,
pkgsrc-2022Q4-base,
pkgsrc-2022Q4,
pkgsrc-2022Q3-base,
pkgsrc-2022Q3,
HEAD
Changes since 1.12: +4 -4
lines
Diff to previous 1.12 (colored)
hs-vector: update to 0.13.0.0. # Changes in version 0.13.0.0 * `mkType` from `Data.Vector.Generic` is deprecated in favor of `Data.Data.mkNoRepType` * The role signatures on several `Vector` types were too permissive, so they have been tightened up: * The role signature for `Data.Vector.Mutable.MVector` is now `type role MVector nominal representational` (previously, both arguments were `phantom`). [#224](https://github.com/haskell/vector/pull/224) * The role signature for `Data.Vector.Primitive.Vector` is now `type role Vector nominal` (previously, it was `phantom`). The role signature for `Data.Vector.Primitive.Mutable.MVector` is now `type role MVector nominal nominal` (previously, both arguments were `phantom`). [#316](https://github.com/haskell/vector/pull/316) * The role signature for `Data.Vector.Storable.Vector` is now `type role Vector nominal` (previous, it was `phantom`), and the signature for `Data.Vector.Storable.Mutable.MVector` is now `type role MVector nominal nominal` (previous, both arguments were `phantom`). [#235](https://github.com/haskell/vector/pull/235) We pick `nominal` for the role of the last argument instead of `representational` since the internal structure of a `Storable` vector is determined by the `Storable` instance of the element type, and it is not guaranteed that the `Storable` instances between two representationally equal types will preserve this internal structure. One consequence of this choice is that it is no longer possible to `coerce` between `Storable.Vector a` and `Storable.Vector b` if `a` and `b` are nominally distinct but representationally equal types. We now provide `unsafeCoerce{M}Vector` and `unsafeCast` functions to allow this (the onus is on the user to ensure that no `Storable` invariants are broken when using these functions). * Methods of type classes `Data.Vector.Generic.Mutable.MVector` and `Data.Vector.Generic.Vector` use concrete monads (`ST`, etc) istead of being polymorphic (`PrimMonad`, etc). [#335](https://github.com/haskell/vector/pull/335). This makes it possible to derive `Unbox` with: * `GeneralizedNewtypeDeriving` * via `UnboxViaPrim` and `Prim` instance * via `As` and `IsoUnbox` instance: [#378](https://github.com/haskell/vector/pull/378) * Add `MonadFix` instance for boxed vectors: [#312](https://github.com/haskell/vector/pull/312) * Re-export `PrimMonad` and `RealWorld` from mutable vectors: [#320](https://github.com/haskell/vector/pull/320) * Add `maximumOn` and `minimumOn`: [#356](https://github.com/haskell/vector/pull/356) * The functions `scanl1`, `scanl1'`, `scanr1`, and `scanr1'` for immutable vectors are now defined when given empty vectors as arguments, in which case they return empty vectors. This new behavior is consistent with the one of the corresponding functions in `Data.List`. Prior to this change, applying an empty vector to any of those functions resulted in an error. This change was introduced in: [#382](https://github.com/haskell/vector/pull/382) * Change allocation strategy for `unfoldrN`: [#387](https://github.com/haskell/vector/pull/387) * Remove `CPP` driven error reporting in favor of `HasCallStack`: [#397](https://github.com/haskell/vector/pull/397) * Remove redundant `Storable` constraints on to/from `ForeignPtr` conversions: [#394](https://github.com/haskell/vector/pull/394) * Add `unsafeCast` to `Primitive` vectors: [#401](https://github.com/haskell/vector/pull/401) * Make `(!?)` operator strict: [#402](https://github.com/haskell/vector/pull/402) * Add `readMaybe`: [#425](https://github.com/haskell/vector/pull/425) * Add `groupBy` and `group` for `Data.Vector.Generic` and the specialized version in `Data.Vector`, `Data.Vector.Unboxed`, `Data.Vector.Storable` and `Data.Vector.Primitive`. [#427](https://github.com/haskell/vector/pull/427) * Add `toArraySlice` and `unsafeFromArraySlice` functions for conversion to and from the underlying boxed `Array`: [#434](https://github.com/haskell/vector/pull/434)
Revision 1.12 / (download) - annotate - [select for diffs], Fri Feb 11 13:40:50 2022 UTC (19 months, 2 weeks ago) by pho
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base,
pkgsrc-2022Q2,
pkgsrc-2022Q1-base,
pkgsrc-2022Q1
Changes since 1.11: +4 -5
lines
Diff to previous 1.11 (colored)
Update to vector-0.12.3.1 Changes in version 0.12.3.1 * Bugfix for ghcjs and Double memset for Storable vector: #410 * Avoid haddock bug: #383 * Improve haddock and doctests * Disable problematic tests with -boundschecks #407 Changes in version 0.12.3.0 * Fix performance regression due to introduction of keepAlive# primop in ghc-9.0: #372 * Add monadic functions for mutable vectors: #338 * Added folds for monadic functions: mapM_, imapM_, forM_, iforM_, foldl, foldl', foldM, foldM', ifoldl, ifoldl', ifoldM, ifoldM' * Added modifyM and unsafeModifyM for mutable vectors * Added generate and generateM for mutable vectors Changes in version 0.12.2.0 * Add MINIMAL pragma to Vector & MVector type classes: #11 * Export unstreamM fromfrom Data.Vector.Generic: #70 * New functions: unfoldrExactN and unfoldrExactNM: #140 * Added iforM and iforM_: #262 * Added MonadFix instance for boxed vectors: #178 * Added uncons and unsnoc: #212 * Added foldMap and foldMap': #263 * Added isSameVector for storable vectors * Added toArray, fromArray, toMutableArray and fromMutableArray * Added iscanl, iscanl', iscanr, iscanr' to Primitive, Storable and Unboxed * Added izipWithM, izipWithM_, imapM and imapM_ to Primitive and Storable * Added ifoldM, ifoldM', ifoldM_ and ifoldM'_ to Primitive and Storable * Added eqBy and cmpBy * Added findIndexR to Generic: #172 * Added catMaybes: #329 * Added mapMaybeM and imapMaybeM: #183 Changes in version 0.12.1.2 * Fix for lost function Data.Vector.Generic.mkType: #287 Changes in version 0.12.1.1 (deprecated) * add semigrioups dep to test suite so CI actually runs again on GHC < 8 Changes in version 0.12.1.0 (deprecated) * Fix integer overflows in specializations of Bundle/Stream enumFromTo on Integral types * Fix possibility of OutOfMemory with take and very large arguments. * Fix slice function causing segfault and not checking the bounds properly. * updated specialization rule for EnumFromTo on Float and Double to make sure it always matches the version in GHC Base (which changed as of 8.6) Thanks to Aleksey Khudyakov @Shimuuar for this fix. * fast rejection short circuiting in eqBy operations * the O2 test suite now has reasonable memory usage on every GHC version, special thanks to Alexey Kuleshevich (@lehins). * The Mutable type family is now injective on GHC 8.0 or later. * Using empty Storable vectors no longer results in division-by-zero errors. * The Data instances for Vector types now have well defined implementations for toConstr, gunfold, and dataTypeOf. * New function: partitionWith. * Add Unbox instances for Identity, Const, Down, Dual, Sum, Product, Min, Max, First, Last, WrappedMonoid, Arg, Any, All, Alt, and Compose. * Add NFData1 instances for applicable Vector types.
Revision 1.11 / (download) - annotate - [select for diffs], Tue Oct 26 10:15:04 2021 UTC (23 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base,
pkgsrc-2021Q4
Changes since 1.10: +2 -2
lines
Diff to previous 1.10 (colored)
archivers: Replace RMD160 checksums with BLAKE2s checksums All checksums have been double-checked against existing RMD160 and SHA512 hashes Could not be committed due to merge conflict: devel/py-traitlets/distinfo The following distfiles were unfetchable (note: some may be only fetched conditionally): ./devel/pvs/distinfo pvs-3.2-solaris.tgz ./devel/eclipse/distinfo eclipse-sourceBuild-srcIncluded-3.0.1.zip
Revision 1.10 / (download) - annotate - [select for diffs], Thu Oct 7 13:39:58 2021 UTC (23 months, 2 weeks ago) by nia
Branch: MAIN
Changes since 1.9: +1 -2
lines
Diff to previous 1.9 (colored)
devel: Remove SHA1 hashes for distfiles
Revision 1.9 / (download) - annotate - [select for diffs], Fri Apr 23 07:00:57 2021 UTC (2 years, 5 months ago) by pho
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base,
pkgsrc-2021Q3,
pkgsrc-2021Q2-base,
pkgsrc-2021Q2
Changes since 1.8: +2 -2
lines
Diff to previous 1.8 (colored)
Fix build with GHC 9
Revision 1.8 / (download) - annotate - [select for diffs], Sat Jan 11 08:50:16 2020 UTC (3 years, 8 months ago) by pho
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base,
pkgsrc-2021Q1,
pkgsrc-2020Q4-base,
pkgsrc-2020Q4,
pkgsrc-2020Q3-base,
pkgsrc-2020Q3,
pkgsrc-2020Q2-base,
pkgsrc-2020Q2,
pkgsrc-2020Q1-base,
pkgsrc-2020Q1
Changes since 1.7: +2 -2
lines
Diff to previous 1.7 (colored)
Fix build with GHC 8.8
Revision 1.7 / (download) - annotate - [select for diffs], Wed Jan 1 02:43:35 2020 UTC (3 years, 8 months ago) by pho
Branch: MAIN
Changes since 1.6: +6 -5
lines
Diff to previous 1.6 (colored)
Update to vector-0.12.0.3 Changes in version 0.12.0.3 * Add support for ghc >=8.8 monad fail Changes in version 0.12.0.2 * Fixes issue #220, compact heap operations crashing on boxed vectors constructed using traverse. * remove usage of Data.Primitive.Address and clarify the memset Prim Storable smuggling trick in Vector.Storable.Mutable * backport injective type family support Changes in version 0.12.0.1 * Make sure `length` can be inlined * Include modules that test-suites depend on in other-modules Changes in version 0.12.0.0 * Documentation fixes/additions * New functions: createT, iscanl/r, iterateNM, unfoldrM, uniq * New instances for various vector types: Semigroup, MonadZip * Made `Storable` vectors respect memory alignment * Changed some macros to ConstraintKinds * Dropped compatibility with old GHCs to support this * Add `Eq1`, `Ord1`, `Show1`, and `Read1` `Vector` instances, and related helper functions. * Relax context for `Unbox (Complex a)`.
Revision 1.6 / (download) - annotate - [select for diffs], Sun Dec 13 14:08:12 2015 UTC (7 years, 9 months ago) by szptvlfn
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base,
pkgsrc-2019Q4,
pkgsrc-2019Q3-base,
pkgsrc-2019Q3,
pkgsrc-2019Q2-base,
pkgsrc-2019Q2,
pkgsrc-2019Q1-base,
pkgsrc-2019Q1,
pkgsrc-2018Q4-base,
pkgsrc-2018Q4,
pkgsrc-2018Q3-base,
pkgsrc-2018Q3,
pkgsrc-2018Q2-base,
pkgsrc-2018Q2,
pkgsrc-2018Q1-base,
pkgsrc-2018Q1,
pkgsrc-2017Q4-base,
pkgsrc-2017Q4,
pkgsrc-2017Q3-base,
pkgsrc-2017Q3,
pkgsrc-2017Q2-base,
pkgsrc-2017Q2,
pkgsrc-2017Q1-base,
pkgsrc-2017Q1,
pkgsrc-2016Q4-base,
pkgsrc-2016Q4,
pkgsrc-2016Q3-base,
pkgsrc-2016Q3,
pkgsrc-2016Q2-base,
pkgsrc-2016Q2,
pkgsrc-2016Q1-base,
pkgsrc-2016Q1,
pkgsrc-2015Q4-base,
pkgsrc-2015Q4
Changes since 1.5: +5 -5
lines
Diff to previous 1.5 (colored)
Update to 0.11.0.0 changelog: Changes in version 0.11.0.0 * Define `Applicative` instances for `Data.Vector.Fusion.Util.{Box,Id}` * Define non-bottom `fail` for `instance Monad Vector` * New generalized stream fusion framework * Various safety fixes - Various overflows due to vector size have been eliminated - Memory is initialized on creation of unboxed vectors * Changes to SPEC usage to allow building under more conditions Changes in version 0.10.12.3 * Allow building with `primtive-0.6`
Revision 1.5 / (download) - annotate - [select for diffs], Tue Nov 3 03:27:34 2015 UTC (7 years, 10 months ago) by agc
Branch: MAIN
Changes since 1.4: +2 -1
lines
Diff to previous 1.4 (colored)
Add SHA512 digests for distfiles for devel category Issues found with existing distfiles: distfiles/eclipse-sourceBuild-srcIncluded-3.0.1.zip distfiles/fortran-utils-1.1.tar.gz distfiles/ivykis-0.39.tar.gz distfiles/enum-1.11.tar.gz distfiles/pvs-3.2-libraries.tgz distfiles/pvs-3.2-linux.tgz distfiles/pvs-3.2-solaris.tgz distfiles/pvs-3.2-system.tgz No changes made to these distinfo files. Otherwise, existing SHA1 digests verified and found to be the same on the machine holding the existing distfiles (morden). All existing SHA1 digests retained for now as an audit trail.
Revision 1.4 / (download) - annotate - [select for diffs], Mon Mar 2 23:44:43 2015 UTC (8 years, 6 months ago) by pho
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base,
pkgsrc-2015Q3,
pkgsrc-2015Q2-base,
pkgsrc-2015Q2,
pkgsrc-2015Q1-base,
pkgsrc-2015Q1
Changes since 1.3: +4 -4
lines
Diff to previous 1.3 (colored)
Update to vector-0.10.12.2 ChangeLog: Changes in version 0.10.12.2 * Add support for `deepseq-1.4.0.0`
Revision 1.3 / (download) - annotate - [select for diffs], Sat Oct 18 21:27:53 2014 UTC (8 years, 11 months ago) by szptvlfn
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base,
pkgsrc-2014Q4
Changes since 1.2: +4 -4
lines
Diff to previous 1.2 (colored)
Update to 0.10.12.1 changelog: Changes in version 0.10.12.1 * Fixed compilation on non-head GHCs Changes in version 0.10.12.0 * Export MVector constructor from Data.Vector.Primitive to match Vector's (which was already exported). * Fix building on GHC 7.9 by adding Applicative instances for Id and Box
Revision 1.2 / (download) - annotate - [select for diffs], Sat Jul 19 13:16:28 2014 UTC (9 years, 2 months ago) by szptvlfn
Branch: MAIN
CVS Tags: pkgsrc-2014Q3-base,
pkgsrc-2014Q3
Changes since 1.1: +4 -4
lines
Diff to previous 1.1 (colored)
Update to 0.10.11.0 changelog: Changes in version 0.10.11.0 * Support OverloadedLists for boxed Vector in GHC >= 7.8 Changes in version 0.10.10.0 * Minor version bump to rectify PVP violation occured in 0.10.9.3 release Changes in version 0.10.9.3 (deprecated) * Add support for OverloadedLists in GHC >= 7.8
Revision 1.1 / (download) - annotate - [select for diffs], Mon May 26 22:02:40 2014 UTC (9 years, 4 months ago) by szptvlfn
Branch: MAIN
CVS Tags: pkgsrc-2014Q2-base,
pkgsrc-2014Q2
Import vector-0.10.9.2 as devel/hs-vector, packaged for wip by pho. An efficient implementation of Int-indexed arrays (both mutable and immutable), with a powerful loop fusion optimization framework. It is structured as follows: * Data.Vector Boxed vectors of arbitrary types. * Data.Vector.Unboxed Unboxed vectors with an adaptive representation based on data type families. * Data.Vector.Storable Unboxed vectors of Storable types. * Data.Vector.Primitive Unboxed vectors of primitive types as defined by the primitive package. Data.Vector.Unboxed is more flexible at no performance cost. * Data.Vector.Generic Generic interface to the vector types.