The NetBSD Project

CVS log for pkgsrc/devel/hs-vector/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / hs-vector

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.23: download - view: text, markup, annotated - select for diffs
Wed Mar 5 03:39:35 2025 UTC (3 weeks, 2 days ago) by pho
Branches: MAIN
CVS tags: HEAD
Diff to: previous 1.22: preferred, colored
Changes since revision 1.22: +2 -2 lines
recursive revbump after patching lang/ghc910

Revision 1.22: download - view: text, markup, annotated - select for diffs
Sun Feb 2 13:05:30 2025 UTC (7 weeks, 4 days ago) by pho
Branches: MAIN
Diff to: previous 1.21: preferred, colored
Changes since revision 1.21: +2 -1 lines
Bump all Haskell packages after switching the default compiler.

Revision 1.21: download - view: text, markup, annotated - select for diffs
Wed Jan 29 17:21:33 2025 UTC (8 weeks, 1 day ago) by pho
Branches: MAIN
Diff to: previous 1.20: preferred, colored
Changes since revision 1.20: +8 -3 lines
devel/hs-vector: update to vector-0.13.2.0

# Changes in version 0.13.2.0

 * Strict boxed vector `Data.Vector.Strict` and `Data.Vector.Strict.Mutable` is
   added (#488). it ensures that all values in the vector are evaluated to WHNF.
 * `DoNotUnboxStrict`, `DoNotUnboxLazy`, and `DoNotUnboxNormalForm` wrapper are
   added for defining unbox instances for types that contain not unboxable fields.
   [#503](https://github.com/haskell/vector/issues/506),
   [#508](https://github.com/haskell/vector/pull/508)
 * `spanR` and `breakR` were added [#476](https://github.com/haskell/vector/pull/476).
   They allow parsing vector from the right.
 * We had some improvements on `*.Mutable.{next,prev}Permutation{,By}`
   [#498](https://github.com/haskell/vector/pull/498):
   * Add `*.Mutable.prevPermutation{,By}` and `*.Mutable.nextPermutationBy`
   * Improve time performance. We may now expect good specialization supported by inlining.
     The implementation has also been algorithmically updated: in the previous implementation
     the full enumeration of all the permutations of `[1..n]` took Omega(n*n!), but it now takes O(n!).
   * Add tests for `{next,prev}Permutation`
   * Add benchmarks for `{next,prev}Permutation`
 * Cabal >= 3.0 is now required for building package (#481).
 * `vector:benchmarks-O2` public sublibrary containing benchmarks is added (#481).
 * Type family `Mutable` provides instances for arrays from `primitive`.
 * Various documentation improvements.

Revision 1.20: download - view: text, markup, annotated - select for diffs
Thu May 9 01:32:19 2024 UTC (10 months, 2 weeks ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4, pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2
Diff to: previous 1.19: preferred, colored
Changes since revision 1.19: +2 -2 lines
Recursive revbump after changing the default Haskell compiler

Revision 1.19: download - view: text, markup, annotated - select for diffs
Thu Nov 2 06:37:03 2023 UTC (16 months, 3 weeks ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4
Diff to: previous 1.18: preferred, colored
Changes since revision 1.18: +2 -1 lines
Revbump all Haskell after updating lang/ghc96

Revision 1.18: download - view: text, markup, annotated - select for diffs
Sat Oct 28 17:01:01 2023 UTC (16 months, 4 weeks ago) by pho
Branches: MAIN
Diff to: previous 1.17: preferred, colored
Changes since revision 1.17: +3 -7 lines
devel/hs-vector: Update to 0.13.1.0

Changes in version 0.13.1.0
* Specialized variants of findIndexR are reexported for all vector
  types. #469
* UnboxViaPrim could be used for deriving Unbox instances (V_UnboxViaPrim
  constructor is exported) #450
* Fields of Data.Vector.Fusion.Bundle.Size are now strict #456
* Compatibility with future GHC 9.10 release #462
* Test suite no longer fails when built with QuickCheck-2.14 #461
* Doctests now work with current versions of GHC #465
* Various documentation improvements

Revision 1.17: download - view: text, markup, annotated - select for diffs
Mon Oct 9 04:54:34 2023 UTC (17 months, 2 weeks ago) by pho
Branches: MAIN
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +2 -2 lines
Bump Haskell packages after updating lang/ghc94

Revision 1.16: download - view: text, markup, annotated - select for diffs
Tue Feb 7 01:40:54 2023 UTC (2 years, 1 month ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +2 -1 lines
revbump all the Haskell packages after modifying the runtime system of lang/ghc94

Revision 1.15: download - view: text, markup, annotated - select for diffs
Wed Jan 25 16:37:32 2023 UTC (2 years, 2 months ago) by pho
Branches: MAIN
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +4 -1 lines
devel/hs-vector: Fix build with GHC 9.4

Revision 1.14: download - view: text, markup, annotated - select for diffs
Fri Aug 19 12:30:14 2022 UTC (2 years, 7 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +3 -3 lines
hs-vector: update to 0.13.0.0.

# Changes in version 0.13.0.0

 * `mkType` from `Data.Vector.Generic` is deprecated in favor of
   `Data.Data.mkNoRepType`
 * The role signatures on several `Vector` types were too permissive, so they
   have been tightened up:
   * The role signature for `Data.Vector.Mutable.MVector` is now
     `type role MVector nominal representational` (previously, both arguments
     were `phantom`). [#224](https://github.com/haskell/vector/pull/224)
   * The role signature for `Data.Vector.Primitive.Vector` is now
     `type role Vector nominal` (previously, it was `phantom`).
     The role signature for `Data.Vector.Primitive.Mutable.MVector` is now
     `type role MVector nominal nominal` (previously, both arguments were
     `phantom`). [#316](https://github.com/haskell/vector/pull/316)
   * The role signature for `Data.Vector.Storable.Vector` is now
     `type role Vector nominal` (previous, it was `phantom`), and the signature
     for `Data.Vector.Storable.Mutable.MVector` is now
     `type role MVector nominal nominal` (previous, both arguments were
     `phantom`). [#235](https://github.com/haskell/vector/pull/235)

     We pick `nominal` for the role of the last argument instead of
     `representational` since the internal structure of a `Storable` vector is
     determined by the `Storable` instance of the element type, and it is not
     guaranteed that the `Storable` instances between two representationally
     equal types will preserve this internal structure.  One consequence of this
     choice is that it is no longer possible to `coerce` between
     `Storable.Vector a` and `Storable.Vector b` if `a` and `b` are nominally
     distinct but representationally equal types. We now provide
     `unsafeCoerce{M}Vector` and `unsafeCast` functions to allow this (the onus
     is on the user to ensure that no `Storable` invariants are broken when
     using these functions).
 * Methods of type classes `Data.Vector.Generic.Mutable.MVector` and
   `Data.Vector.Generic.Vector` use concrete monads (`ST`, etc) istead of being
   polymorphic (`PrimMonad`, etc). [#335](https://github.com/haskell/vector/pull/335).
   This makes it possible to derive `Unbox` with:
   * `GeneralizedNewtypeDeriving`
   * via `UnboxViaPrim` and `Prim` instance
   * via `As` and `IsoUnbox` instance: [#378](https://github.com/haskell/vector/pull/378)
 * Add `MonadFix` instance for boxed vectors: [#312](https://github.com/haskell/vector/pull/312)
 * Re-export `PrimMonad` and `RealWorld` from mutable vectors:
   [#320](https://github.com/haskell/vector/pull/320)
 * Add `maximumOn` and `minimumOn`: [#356](https://github.com/haskell/vector/pull/356)
 * The functions `scanl1`, `scanl1'`, `scanr1`, and `scanr1'` for immutable
   vectors are now defined when given empty vectors as arguments,
   in which case they return empty vectors. This new behavior is consistent
   with the one of the corresponding functions in `Data.List`.
   Prior to this change, applying an empty vector to any of those functions
   resulted in an error. This change was introduced in:
   [#382](https://github.com/haskell/vector/pull/382)
 * Change allocation strategy for `unfoldrN`: [#387](https://github.com/haskell/vector/pull/387)
 * Remove `CPP` driven error reporting in favor of `HasCallStack`:
   [#397](https://github.com/haskell/vector/pull/397)
 * Remove redundant `Storable` constraints on to/from `ForeignPtr` conversions:
   [#394](https://github.com/haskell/vector/pull/394)
 * Add `unsafeCast` to `Primitive` vectors: [#401](https://github.com/haskell/vector/pull/401)
 * Make `(!?)` operator strict: [#402](https://github.com/haskell/vector/pull/402)
 * Add `readMaybe`: [#425](https://github.com/haskell/vector/pull/425)
 * Add `groupBy` and `group` for `Data.Vector.Generic` and the specialized
   version in `Data.Vector`, `Data.Vector.Unboxed`, `Data.Vector.Storable` and
   `Data.Vector.Primitive`. [#427](https://github.com/haskell/vector/pull/427)
 * Add `toArraySlice` and `unsafeFromArraySlice` functions for conversion to and
   from the underlying boxed `Array`: [#434](https://github.com/haskell/vector/pull/434)

Revision 1.13: download - view: text, markup, annotated - select for diffs
Sat Feb 26 03:58:12 2022 UTC (3 years, 1 month ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +2 -2 lines
Bump all Haskell packages after enabling "split sections" in mk/haskell.mk

Revision 1.12: download - view: text, markup, annotated - select for diffs
Sat Feb 12 08:50:41 2022 UTC (3 years, 1 month ago) by pho
Branches: MAIN
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +2 -1 lines
revbump after changing the default Haskell compiler

Revision 1.11: download - view: text, markup, annotated - select for diffs
Fri Feb 11 13:40:50 2022 UTC (3 years, 1 month ago) by pho
Branches: MAIN
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +2 -3 lines
Update to vector-0.12.3.1

Changes in version 0.12.3.1
* Bugfix for ghcjs and Double memset for Storable vector: #410
* Avoid haddock bug: #383
* Improve haddock and doctests
* Disable problematic tests with -boundschecks #407

Changes in version 0.12.3.0
* Fix performance regression due to introduction of keepAlive# primop in
  ghc-9.0: #372
* Add monadic functions for mutable vectors: #338
  * Added folds for monadic functions: mapM_, imapM_, forM_, iforM_, foldl,
    foldl', foldM, foldM', ifoldl, ifoldl', ifoldM, ifoldM'
  * Added modifyM and unsafeModifyM for mutable vectors
  * Added generate and generateM for mutable vectors

Changes in version 0.12.2.0
* Add MINIMAL pragma to Vector & MVector type classes: #11
* Export unstreamM fromfrom Data.Vector.Generic: #70
* New functions: unfoldrExactN and unfoldrExactNM: #140
* Added iforM and iforM_: #262
* Added MonadFix instance for boxed vectors: #178
* Added uncons and unsnoc: #212
* Added foldMap and foldMap': #263
* Added isSameVector for storable vectors
* Added toArray, fromArray, toMutableArray and fromMutableArray
* Added iscanl, iscanl', iscanr, iscanr' to Primitive, Storable and Unboxed
* Added izipWithM, izipWithM_, imapM and imapM_ to Primitive and Storable
* Added ifoldM, ifoldM', ifoldM_ and ifoldM'_ to Primitive and Storable
* Added eqBy and cmpBy
* Added findIndexR to Generic: #172
* Added catMaybes: #329
* Added mapMaybeM and imapMaybeM: #183

Changes in version 0.12.1.2
* Fix for lost function Data.Vector.Generic.mkType: #287

Changes in version 0.12.1.1 (deprecated)
* add semigrioups dep to test suite so CI actually runs again on GHC < 8

Changes in version 0.12.1.0 (deprecated)
* Fix integer overflows in specializations of Bundle/Stream enumFromTo on
  Integral types
* Fix possibility of OutOfMemory with take and very large arguments.
* Fix slice function causing segfault and not checking the bounds properly.
* updated specialization rule for EnumFromTo on Float and Double to make
  sure it always matches the version in GHC Base (which changed as of 8.6)
  Thanks to Aleksey Khudyakov @Shimuuar for this fix.
* fast rejection short circuiting in eqBy operations
* the O2 test suite now has reasonable memory usage on every GHC version,
  special thanks to Alexey Kuleshevich (@lehins).
* The Mutable type family is now injective on GHC 8.0 or later.
* Using empty Storable vectors no longer results in division-by-zero
  errors.
* The Data instances for Vector types now have well defined implementations
  for toConstr, gunfold, and dataTypeOf.
* New function: partitionWith.
* Add Unbox instances for Identity, Const, Down, Dual, Sum, Product, Min,
  Max, First, Last, WrappedMonoid, Arg, Any, All, Alt, and Compose.
* Add NFData1 instances for applicable Vector types.

Revision 1.10: download - view: text, markup, annotated - select for diffs
Tue Jan 18 02:48:15 2022 UTC (3 years, 2 months ago) by pho
Branches: MAIN
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +2 -2 lines
Bump packages that depends on GHC

Revision 1.9: download - view: text, markup, annotated - select for diffs
Mon May 3 19:01:05 2021 UTC (3 years, 10 months ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +2 -1 lines
*: Bump PKGREVISION for ghc-9.0.1

Revision 1.8: download - view: text, markup, annotated - select for diffs
Sat Jan 11 08:50:16 2020 UTC (5 years, 2 months ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +1 -3 lines
Fix build with GHC 8.8

Revision 1.7: download - view: text, markup, annotated - select for diffs
Wed Jan 1 02:43:35 2020 UTC (5 years, 2 months ago) by pho
Branches: MAIN
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +4 -2 lines
Update to vector-0.12.0.3

Changes in version 0.12.0.3
* Add support for ghc >=8.8 monad fail

Changes in version 0.12.0.2
* Fixes issue #220, compact heap operations crashing on boxed vectors
  constructed using traverse.
* remove usage of Data.Primitive.Address and clarify the memset Prim
  Storable smuggling trick in Vector.Storable.Mutable
* backport injective type family support

Changes in version 0.12.0.1
* Make sure `length` can be inlined
* Include modules that test-suites depend on in other-modules

Changes in version 0.12.0.0
* Documentation fixes/additions
* New functions: createT, iscanl/r, iterateNM, unfoldrM, uniq
* New instances for various vector types: Semigroup, MonadZip
* Made `Storable` vectors respect memory alignment
* Changed some macros to ConstraintKinds
  * Dropped compatibility with old GHCs to support this
* Add `Eq1`, `Ord1`, `Show1`, and `Read1` `Vector` instances, and
  related helper functions.
* Relax context for `Unbox (Complex a)`.

Revision 1.6: download - view: text, markup, annotated - select for diffs
Sun Dec 13 14:08:12 2015 UTC (9 years, 3 months ago) by szptvlfn
Branches: MAIN
CVS tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -3 lines
Update to 0.11.0.0

changelog:
Changes in version 0.11.0.0

 * Define `Applicative` instances for `Data.Vector.Fusion.Util.{Box,Id}`
 * Define non-bottom `fail` for `instance Monad Vector`
 * New generalized stream fusion framework
 * Various safety fixes
   - Various overflows due to vector size have been eliminated
   - Memory is initialized on creation of unboxed vectors
 * Changes to SPEC usage to allow building under more conditions

Changes in version 0.10.12.3

 * Allow building with `primtive-0.6`

Revision 1.5: download - view: text, markup, annotated - select for diffs
Sat May 9 11:22:26 2015 UTC (9 years, 10 months ago) by szptvlfn
Branches: MAIN
CVS tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -1 lines
Because this error:
  ERROR: hs-primitive>=0.5.4 is not installed; can't buildlink files.
Bump PKGREVISION for hs-primitive-0.5.4.0

Revision 1.4: download - view: text, markup, annotated - select for diffs
Mon Mar 2 23:44:43 2015 UTC (10 years ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2015Q1-base, pkgsrc-2015Q1
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -2 lines
Update to vector-0.10.12.2

ChangeLog:
Changes in version 0.10.12.2

 * Add support for `deepseq-1.4.0.0`

Revision 1.3: download - view: text, markup, annotated - select for diffs
Sat Oct 18 21:27:53 2014 UTC (10 years, 5 months ago) by szptvlfn
Branches: MAIN
CVS tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -2 lines
Update to 0.10.12.1

changelog:
Changes in version 0.10.12.1

 * Fixed compilation on non-head GHCs

Changes in version 0.10.12.0

 * Export MVector constructor from Data.Vector.Primitive to match Vector's
   (which was already exported).

 * Fix building on GHC 7.9 by adding Applicative instances for Id and Box

Revision 1.2: download - view: text, markup, annotated - select for diffs
Sat Jul 19 13:16:28 2014 UTC (10 years, 8 months ago) by szptvlfn
Branches: MAIN
CVS tags: pkgsrc-2014Q3-base, pkgsrc-2014Q3
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -2 lines
Update to 0.10.11.0

changelog:
Changes in version 0.10.11.0

* Support OverloadedLists for boxed Vector in GHC >= 7.8

Changes in version 0.10.10.0

 * Minor version bump to rectify PVP violation occured in 0.10.9.3 release

Changes in version 0.10.9.3 (deprecated)

 * Add support for OverloadedLists in GHC >= 7.8

Revision 1.1: download - view: text, markup, annotated - select for diffs
Mon May 26 22:02:40 2014 UTC (10 years, 10 months ago) by szptvlfn
Branches: MAIN
CVS tags: pkgsrc-2014Q2-base, pkgsrc-2014Q2
Import vector-0.10.9.2 as devel/hs-vector,
packaged for wip by pho.

An efficient implementation of Int-indexed arrays (both mutable and
immutable), with a powerful loop fusion optimization framework.

It is structured as follows:
* Data.Vector
    Boxed vectors of arbitrary types.
* Data.Vector.Unboxed
    Unboxed vectors with an adaptive representation based on data type
    families.
* Data.Vector.Storable
    Unboxed vectors of Storable types.
* Data.Vector.Primitive
    Unboxed vectors of primitive types as defined by the primitive
    package. Data.Vector.Unboxed is more flexible at no performance
    cost.
* Data.Vector.Generic
    Generic interface to the vector types.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>