The NetBSD Project

CVS log for pkgsrc/devel/hs-unagi-chan/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / hs-unagi-chan

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.5: download - view: text, markup, annotated - select for diffs
Wed Mar 5 03:39:33 2025 UTC (2 weeks, 2 days ago) by pho
Branches: MAIN
CVS tags: HEAD
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -2 lines
recursive revbump after patching lang/ghc910

Revision 1.4: download - view: text, markup, annotated - select for diffs
Sun Feb 2 13:05:28 2025 UTC (6 weeks, 5 days ago) by pho
Branches: MAIN
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -2 lines
Bump all Haskell packages after switching the default compiler.

Revision 1.3: download - view: text, markup, annotated - select for diffs
Thu May 9 01:32:17 2024 UTC (10 months, 1 week ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4, pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -2 lines
Recursive revbump after changing the default Haskell compiler

Revision 1.2: download - view: text, markup, annotated - select for diffs
Thu Nov 2 06:37:01 2023 UTC (16 months, 2 weeks ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -1 lines
Revbump all Haskell after updating lang/ghc96

Revision 1.1: download - view: text, markup, annotated - select for diffs
Tue Oct 31 16:29:34 2023 UTC (16 months, 2 weeks ago) by pho
Branches: MAIN
devel/hs-unagi-chan: import hs-unagi-chan-0.4.1.4

This library provides implementations of concurrent FIFO queues (for both
general boxed and primitive unboxed values) that are fast, perform well
under contention, and offer a Chan-like interface. The library may be of
limited usefulness outside of x86 architectures where the fetch-and-add
instruction is not available.

We export several variations of our design; some support additional
functionality while others try for lower latency by removing features or
making them more restrictive (e.g. in the Unboxed variants).

* Unagi: a general-purpose near drop-in replacement for Chan.
* Unagi.Unboxed: like Unagi but specialized for primitive types; this may
  perform better if a queue grows very large.
* Unagi.Bounded: a bounded variant with blocking and non-blocking writes,
  and other functionality where a notion of the queue's capacity is
  required.
* Unagi.NoBlocking: lowest latency implementations for when blocking reads
  aren't required.
* Unagi.NoBlocking.Unboxed: like Unagi.NoBlocking but for primitive types.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>