Up to [cvs.NetBSD.org] / pkgsrc / devel / hs-optparse-applicative
Request diff between arbitrary revisions
Keyword substitution: kv
Default branch: MAIN
recursive revbump after patching lang/ghc910
Bump all Haskell packages after switching the default compiler.
Recursive revbump after changing the default Haskell compiler
Revbump all Haskell after updating lang/ghc96
devel/hs-optparse-applicative: Update to 0.18.1.0 Version 0.18.1.0 (29 May 2023) * Change pretty printer layout algorithm used. The layoutSmart algorithm appears to be extremely slow with some command line sets, to the point where the program appears to hang. Fixes issues: # 476 - Stack executable 'hangs' with 0.17.1 and 0.18.0. * Render help text with AnsiStyle aware rendering functions. Version 0.18.0.0 (22 May 2023) * Move to 'prettyprinter` library for pretty printing. * This is a potentially breaking change when one uses the '*Doc' family of functions (like headerDoc) from Options.Applicative. However, as versions of 'ansi-wl-pprint > 1.0' export a compatible Doc type, this can be mitigated by using a recent version. * One can also either import directly from Options.Applicative.Help or from the Prettyprinter module of 'prettyprinter'. * Allow commands to be disambiguated in a similar manner to flags when the disambiguate modifier is used. * This is a potentially breaking change as the internal CmdReader constructor has been adapted so it is able to be inspected to a greater degree to support finding prefix matches. Version 0.17.1.0 (22 May 2023) * Widen bounds for ansi-wl-pprint. This supports the use of prettyprinter in a non-breaking way, as the ansi-wl-pprint > 1.0 support the newer library. * Export helpIndent from Options.Applicative. * Export completion script generators from Options.Applicative.BashCompletion. * Add simpleVersioner utility for adding a '--version' option to a parser. * Improve documentation. * Drop support for GHC 7.0 and 7.2.
Bump Haskell packages after updating lang/ghc94
revbump all the Haskell packages after modifying the runtime system of lang/ghc94
Recursive bump for recently updated Haskell packages
Bump all Haskell packages after enabling "split sections" in mk/haskell.mk
revbump after changing the default Haskell compiler
Update to optparse-applicative- Version 0.17.0.0 (1 Feb 2022) * Make tabulation width configurable in usage texts. * Separate program name and description in ParserHelp type. * Add helperWith function, which can be easily used to localize the help flag. * Improve usage texts when command names are long. * Improve Documentation.
Bump packages that depends on GHC
*: Bump PKGREVISION for ghc-9.0.1
Update to optparse-applicative-0.16.1.0 Version 0.16.1.0 (21 Nov 2020) * Guard process dependency behind an on by default flag. This allows one to shrink the dependency tree significantly by turning off the ability to use bash completion actions. * Remove bytestring dependency from the test suite. Version 0.16.0.0 (14 Aug 2020) * Add Options.Applicative.NonEmpty.some1 function, which parses options the same as some1 from base, but doesn't cause duplicates in the usage texts. * Further improve help text generation in the presence of optional values when nesting is involved, and many and some when displayed with a suffix. * Add "global" options to the usage texts for subcommands. When using subcommands, a "global options" section can now appear below the options and commands sections. Global options are off by default, to enable them, use the helpShowGlobals modifier. The noGlobal builder will suppress a single option being displayed in the global options list. * Allow the --help option to take the name of a command. Usage without any arguments is the same, but now, when an argument is given, if it is the name of a currently reachable command, the help text for that command will be show. * Updated dependency bounds. * Add builder for the all positional parser policy. * Remove deprecated functions - nullOption - execParserMaybe - customExecParserMaybe
Import optparse-applicative-0.15.1.0 optparse-applicative is a haskell library for parsing options on the command line, providing a powerful applicative interface for composing these options. optparse-applicative takes care of reading and validating the arguments passed to the command line, handling and reporting errors, generating a usage line, a comprehensive help screen, and enabling context-sensitive bash completions.