The NetBSD Project

CVS log for pkgsrc/devel/hs-lens/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / hs-lens

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.13: download - view: text, markup, annotated - select for diffs
Wed Mar 5 03:39:18 2025 UTC (2 weeks, 1 day ago) by pho
Branches: MAIN
CVS tags: HEAD
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +2 -2 lines
recursive revbump after patching lang/ghc910

Revision 1.12: download - view: text, markup, annotated - select for diffs
Sun Feb 2 13:05:12 2025 UTC (6 weeks, 3 days ago) by pho
Branches: MAIN
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +2 -1 lines
Bump all Haskell packages after switching the default compiler.

Revision 1.11: download - view: text, markup, annotated - select for diffs
Thu Jan 30 07:59:00 2025 UTC (7 weeks ago) by pho
Branches: MAIN
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +2 -7 lines
devel/hs-lens: update to lens-5.3.3

5.3.3 [2024.12.28]
------------------
* Add `makeFieldsId`, which generates overloaded field accessors using the
  same names as the underlying fields. This is intended for use with the
  `NoFieldSelectors` and `DuplicateRecordFields` language extensions.

  Also add `classIdFields :: LensRules` and `classIdNamer :: FieldNamer`, both
  of which use the same naming rules as `makeFieldsId`.
* Update the `Prism`s in `Language.Haskell.TH.Lens` to reflect additions to
  `template-haskell-2.23.0.0`:
  * Add an `_OrP` `Prism` for the `Pat` data type.
  * Add `_ForallE`, `_ForallVisE`, and `_ConstrainedE` `Prism`s for the `Exp`
    data type.

5.3.2 [2024.05.12]
------------------
* Define the following lenses that perform an operation and result the old
  result:
  * `(<<<>:~)` (prepend to the front via `(<>)` and return the old result)
  * `(<<<|~)` (prepend to the front via `(<|)` and return the old result)
  * `(<<|>~)` (append to the back via `(|>)` and return the old result)

  Each of these also has a variant that end with `=` instead of `~` (e.g.,
  `(<<<>:=)`) for working in a `MonadState` setting.
* Re-export `(<>:~)`, `(<<>:~)`, `(<|~)`, `(<<|~)`, `(|>~)`, and `(<|>~)` (as
  well as their variants which end with `=` instead of `~`, and their variants
  which return the old result) from `Control.Lens.Operators`.

5.3.1 [2024.05.05]
------------------
* Add a `Magnify` instance for the CPS variant of `RWST` when building with
  `mtl-2.3` or later.

5.3 [2024.05.04]
----------------
* Allow building with GHC 9.10.
* Update the `Prism`s in `Language.Haskell.TH.Lens` to reflect additions to
  `template-haskell-2.22.0.0`:
  * The `_InfixD` `Prism` now focuses on `(Fixity, NamespaceSpecifier, Name)`
    when building with `template-haskell-2.22.0.0` or later.
  * Add `Prism`s for the newly introduced `NamespaceSpecifier` data type.
  * Add `_TypeP` and `_InvisP` `Prism`s for the `Pat` data type.
  * Add a `_TypeE` `Prism` for the `Exp` data type.
  * Add a `_SCCP` `Prism` for the `Pragma` data type.
* Add the following `Setter`s for prepending and appending elements:
  * `(<>:~)`: prepend an element to the front via `(<>)`.
  * `(<<>:~)`: prepend an element to the front via `(<>)` and return the result.
  * `(<|~)`: cons an element to the front via `(<|)`.
  * `(<<|~)`: cons an element to the front via `(<|)` and return the result.
  * `(|>~)`: snoc an element to the back via `(|>)`.
  * `(<|>~)`: snoc an element to the back via `(|>)` and return the result.

  Each of these also has a variant that end with `=` instead of `~` (e.g.,
  `(<>:=)`) for working in a `MonadState` setting.

Revision 1.10: download - view: text, markup, annotated - select for diffs
Thu May 9 01:32:01 2024 UTC (10 months, 1 week ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4, pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +2 -2 lines
Recursive revbump after changing the default Haskell compiler

Revision 1.9: download - view: text, markup, annotated - select for diffs
Fri May 3 10:43:32 2024 UTC (10 months, 2 weeks ago) by pho
Branches: MAIN
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +5 -1 lines
devel/hs-lens: Fix build with GHC 9.8

This breaks build with the currently default GHC 9.6. Please bear with me
until I switch the default compiler.

Revision 1.8: download - view: text, markup, annotated - select for diffs
Thu Nov 2 06:36:43 2023 UTC (16 months, 2 weeks ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -1 lines
Revbump all Haskell after updating lang/ghc96

Revision 1.7: download - view: text, markup, annotated - select for diffs
Mon Oct 30 18:52:37 2023 UTC (16 months, 2 weeks ago) by pho
Branches: MAIN
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +2 -3 lines
devel/hs-lens: Update to 5.2.3

5.2.3 [2023.08.24]
* Allow building with GHC 9.8.
* Add new Prisms to Language.Haskell.TH.Lens to reflect recent additions to
  template-haskell:
  - _GetFieldE and _ProjectionE Prisms for the Exp data type, whose
    corresponding data constructors were introduced in
    template-haskell-2.18.*.
  - _TypedBracketE and _TypedSpliceE Prisms for the Exp data type, whose
    corresponding data constructors were introduced in
    template-haskell-2.21.*.
  - _BndrReq and _BndrInvis Prisms for the BndrVis data type, which was
    added in template-haskell-2.21.*.
* Add a generateRecordSyntax option to Control.Lens.TH, which controls
  whether to generate lenses using record update syntax or not. By default,
  this option is disabled.
* Fix a bug in which the declare* Template Haskell functions would fail if
  a data type's field has a type that is defined in the same Template
  Haskell quotation.
* Add altOf, which collects targets into any Alternative.

5.2.2 [2023.03.18]
* Fix a bug in which calling ix i (where i is a negative number) on Text or
  ByteString would return the Just the first character instead of returning
  Nothing.

5.2.1 [2023.02.27]
* Allow building with GHC 9.6.
* Allow building with GHC backends where HTYPE_SIG_ATOMIC_T is not defined,
  such as the WASM backend.
* Support building with th-abstraction-0.5.*.
* Define _TypeDataD in Language.Haskell.TH.Lens when building with
  template-haskell-2.20.0.0 (GHC 9.6) or later.

Revision 1.6: download - view: text, markup, annotated - select for diffs
Mon Oct 9 04:54:21 2023 UTC (17 months, 1 week ago) by pho
Branches: MAIN
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -2 lines
Bump Haskell packages after updating lang/ghc94

Revision 1.5: download - view: text, markup, annotated - select for diffs
Tue Feb 7 01:40:41 2023 UTC (2 years, 1 month ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -1 lines
revbump all the Haskell packages after modifying the runtime system of lang/ghc94

Revision 1.4: download - view: text, markup, annotated - select for diffs
Tue Aug 23 12:16:25 2022 UTC (2 years, 6 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -3 lines
hs-lens: update to 5.2.

5.2 [2022.08.11]
----------------
* Allow building with GHC 9.4.
* The type of `universeOf` has changed:

  ```diff
  -universeOf :: Getting       [a]  a a -> a -> [a]
  +universeOf :: Getting (Endo [a]) a a -> a -> [a]
  ```

  In many cases, using `Endo [a]` over `[a]` improves performance. Most call
  sites to `universeOf` will not be affected by this change, although you may
  need to update your code if you define your own combinators in terms of
  `universeOf`.
* Allow `makeWrapped` to accept the names of data constructors. This way,
  `makeWrapped` can be used with data family instances, much like other
  functions in `Control.Lens.TH`.
* Define `_OpaqueP`, `_DefaultD`, `_LamCasesE`, `_PromotedInfixT`, and
  `_PromotedUInfixT` in `Language.Haskell.TH.Lens` when building with
  `template-haskell-2.19.0.0` (GHC 9.4) or later.

5.1.1 [2022.05.17]
------------------
* Add `Data.HashSet.Lens.hashMap`, an `Iso` between a `HashSet a` and a
  `HashMap a ()`.
* Allow building with `transformers-0.6.*` and `mtl-2.3.*`.

  Note that `lens` no longer defines `Zoom` instances for `ErrorT` or `ListT`
  when building with `mtl-2.3` or later. This is because `MonadState` is a
  superclass of `Zoom`, and the `MonadState` instances for `ErrorT` and `ListT`
  were removed in `mtl-2.3`. Be watchful of this if you build `lens` with
  `mtl-2.3` (or later) combined with an older version of `transformers`
  (pre-`0.6`) that defines `ErrorT` or `ListT`.

Revision 1.3: download - view: text, markup, annotated - select for diffs
Sat Aug 20 08:08:17 2022 UTC (2 years, 7 months ago) by wiz
Branches: MAIN
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -2 lines
hs*: recursive bump for new dependencies needed

for hs-aeson, hs-vector

Revision 1.2: download - view: text, markup, annotated - select for diffs
Sat Feb 26 03:58:00 2022 UTC (3 years ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -1 lines
Bump all Haskell packages after enabling "split sections" in mk/haskell.mk

Revision 1.1: download - view: text, markup, annotated - select for diffs
Wed Feb 16 10:00:52 2022 UTC (3 years, 1 month ago) by pho
Branches: MAIN
devel/hs-lens: import hs-lens-5.1

This package provides families of lenses, isomorphisms, folds, traversals,
getters and setters.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>