The NetBSD Project

CVS log for pkgsrc/devel/hs-ansi-terminal-types/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / hs-ansi-terminal-types

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.6: download - view: text, markup, annotated - select for diffs
Wed Mar 5 03:39:01 2025 UTC (2 weeks, 1 day ago) by pho
Branches: MAIN
CVS tags: HEAD
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -2 lines
recursive revbump after patching lang/ghc910

Revision 1.5: download - view: text, markup, annotated - select for diffs
Sun Feb 2 13:04:56 2025 UTC (6 weeks, 3 days ago) by pho
Branches: MAIN
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -2 lines
Bump all Haskell packages after switching the default compiler.

Revision 1.4: download - view: text, markup, annotated - select for diffs
Thu May 9 01:31:44 2024 UTC (10 months, 1 week ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4, pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -1 lines
Recursive revbump after changing the default Haskell compiler

Revision 1.3: download - view: text, markup, annotated - select for diffs
Sun Apr 28 20:37:47 2024 UTC (10 months, 3 weeks ago) by pho
Branches: MAIN
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -3 lines
devel/hs-ansi-terminal-types: Update to 1.1

Version 1.1
    Add Underlining constructor to type ConsoleLayer.
    Add CurlyUnderline, DottedUnderline, and DashedUnderline constructors to type Underlining.

Revision 1.2: download - view: text, markup, annotated - select for diffs
Thu Nov 2 06:36:17 2023 UTC (16 months, 2 weeks ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -1 lines
Revbump all Haskell after updating lang/ghc96

Revision 1.1: download - view: text, markup, annotated - select for diffs
Thu Oct 26 07:08:41 2023 UTC (16 months, 3 weeks ago) by pho
Branches: MAIN
devel/hs-ansi-terminal-types: import hs-ansi-terminal-types-0.11.5

The 'ANSI' standards refer to the visual style of displaying characters as
their 'graphic rendition'. The 'ANSI' codes to establish the graphic
rendition for subsequent text are referred to as SELECT GRAPHIC RENDITION
(SGR). This package exposes modules that export types and functions used to
represent SGR aspects.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>