Up to [cvs.NetBSD.org] / pkgsrc / devel / hlint
Request diff between arbitrary revisions
Default branch: MAIN
Revision 1.5 / (download) - annotate - [select for diffs], Sat Jan 28 02:59:27 2023 UTC (7 months, 3 weeks ago) by pho
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base,
pkgsrc-2023Q2,
pkgsrc-2023Q1-base,
pkgsrc-2023Q1,
HEAD
Changes since 1.4: +4 -4
lines
Diff to previous 1.4 (colored)
devel/hlint: Update to 3.5 (* = breaking change) 3.5, released 2022-09-20 #1421, change zip/repeat to map with tuple section #1418, add more QuickCheck hints #1420, suggest use of Data.Tuple.Extra.both in the extra hints #1407, fix some list-comp hints that applied too broadly #1407, suggest [ f x | x <- [y] ] to [f y] #1417, add some more isAlpha/isDigit suggestions #1411, add some empty list equivalent to "" hints #1416, add hints for (== True) and other bool/section values #1410, remove support for building with GHC 8.10 * #1410, always default to using ghc-parser instead of the GHC API * #1410, upgrade to the GHC 9.4 parse tree #1408, evaluate calls of map with empty/singleton lists #1409, add notNull hints, e.g. notNull . concat ==> any notNull #1406, spot list comprehension that should be lefts/rights #1404, add more if/then/else to min or max hints #1403, add last . reverse ==> head #1397, evaluation rules for minimum/maximum on singleton lists 3.4.1, released 2022-07-10 #1345, add --generate-config to generate a complete config #1345, add --generate-summary-json #1377, make anyM/allM on [] produce pure, rather than return #1377, add a pure rule for every return variant #1380, add counts as comments for --default #1372, remove unnecessary brackets when suggesting forM_ #1372, suggest void (forM x y) to forM_ without the void #1394, replace maximum [a, b] ==> max a b (and for min) #1393, for QuickCheck, join . elements ==> oneOf #1387, bypass camelCase hint for new tasty_... custom test prefix 3.4, released 2022-04-24 #1360, make -XHaskell2010 still obey CPP pragmas #1368, make TH quotation bracket rule off by default #1367, add brackets on refactoring templates when needed #1348, make module restrict hints more powerful #1363, add more hints for <$> #1362, add support for language specifier GHC2021 #1342, make module wildcards work with `within` restrictions #1340, include Restriction hints in splitSettings and argsSettings output #1330, make ignore: {} not ignore subsequent hints #1317, evaluating all/any/allM/anyM on simple lists #1303, allow more matches for modules doing `import Prelude ()` #1324, add createModuleExWithFixities #1336, warn on unused OverloadedRecordDot #1334, don't remove TypeApplications if there are type-level type applications #1332, suggest using iterate instead of scanl/foldl #1331, suggest using min/max instead of if * #1247, move to GHC 9.2
Revision 1.4 / (download) - annotate - [select for diffs], Sat Feb 12 07:21:15 2022 UTC (19 months, 1 week ago) by pho
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base,
pkgsrc-2022Q4,
pkgsrc-2022Q3-base,
pkgsrc-2022Q3,
pkgsrc-2022Q2-base,
pkgsrc-2022Q2,
pkgsrc-2022Q1-base,
pkgsrc-2022Q1
Changes since 1.3: +4 -4
lines
Diff to previous 1.3 (colored)
Update to hlint-3.3.6, but mark it as BROKEN for now 3.3.6, released 2021-12-29 #1326, produce release binaries 3.3.5, released 2021-12-12 #1304, support aeson-2.0 #1309, suggest `either Left f x` becomes `f =<< x` #1295, suggest TemplateHaskell to TemplateHaskellQuotes if it works #1292, don't say redundant bracket around pattern splices #1289, suggest expanding tuple sections in some cases #1289, suggest length [1..n] ==> max 0 n #1279, suggest using NumericUnderscores more if it is enabled #1290, move reverse out of filter 3.3.4, released 2021-08-30 #1288, fix generation of Linux binaries 3.3.3, released 2021-08-29 #1286, compatibility with extra-1.7.10 #114, if OverloadedLists are enabled, don't suggest list literals 3.3.2, released 2021-08-28 #1244, add `only` restriction to modules #1278, make --ignore-glob patterns also ignore directories #1268, move nub/sort/reverse over catMaybes/lefts/rights #1276, fix some incorrect unused LANGUAGE warnings #1271, suggest foldr (<>) mempty ==> fold (not mconcat) #1274, make the (& f) ==> f hint apply more #1264, suggest eta reduction under a where #1266, suggest () <$ x ==> void x #1223, add some traverse laws #1254, suggest null [x] ==> False #1253, suggest reverse . init ==> tail . reverse #1253, suggest null . concat ==> all null #1255, suggest filter instead of list comprehension in teaching
Revision 1.3 / (download) - annotate - [select for diffs], Tue Oct 26 10:14:50 2021 UTC (22 months, 4 weeks ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base,
pkgsrc-2021Q4
Changes since 1.2: +2 -2
lines
Diff to previous 1.2 (colored)
archivers: Replace RMD160 checksums with BLAKE2s checksums All checksums have been double-checked against existing RMD160 and SHA512 hashes Could not be committed due to merge conflict: devel/py-traitlets/distinfo The following distfiles were unfetchable (note: some may be only fetched conditionally): ./devel/pvs/distinfo pvs-3.2-solaris.tgz ./devel/eclipse/distinfo eclipse-sourceBuild-srcIncluded-3.0.1.zip
Revision 1.2 / (download) - annotate - [select for diffs], Thu Oct 7 13:39:48 2021 UTC (23 months, 2 weeks ago) by nia
Branch: MAIN
Changes since 1.1: +1 -2
lines
Diff to previous 1.1 (colored)
devel: Remove SHA1 hashes for distfiles
Revision 1.1 / (download) - annotate - [select for diffs], Wed May 5 10:23:03 2021 UTC (2 years, 4 months ago) by pho
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base,
pkgsrc-2021Q3,
pkgsrc-2021Q2-base,
pkgsrc-2021Q2
Import hlint-3.3.1 HLint is a tool for suggesting possible improvements to Haskell code. These suggestions include ideas such as using alternative functions, simplifying code and spotting redundancies.