Up to [cvs.NetBSD.org] / pkgsrc / devel / hlint
Request diff between arbitrary revisions
Keyword substitution: kv
Default branch: MAIN
devel/hlint: Update the reason for being BROKEN
recursive revbump after patching lang/ghc910
Bump all Haskell packages after switching the default compiler.
devel/hlint: Mark the package as broken. Hope we can revive it soon
Recursive revbump after changing the default Haskell compiler
devel/hlint: Update to 3.8 Changelog for HLint (* = breaking change) 3.8, released 2024-01-15 #1552, make --git and --ignore-glob work nicely together #1502, fix incorrect free variable calculation in some cases #1555, slightly more efficient concatMap usages (e.g. pull filter out) #1500, suggest avoiding NonEmpty.unzip (use Functor.unzip) * #1544, upgrade to GHC 9.8 #1540, correct Functor law hint, was missing brackets
Revbump all Haskell after updating lang/ghc96
devel/hlint: Mark the package as BROKEN
Bump Haskell packages after updating lang/ghc94
revbump all the Haskell packages after modifying the runtime system of lang/ghc94
devel/hlint: Update to 3.5 (* = breaking change) 3.5, released 2022-09-20 #1421, change zip/repeat to map with tuple section #1418, add more QuickCheck hints #1420, suggest use of Data.Tuple.Extra.both in the extra hints #1407, fix some list-comp hints that applied too broadly #1407, suggest [ f x | x <- [y] ] to [f y] #1417, add some more isAlpha/isDigit suggestions #1411, add some empty list equivalent to "" hints #1416, add hints for (== True) and other bool/section values #1410, remove support for building with GHC 8.10 * #1410, always default to using ghc-parser instead of the GHC API * #1410, upgrade to the GHC 9.4 parse tree #1408, evaluate calls of map with empty/singleton lists #1409, add notNull hints, e.g. notNull . concat ==> any notNull #1406, spot list comprehension that should be lefts/rights #1404, add more if/then/else to min or max hints #1403, add last . reverse ==> head #1397, evaluation rules for minimum/maximum on singleton lists 3.4.1, released 2022-07-10 #1345, add --generate-config to generate a complete config #1345, add --generate-summary-json #1377, make anyM/allM on [] produce pure, rather than return #1377, add a pure rule for every return variant #1380, add counts as comments for --default #1372, remove unnecessary brackets when suggesting forM_ #1372, suggest void (forM x y) to forM_ without the void #1394, replace maximum [a, b] ==> max a b (and for min) #1393, for QuickCheck, join . elements ==> oneOf #1387, bypass camelCase hint for new tasty_... custom test prefix 3.4, released 2022-04-24 #1360, make -XHaskell2010 still obey CPP pragmas #1368, make TH quotation bracket rule off by default #1367, add brackets on refactoring templates when needed #1348, make module restrict hints more powerful #1363, add more hints for <$> #1362, add support for language specifier GHC2021 #1342, make module wildcards work with `within` restrictions #1340, include Restriction hints in splitSettings and argsSettings output #1330, make ignore: {} not ignore subsequent hints #1317, evaluating all/any/allM/anyM on simple lists #1303, allow more matches for modules doing `import Prelude ()` #1324, add createModuleExWithFixities #1336, warn on unused OverloadedRecordDot #1334, don't remove TypeApplications if there are type-level type applications #1332, suggest using iterate instead of scanl/foldl #1331, suggest using min/max instead of if * #1247, move to GHC 9.2
Recursive bump for recently updated Haskell packages
*: bump for hs-vector-algorithms buildlink3.mk change
hs*: recursive bump for new dependencies needed for hs-aeson, hs-vector
Bump all Haskell packages after enabling "split sections" in mk/haskell.mk
revbump after changing the default Haskell compiler
Update to hlint-3.3.6, but mark it as BROKEN for now 3.3.6, released 2021-12-29 #1326, produce release binaries 3.3.5, released 2021-12-12 #1304, support aeson-2.0 #1309, suggest `either Left f x` becomes `f =<< x` #1295, suggest TemplateHaskell to TemplateHaskellQuotes if it works #1292, don't say redundant bracket around pattern splices #1289, suggest expanding tuple sections in some cases #1289, suggest length [1..n] ==> max 0 n #1279, suggest using NumericUnderscores more if it is enabled #1290, move reverse out of filter 3.3.4, released 2021-08-30 #1288, fix generation of Linux binaries 3.3.3, released 2021-08-29 #1286, compatibility with extra-1.7.10 #114, if OverloadedLists are enabled, don't suggest list literals 3.3.2, released 2021-08-28 #1244, add `only` restriction to modules #1278, make --ignore-glob patterns also ignore directories #1268, move nub/sort/reverse over catMaybes/lefts/rights #1276, fix some incorrect unused LANGUAGE warnings #1271, suggest foldr (<>) mempty ==> fold (not mconcat) #1274, make the (& f) ==> f hint apply more #1264, suggest eta reduction under a where #1266, suggest () <$ x ==> void x #1223, add some traverse laws #1254, suggest null [x] ==> False #1253, suggest reverse . init ==> tail . reverse #1253, suggest null . concat ==> all null #1255, suggest filter instead of list comprehension in teaching
Bump packages that depends on GHC
Import hlint-3.3.1 HLint is a tool for suggesting possible improvements to Haskell code. These suggestions include ideas such as using alternative functions, simplifying code and spotting redundancies.