[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / gps

File: [cvs.NetBSD.org] / pkgsrc / devel / gps / Attic / Makefile (download)

Revision 1.24, Fri May 31 12:39:59 2013 UTC (10 years, 10 months ago) by wiz
Branch: MAIN
Changes since 1.23: +2 -2 lines

Bump all packages for perl-5.18, that
a) refer 'perl' in their Makefile, or
b) have a directory name of p5-*, or
c) have any dependency on any p5-* package

Like last time, where this caused no complaints.

# $NetBSD: Makefile,v 1.24 2013/05/31 12:39:59 wiz Exp $
#

DISTNAME=	gps-${GPS_VERSION}
PKGREVISION=	17
CATEGORIES=	devel
MASTER_SITES=	http://downloads.dragonlace.net/src/ \
		http://dragonlace.mirrors.ada.cx/src/
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	draco@marino.st
HOMEPAGE=	http://www.adacore.com/home/products/gnatpro/toolsuite/gps/
COMMENT=	GNAT Programming Studio - IDE for Ada and many other languages
LICENSE=	gnu-gpl-v2

GNU_CONFIGURE=		yes
USE_TOOLS+=		gmake sed perl awk pkg-config

GPS_VERSION=		5.0.1
USE_LANGUAGES=		c ada c++ fortran
MY_CONFIGURE_ENV+=	ADA_PROJECT_PATH=${APP}
MY_CONFIGURE_ENV+=	PYTHON=${PREFIX}/bin/python${PYVERSSUFFIX}
APP=			${PREFIX}/lib/gnat

.include "options.mk"

CONFIGURE_ARGS+=	--with-gmp=${PREFIX}

do-configure:
	cd ${WRKSRC} && ${SETENV} ${MY_CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}
do-build:
	cd ${WRKSRC} && ${SETENV} ADA_PROJECT_PATH=${APP} gmake default

pre-install:
.if !empty(PKG_OPTIONS:Mpython)
	${PY_COMPILE_ALL} ${WRKSRC}/share/plug-ins
	${PY_COMPILE_ALL} ${WRKSRC}/share/library
.endif

.include "../../x11/gtkada/buildlink3.mk"
.include "../../textproc/xmlada/buildlink3.mk"
.include "../../devel/gprbuild-aux/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"