[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / go-tools

Annotation of pkgsrc/devel/go-tools/Makefile, Revision 1.29

1.29    ! bsiegert    1: # $NetBSD: Makefile,v 1.28 2019/04/16 18:41:12 bsiegert Exp $
1.1       bsiegert    2:
                      3: DISTNAME=              tools
1.21      bsiegert    4: PKGNAME=               go-tools-1.11.20181009
1.29    ! bsiegert    5: PKGREVISION=           8
1.1       bsiegert    6: CATEGORIES=            devel
                      7: MASTER_SITES=          ${MASTER_SITE_GITHUB:=golang/}
                      8: GITHUB_PROJECT=                ${DISTNAME}
1.21      bsiegert    9: GITHUB_TAG=            34804b1
1.1       bsiegert   10:
                     11: MAINTAINER=            bsiegert@NetBSD.org
                     12: HOMEPAGE=              http://golang.org/
                     13: COMMENT=               Tools for use with Go, including godoc
                     14: LICENSE=               modified-bsd
                     15:
                     16: GO_SRCPATH=            golang.org/x/tools
                     17: GO_DIST_BASE=          ${DISTNAME}-${GITHUB_TAG}*
                     18:
1.3       bsiegert   19: USE_TOOLS+=            bash
1.21      bsiegert   20: REPLACE_BASH+=         cmd/getgo/*.bash
                     21: REPLACE_BASH+=         cmd/godoc/*.bash
1.13      bsiegert   22: REPLACE_BASH+=         cmd/toolstash/buildall
1.3       bsiegert   23:
1.22      bsiegert   24: PLIST_SUBST+=          GOTOOLDIR=${GOTOOLDIR:Q}
                     25: INSTALLATION_DIRS+=    ${GOTOOLDIR}
                     26:
1.15      wiz        27: CHECK_RELRO_SKIP+=     bin/benchcmp
                     28: CHECK_RELRO_SKIP+=     bin/bundle
                     29: CHECK_RELRO_SKIP+=     bin/callgraph
                     30: CHECK_RELRO_SKIP+=     bin/cover
                     31: CHECK_RELRO_SKIP+=     bin/digraph
                     32: CHECK_RELRO_SKIP+=     bin/eg
                     33: CHECK_RELRO_SKIP+=     bin/fiximports
                     34: CHECK_RELRO_SKIP+=     bin/godex
                     35: CHECK_RELRO_SKIP+=     bin/godoc
                     36: CHECK_RELRO_SKIP+=     bin/goimports
                     37: CHECK_RELRO_SKIP+=     bin/gomvpkg
                     38: CHECK_RELRO_SKIP+=     bin/gorename
                     39: CHECK_RELRO_SKIP+=     bin/gotype
                     40: CHECK_RELRO_SKIP+=     bin/goyacc
                     41: CHECK_RELRO_SKIP+=     bin/guru
                     42: CHECK_RELRO_SKIP+=     bin/heapview
                     43: CHECK_RELRO_SKIP+=     bin/html2article
                     44: CHECK_RELRO_SKIP+=     bin/present
                     45: CHECK_RELRO_SKIP+=     bin/ssadump
                     46: CHECK_RELRO_SKIP+=     bin/stress
                     47: CHECK_RELRO_SKIP+=     bin/stringer
                     48: CHECK_RELRO_SKIP+=     bin/tip
                     49: CHECK_RELRO_SKIP+=     bin/toolstash
                     50:
1.22      bsiegert   51: post-install:
                     52:        cd ${DESTDIR}${PREFIX} && mv bin/analyze ${GOTOOLDIR}
                     53:
1.1       bsiegert   54: .include "../../lang/go/go-package.mk"
                     55: .include "../../devel/google-api-go-client/buildlink3.mk"
1.19      minskim    56: BUILDLINK_API_DEPENDS.go-crypto+=      go-crypto>=0.0.20180308
1.17      bsiegert   57: .include "../../security/go-crypto/buildlink3.mk"
1.1       bsiegert   58: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>