[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / go-testify

File: [cvs.NetBSD.org] / pkgsrc / devel / go-testify / Attic / Makefile (download)

Revision 1.8, Tue Mar 13 17:06:05 2018 UTC (6 years ago) by bsiegert
Branch: MAIN
Changes since 1.7: +2 -2 lines

Fix build with Go 1.10, bump revision.

It seems that the rules for pattern matching have changed at some point,
which is what is breaking these builds (or more exactly, their PLISTs).
Now, foo/... does not match anything under foo/vendor AFAICT, and packages
that do not match the pattern do not get .a files explicitly created.

# $NetBSD: Makefile,v 1.8 2018/03/13 17:06:05 bsiegert Exp $

DISTNAME=	go-testify-1.1.3
PKGREVISION=	7
CATEGORIES=	devel
MASTER_SITES=	${MASTER_SITE_GITHUB:=stretchr/}
GITHUB_PROJECT=	testify
GITHUB_TAG=	v1.1.3

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://github.com/stretchr/testify
COMMENT=	Extension to the standard Go testing package
LICENSE=	modified-bsd

WRKSRC=		${WRKDIR}
GO_DIST_BASE=	${GITHUB_PROJECT}-${GITHUB_TAG:S/v//}
GO_SRCPATH=	github.com/stretchr/testify

.include "../../lang/go/go-package.mk"
.include "../../mk/bsd.pkg.mk"