[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / gmp

Annotation of pkgsrc/devel/gmp/Makefile, Revision 1.71

1.71    ! adam        1: # $NetBSD: Makefile,v 1.70 2013/05/25 13:32:26 wiz Exp $
1.1       hubertf     2:
1.71    ! adam        3: DISTNAME=      gmp-5.1.3
1.29      adam        4: CATEGORIES=    devel math
1.65      adam        5: MASTER_SITES=  ftp://ftp.gmplib.org/pub/${DISTNAME}/
1.67      hans        6: # Use .tar.bz2 distfile so that no extra dependency on archivers/xz
                      7: # is needed when building lang/gcc* with option gcc-inplace-math.
1.71    ! adam        8: EXTRACT_SUFX=  .tar.xz
1.29      adam        9:
1.38      jlam       10: MAINTAINER=    pkgsrc-users@NetBSD.org
1.49      wiz        11: HOMEPAGE=      http://gmplib.org/
1.29      adam       12: COMMENT=       Library for arbitrary precision arithmetic
1.57      wiz        13: LICENSE=       gnu-lgpl-v3 AND gnu-gpl-v3
1.1       hubertf    14:
1.25      jlam       15: PKG_INSTALLATION_TYPES=        overwrite pkgviews
                     16:
1.52      bjs        17: INFO_FILES=            yes
1.41      jschauma   18: USE_LANGUAGES=         c c++ c99
1.52      bjs        19: USE_LIBTOOL=           yes
1.54      bjs        20: USE_TOOLS+=            gm4 autoconf makeinfo
1.65      adam       21: GNU_CONFIGURE=         yes
1.55      sketch     22: CONFIGURE_ARGS+=       --without-readline
1.20      heinz      23:
                     24: TEST_TARGET=           check
1.23      kristerw   25:
1.55      sketch     26: PLIST_VARS+=           cxx
                     27:
1.32      grant      28: .include "../../mk/bsd.prefs.mk"
1.55      sketch     29:
1.69      riastrad   30: .if !empty(USE_CROSS_COMPILE:M[yY][eE][sS])
                     31: CONFIGURE_ENV+=                CC_FOR_BUILD=${NATIVE_CC:Q}
                     32: .endif
                     33:
1.55      sketch     34: .if empty(PKGSRC_COMPILER:Msunpro)
                     35: CONFIGURE_ARGS+=       --enable-cxx
                     36: PLIST.cxx=             yes
                     37: .endif
                     38:
1.50      tnn        39: .if !empty(MACHINE_PLATFORM:MIRIX-5*) && !empty(ABI)
1.32      grant      40: ABI=                   o32
                     41: .endif
                     42:
1.23      kristerw   43: .if ${MACHINE_ARCH} == "arm" || ${MACHINE_ARCH} == "arm32"
                     44: # The configure script thinks gcc 2.95 for ARM is too buggy to use.
1.26      jlam       45: GCC_REQD+=             3.0
1.23      kristerw   46: .endif
1.1       hubertf    47:
1.46      bjs        48: .if ${MACHINE_ARCH} == "i386"
1.59      jwise      49: # XXX SunOS should work, but currently bombs in mpn/fat.c
                     50: .  if ${OPSYS} == "Darwin" || ${OPSYS} == "SunOS" || !empty(PKGSRC_COMPILER:Msunpro)
1.44      schmonz    51: # don't use x86 assembly (it doesn't build)
                     52: CONFIGURE_ENV+=                MPN_PATH="generic"
1.46      bjs        53: .  else
                     54: PKG_OPTIONS_VAR=       PKG_OPTIONS.gmp
1.54      bjs        55: PKG_SUPPORTED_OPTIONS= gmp-fat mmx simd
                     56: PKG_SUGGESTED_OPTIONS= gmp-fat
1.46      bjs        57: .    include "../../mk/bsd.options.mk"
                     58: ###
                     59: ### Support for a "fat" binary on i386.  There's CPU autodetection,
                     60: ### so we'll be safe and filter out -march/-mcpu, et. al.
                     61: ###
1.54      bjs        62: ### XXX        Currently, the 'mmx' and 'simd' options imply the same thing,
                     63: ###    as cpu detection is done at runtime.  Is there a more elegant
                     64: ###    way to handle this?
                     65: ###
                     66: .    if empty(PKG_OPTIONS:Mgmp-fat) && \
                     67:         (!empty(PKG_OPTIONS:Mmmx) || !empty(PKG_OPTIONS:Msimd))
                     68: PKG_OPTIONS+=  gmp-fat
                     69: .    endif
1.46      bjs        70: .    if !empty(PKG_OPTIONS:Mgmp-fat)
                     71: CONFIGURE_ARGS+=       --enable-fat
                     72: BUILDLINK_TRANSFORM+=  rm-optarg:-march rm-optarg:-mcpu
                     73: BUILDLINK_TRANSFORM+=  rm:-mmmx rm:-msse rm:-msse2 rm:-msse3 rm:-m3dnow
                     74: .    endif
                     75: .  endif
1.44      schmonz    76: .endif
                     77:
1.48      rillig     78: pre-configure:
                     79:        cd ${WRKSRC} && type autoconf && autoconf
                     80:
1.1       hubertf    81: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>