[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / glib2

Annotation of pkgsrc/devel/glib2/Makefile, Revision 1.183

1.183   ! obache      1: # $NetBSD: Makefile,v 1.182 2011/04/21 10:27:35 roy Exp $
1.1       dmcmahil    2:
1.173     jmmv        3: .include "Makefile.common"
                      4:
1.183   ! obache      5: PKGREVISION=           3
1.181     roy         6:
1.1       dmcmahil    7: CATEGORIES=            devel
                      8:
1.58      grant       9: COMMENT=               Some useful routines for C programming (glib2)
1.49      minskim    10:
1.173     jmmv       11: USE_TOOLS+=            msgfmt perl:run
1.8       jlam       12:
1.68      jmmv       13: PKGCONFIG_OVERRIDE=    glib-2.0-uninstalled.pc.in
                     14: PKGCONFIG_OVERRIDE+=   glib-2.0.pc.in
                     15: PKGCONFIG_OVERRIDE+=   gmodule-2.0-uninstalled.pc.in
1.41      jmmv       16: PKGCONFIG_OVERRIDE+=   gmodule-2.0.pc.in
1.68      jmmv       17: PKGCONFIG_OVERRIDE+=   gmodule-export-2.0.pc.in
1.82      jmmv       18: PKGCONFIG_OVERRIDE+=   gmodule-no-export-2.0-uninstalled.pc.in
1.68      jmmv       19: PKGCONFIG_OVERRIDE+=   gmodule-no-export-2.0.pc.in
                     20: PKGCONFIG_OVERRIDE+=   gobject-2.0-uninstalled.pc.in
1.41      jmmv       21: PKGCONFIG_OVERRIDE+=   gobject-2.0.pc.in
1.68      jmmv       22: PKGCONFIG_OVERRIDE+=   gthread-2.0-uninstalled.pc.in
1.41      jmmv       23: PKGCONFIG_OVERRIDE+=   gthread-2.0.pc.in
1.132     drochner   24: PKGCONFIG_OVERRIDE+=   gio-2.0.pc.in
                     25: PKGCONFIG_OVERRIDE+=   gio-unix-2.0.pc.in
1.8       jlam       26:
1.178     jmmv       27: FILES_SUBST+=          GIO_MODULES_DIR=${PREFIX}/lib/gio/modules
                     28: FILES_SUBST+=          GIO_QUERYMODULES=${PREFIX}/bin/gio-querymodules
                     29: FILES_SUBST+=          GLIB_COMPILE_SCHEMAS=${PREFIX}/bin/glib-compile-schemas
                     30: FILES_SUBST+=          GLIB_SCHEMAS_DIR=${PREFIX}/share/glib-2.0/schemas
                     31:
1.182     roy        32: # gtester is the glib unit testing and reporting framework
                     33: # agc doesn't want glib2 to depend on python so we install it
                     34: # in a broken and useless state.
                     35: CHECK_INTERPRETER_SKIP+=       bin/gtester-report
1.181     roy        36:
1.173     jmmv       37: # need pcre utf8 + unicode-properties
1.180     cegger     38: BUILDLINK_API_DEPENDS.pcre+=   pcre>=8.11
1.139     joerg      39:
1.176     tez        40: LIBS.SunOS+=   -lnsl -lsocket
                     41:
1.35      xtraeme    42: .include "../../converters/libiconv/buildlink3.mk"
                     43: .include "../../devel/gettext-lib/buildlink3.mk"
1.126     drochner   44: .include "../../devel/pcre/buildlink3.mk"
1.175     dsainty    45: .include "../../devel/zlib/buildlink3.mk"
1.1       dmcmahil   46: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>