[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / glib2

Annotation of pkgsrc/devel/glib2/Makefile, Revision 1.158

1.158   ! zafer       1: # $NetBSD: Makefile,v 1.157 2009/04/16 18:51:02 drochner Exp $
1.1       dmcmahil    2:
1.118     tnn         3: # When updating glib2, please apply patch-ak to configure.in
                      4: # Then run a matching version of autoconf to regen patch-aa.
1.157     drochner    5: DISTNAME=              glib-2.20.1
1.39      jmmv        6: PKGNAME=               ${DISTNAME:S/glib/glib2/}
1.1       dmcmahil    7: CATEGORIES=            devel
1.155     jmcneill    8: MASTER_SITES=          ftp://ftp.gtk.org/pub/glib/2.20/ \
                      9:                        ${MASTER_SITE_GNOME:=sources/glib/2.20/}
1.15      grant      10: EXTRACT_SUFX=          .tar.bz2
1.1       dmcmahil   11:
1.117     wiz        12: MAINTAINER=            pkgsrc-users@NetBSD.org
1.119     tron       13: HOMEPAGE=              http://developer.gnome.org/doc/API/2.0/glib/glib.html
1.58      grant      14: COMMENT=               Some useful routines for C programming (glib2)
1.1       dmcmahil   15:
1.49      minskim    16: PKG_INSTALLATION_TYPES=        overwrite pkgviews
1.108     joerg      17: PKG_DESTDIR_SUPPORT=   user-destdir
1.49      minskim    18:
1.14      salo       19: USE_PKGLOCALEDIR=      yes
1.97      jlam       20: USE_TOOLS+=            gmake msgfmt perl:run pkg-config
1.110     jschauma   21: USE_LANGUAGES=         c c++ c99
1.40      jlam       22: USE_LIBTOOL=           yes
1.43      jlam       23: TEST_TARGET=           check
1.8       jlam       24:
1.68      jmmv       25: PKGCONFIG_OVERRIDE=    glib-2.0-uninstalled.pc.in
                     26: PKGCONFIG_OVERRIDE+=   glib-2.0.pc.in
                     27: PKGCONFIG_OVERRIDE+=   gmodule-2.0-uninstalled.pc.in
1.41      jmmv       28: PKGCONFIG_OVERRIDE+=   gmodule-2.0.pc.in
1.68      jmmv       29: PKGCONFIG_OVERRIDE+=   gmodule-export-2.0.pc.in
1.82      jmmv       30: PKGCONFIG_OVERRIDE+=   gmodule-no-export-2.0-uninstalled.pc.in
1.68      jmmv       31: PKGCONFIG_OVERRIDE+=   gmodule-no-export-2.0.pc.in
                     32: PKGCONFIG_OVERRIDE+=   gobject-2.0-uninstalled.pc.in
1.41      jmmv       33: PKGCONFIG_OVERRIDE+=   gobject-2.0.pc.in
1.68      jmmv       34: PKGCONFIG_OVERRIDE+=   gthread-2.0-uninstalled.pc.in
1.41      jmmv       35: PKGCONFIG_OVERRIDE+=   gthread-2.0.pc.in
1.132     drochner   36: PKGCONFIG_OVERRIDE+=   gio-2.0.pc.in
                     37: PKGCONFIG_OVERRIDE+=   gio-unix-2.0.pc.in
1.8       jlam       38:
1.81      rillig     39: GNU_CONFIGURE=         yes
1.86      rillig     40: CONFIGURE_ENV+=                PKGLOCALEDIR=${PKGLOCALEDIR:Q}
1.1       dmcmahil   41: CONFIGURE_ARGS+=       --includedir=${PREFIX}/include/glib
1.43      jlam       42: CONFIGURE_ARGS+=       ${CONFIGURE_ARGS.${ICONV_TYPE}-iconv}
1.91      schwarz    43: CONFIGURE_ARGS.gnu-iconv+=     --with-libiconv=gnu
1.126     drochner   44: CONFIGURE_ARGS+=       --with-pcre=system
1.44      snj        45:
1.86      rillig     46: CONFIGURE_ENV+=                PERL_PATH=${PERL5:Q}
1.60      gavan      47:
1.80      jmmv       48: .include "../../mk/bsd.prefs.mk"
                     49:
1.132     drochner   50: .if ${OPSYS} == "NetBSD"
                     51: # configure detects wrongly
                     52: CONFIGURE_ENV+=                ac_cv_func_statfs=no
                     53: .endif
                     54:
1.66      recht      55: CPPFLAGS+=             -DPREFIX="\"${PREFIX}\""
                     56: CPPFLAGS+=             -DPKGLOCALEDIR="\"${PKGLOCALEDIR}\""
                     57: CPPFLAGS+=             -DPKG_SYSCONFDIR="\"${PKG_SYSCONFDIR}\""
1.64      jmmv       58:
1.47      xtraeme    59: .if ${OPSYS} == "FreeBSD"
1.86      rillig     60: SUBST_CLASSES+=                thr
1.47      xtraeme    61: SUBST_STAGE.thr=       post-patch
                     62: SUBST_FILES.thr=       gthread/Makefile.in
1.74      reed       63: .  if ${OS_VERSION:R} >= 5
1.105     wiz        64: SUBST_SED.thr+=                -e "s|@G_THREAD_LIBS_FOR_GTHREAD@|-lpthread|g"
1.74      reed       65: .  else
1.105     wiz        66: SUBST_SED.thr+=                -e "s|@G_THREAD_LIBS_FOR_GTHREAD@|-Wc,-lc_r|g"
1.74      reed       67: .  endif
1.93      wiz        68: SUBST_MESSAGE.thr=     Fixing libgthread.
1.47      xtraeme    69:
                     70: .endif
                     71:
1.102     minskim    72: .if !empty(MACHINE_PLATFORM:MDarwin-[56].*-*)
                     73: CONFIGURE_ENV+=                gt_cv_c_wchar_t=no
                     74: .endif
                     75:
1.151     obache     76: # Workaround for Bug#562310
1.152     wiz        77: .if ${OPSYS} == "Darwin" || ${OPSYS} == "SunOS"
1.151     obache     78: TOOLS_NOOP+=           gtkdoc-rebase
                     79: .endif
                     80:
1.122     tnn        81: .if ${OPSYS} == "HPUX"
                     82: CONFIGURE_ENV+=                ac_cv_func_mmap_fixed_mapped=yes
                     83: .endif
                     84:
1.50      jmmv       85: # Handle directories shared with devel/glib.
                     86: PRINT_PLIST_AWK+=      /^@dirrm include\/glib$$/ \
                     87:                                { print "@unexec $${RMDIR} %D/" $$2 \
                     88:                                  " 2>/dev/null || $${TRUE}"; next; }
                     89:
1.139     joerg      90: PLIST_VARS+=           fam
                     91:
                     92: .if ${OPSYS} != "HPUX" && ${OPSYS} != "OSF1"
                     93: .include "options.mk"
                     94: .endif
                     95:
1.35      xtraeme    96: .include "../../converters/libiconv/buildlink3.mk"
                     97: .include "../../devel/gettext-lib/buildlink3.mk"
1.62      grant      98: .include "../../mk/dlopen.buildlink3.mk"
1.139     joerg      99:
1.131     tnn       100: .if !empty(MACHINE_PLATFORM:MIRIX-5*)
1.90      schwarz   101: CONFIGURE_ARGS+=       --disable-threads
                    102: .else
1.35      xtraeme   103: .include "../../mk/pthread.buildlink3.mk"
1.90      schwarz   104: .endif
1.150     wiz       105: # need pcre utf8 + unicode-properties
                    106: BUILDLINK_API_DEPENDS.pcre+= pcre>=7.4nb1
1.126     drochner  107: .include "../../devel/pcre/buildlink3.mk"
1.5       jlam      108:
1.1       dmcmahil  109: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>