[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / glib2

Annotation of pkgsrc/devel/glib2/Makefile, Revision 1.150

1.150   ! wiz         1: # $NetBSD: Makefile,v 1.149 2008/11/29 19:09:04 jmcneill Exp $
1.1       dmcmahil    2:
1.118     tnn         3: # When updating glib2, please apply patch-ak to configure.in
                      4: # Then run a matching version of autoconf to regen patch-aa.
1.148     wiz         5: DISTNAME=              glib-2.18.3
1.149     jmcneill    6: PKGREVISION=           1
1.39      jmmv        7: PKGNAME=               ${DISTNAME:S/glib/glib2/}
1.1       dmcmahil    8: CATEGORIES=            devel
1.145     obache      9: MASTER_SITES=          ftp://ftp.gtk.org/pub/glib/2.18/ \
                     10:                        ftp://ftp.cs.umn.edu/pub/gimp/pub/glib/2.18/ \
                     11:                        ${MASTER_SITE_GNOME:=sources/glib/2.18/}
1.15      grant      12: EXTRACT_SUFX=          .tar.bz2
1.1       dmcmahil   13:
1.117     wiz        14: MAINTAINER=            pkgsrc-users@NetBSD.org
1.119     tron       15: HOMEPAGE=              http://developer.gnome.org/doc/API/2.0/glib/glib.html
1.58      grant      16: COMMENT=               Some useful routines for C programming (glib2)
1.1       dmcmahil   17:
1.49      minskim    18: PKG_INSTALLATION_TYPES=        overwrite pkgviews
1.108     joerg      19: PKG_DESTDIR_SUPPORT=   user-destdir
1.49      minskim    20:
1.14      salo       21: USE_PKGLOCALEDIR=      yes
1.97      jlam       22: USE_TOOLS+=            gmake msgfmt perl:run pkg-config
1.110     jschauma   23: USE_LANGUAGES=         c c++ c99
1.40      jlam       24: USE_LIBTOOL=           yes
1.43      jlam       25: TEST_TARGET=           check
1.8       jlam       26:
1.68      jmmv       27: PKGCONFIG_OVERRIDE=    glib-2.0-uninstalled.pc.in
                     28: PKGCONFIG_OVERRIDE+=   glib-2.0.pc.in
                     29: PKGCONFIG_OVERRIDE+=   gmodule-2.0-uninstalled.pc.in
1.41      jmmv       30: PKGCONFIG_OVERRIDE+=   gmodule-2.0.pc.in
1.68      jmmv       31: PKGCONFIG_OVERRIDE+=   gmodule-export-2.0.pc.in
1.82      jmmv       32: PKGCONFIG_OVERRIDE+=   gmodule-no-export-2.0-uninstalled.pc.in
1.68      jmmv       33: PKGCONFIG_OVERRIDE+=   gmodule-no-export-2.0.pc.in
                     34: PKGCONFIG_OVERRIDE+=   gobject-2.0-uninstalled.pc.in
1.41      jmmv       35: PKGCONFIG_OVERRIDE+=   gobject-2.0.pc.in
1.68      jmmv       36: PKGCONFIG_OVERRIDE+=   gthread-2.0-uninstalled.pc.in
1.41      jmmv       37: PKGCONFIG_OVERRIDE+=   gthread-2.0.pc.in
1.132     drochner   38: PKGCONFIG_OVERRIDE+=   gio-2.0.pc.in
                     39: PKGCONFIG_OVERRIDE+=   gio-unix-2.0.pc.in
1.8       jlam       40:
1.81      rillig     41: GNU_CONFIGURE=         yes
1.86      rillig     42: CONFIGURE_ENV+=                PKGLOCALEDIR=${PKGLOCALEDIR:Q}
1.1       dmcmahil   43: CONFIGURE_ARGS+=       --includedir=${PREFIX}/include/glib
1.43      jlam       44: CONFIGURE_ARGS+=       ${CONFIGURE_ARGS.${ICONV_TYPE}-iconv}
1.91      schwarz    45: CONFIGURE_ARGS.gnu-iconv+=     --with-libiconv=gnu
1.126     drochner   46: CONFIGURE_ARGS+=       --with-pcre=system
1.44      snj        47:
1.86      rillig     48: CONFIGURE_ENV+=                PERL_PATH=${PERL5:Q}
1.60      gavan      49:
1.80      jmmv       50: .include "../../mk/bsd.prefs.mk"
                     51:
1.132     drochner   52: .if ${OPSYS} == "NetBSD"
                     53: # configure detects wrongly
                     54: CONFIGURE_ENV+=                ac_cv_func_statfs=no
                     55: .endif
                     56:
1.66      recht      57: CPPFLAGS+=             -DPREFIX="\"${PREFIX}\""
                     58: CPPFLAGS+=             -DPKGLOCALEDIR="\"${PKGLOCALEDIR}\""
                     59: CPPFLAGS+=             -DPKG_SYSCONFDIR="\"${PKG_SYSCONFDIR}\""
1.64      jmmv       60:
1.47      xtraeme    61: .if ${OPSYS} == "FreeBSD"
1.86      rillig     62: SUBST_CLASSES+=                thr
1.47      xtraeme    63: SUBST_STAGE.thr=       post-patch
                     64: SUBST_FILES.thr=       gthread/Makefile.in
1.74      reed       65: .  if ${OS_VERSION:R} >= 5
1.105     wiz        66: SUBST_SED.thr+=                -e "s|@G_THREAD_LIBS_FOR_GTHREAD@|-lpthread|g"
1.74      reed       67: .  else
1.105     wiz        68: SUBST_SED.thr+=                -e "s|@G_THREAD_LIBS_FOR_GTHREAD@|-Wc,-lc_r|g"
1.74      reed       69: .  endif
1.93      wiz        70: SUBST_MESSAGE.thr=     Fixing libgthread.
1.47      xtraeme    71:
                     72: .endif
                     73:
1.102     minskim    74: .if !empty(MACHINE_PLATFORM:MDarwin-[56].*-*)
                     75: CONFIGURE_ENV+=                gt_cv_c_wchar_t=no
                     76: .endif
                     77:
1.122     tnn        78: .if ${OPSYS} == "HPUX"
                     79: CONFIGURE_ENV+=                ac_cv_func_mmap_fixed_mapped=yes
                     80: .endif
                     81:
1.50      jmmv       82: # Handle directories shared with devel/glib.
                     83: PRINT_PLIST_AWK+=      /^@dirrm include\/glib$$/ \
                     84:                                { print "@unexec $${RMDIR} %D/" $$2 \
                     85:                                  " 2>/dev/null || $${TRUE}"; next; }
                     86:
1.139     joerg      87: PLIST_VARS+=           fam
                     88:
                     89: .if ${OPSYS} != "HPUX" && ${OPSYS} != "OSF1"
                     90: .include "options.mk"
                     91: .endif
                     92:
1.35      xtraeme    93: .include "../../converters/libiconv/buildlink3.mk"
                     94: .include "../../devel/gettext-lib/buildlink3.mk"
1.62      grant      95: .include "../../mk/dlopen.buildlink3.mk"
1.139     joerg      96:
1.131     tnn        97: .if !empty(MACHINE_PLATFORM:MIRIX-5*)
1.90      schwarz    98: CONFIGURE_ARGS+=       --disable-threads
                     99: .else
1.35      xtraeme   100: .include "../../mk/pthread.buildlink3.mk"
1.90      schwarz   101: .endif
1.150   ! wiz       102: # need pcre utf8 + unicode-properties
        !           103: BUILDLINK_API_DEPENDS.pcre+= pcre>=7.4nb1
1.126     drochner  104: .include "../../devel/pcre/buildlink3.mk"
1.5       jlam      105:
1.1       dmcmahil  106: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>