[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / glib2

File: [cvs.NetBSD.org] / pkgsrc / devel / glib2 / Makefile.common (download)

Revision 1.84, Tue Sep 29 10:43:33 2020 UTC (3 years, 5 months ago) by prlw1
Branch: MAIN
Changes since 1.83: +2 -2 lines

Update glib2 to 2.66.0

Highlights:
* Fixes to the new `statx()` calls - note that since GLib 2.65.2 uses `statx()`
  (if available) instead of `stat()`/`fstat()`/`lstat()`/`fstatat()`, syscall
  sandboxing for third party applications might need to be updated
* Fix deadlock in `g_subprocess_communicate_async()` (work by Alexander Larsson) (#2182)
* Add `%f`/microsecond placeholder support to `g_date_time_format()` (work by Johan Bjäreholt) (!1605)
* Add `GUri` API for parsing, building and representing URIs according to
  [RFC 3986](https://tools.ietf.org/html/rfc3986) (work by Marc-Andre Lureau) (#110)
* D-Bus credentials support on macOS (#507)
* Year 2038 fixes involving new API in `GBookmarkFile` (#1931)

For full details, see:
https://gitlab.gnome.org/GNOME/glib/-/blob/2.66.0/NEWS

# $NetBSD: Makefile.common,v 1.84 2020/09/29 10:43:33 prlw1 Exp $
# used by devel/gdbus-codegen/Makefile
# used by devel/glib2/Makefile
# used by devel/glib2-tools/Makefile

DISTNAME=	glib-2.66.0
PKGNAME=	${DISTNAME:S/glib/glib2/}
MASTER_SITES=	${MASTER_SITE_GNOME:=sources/glib/${PKGVERSION_NOREV:R}/}
EXTRACT_SUFX=	.tar.xz

MAINTAINER=	prlw1@cam.ac.uk
HOMEPAGE=	https://developer.gnome.org/glib/
LICENSE=	gnu-lgpl-v2.1

USE_LANGUAGES=	c c++ c99
USE_TOOLS+=	msgfmt pkg-config

# does snprintf %d with pid_t...
BUILDLINK_TRANSFORM+=	rm:-Werror=format=2

PYTHON_VERSIONS_INCOMPATIBLE=	27