[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / gearmand

File: [cvs.NetBSD.org] / pkgsrc / devel / gearmand / Makefile (download)

Revision 1.1, Fri Oct 4 07:03:37 2013 UTC (10 years, 6 months ago) by fhajny
Branch: MAIN

Import wip/gearmand as devel/gearmand

Gearman provides a generic application framework to farm out work
to other machines or processes that are better suited to do the work.
It allows you to do work in parallel, to load balance processing,
and to call functions between languages. It can be used in a variety
of applications, from high-availability web sites to the transport
of database replication events.

# $NetBSD: Makefile,v 1.1 2013/10/04 07:03:37 fhajny Exp $
#

DISTNAME=	gearmand-1.0.6
CATEGORIES=	devel
MASTER_SITES=	https://launchpad.net/gearmand/1.0/1.0.6/+download/

MAINTAINER=	filip@joyent.com
HOMEPAGE=	http://gearman.org/
COMMENT=	Gearman C Server and Library
LICENSE=	modified-bsd
FETCH_USING=	curl

GNU_CONFIGURE=	yes
USE_TOOLS+=	gmake pkg-config
USE_LIBTOOL=	yes
USE_LANGUAGES=	c c++

CONFIGURE_ARGS+=	--enable-jobserver=no
CONFIGURE_ARGS+=	--disable-libdrizzle

.include "options.mk"

PKGCONFIG_OVERRIDE+=	support/gearmand.pc.in

.include "../../devel/boost-headers/buildlink3.mk"
.include "../../devel/boost-libs/buildlink3.mk"
.include "../../devel/libevent/buildlink3.mk"
.include "../../devel/libexecinfo/buildlink3.mk"
.include "../../security/libssh2/buildlink3.mk"
.include "../../www/curl/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"