The NetBSD Project

CVS log for pkgsrc/devel/g-wrap/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / g-wrap

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.73 / (download) - annotate - [select for diffs], Wed Oct 26 10:31:01 2022 UTC (3 months, 1 week ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, HEAD
Changes since 1.72: +2 -2 lines
Diff to previous 1.72 (colored)

*: bump PKGREVISION for libunistring shlib major bump

Revision 1.72 / (download) - annotate - [select for diffs], Mon Mar 7 22:59:49 2022 UTC (11 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Changes since 1.71: +2 -2 lines
Diff to previous 1.71 (colored)

*: bump for guile20 PREFIX change

Revision 1.71 / (download) - annotate - [select for diffs], Wed Dec 8 16:01:51 2021 UTC (13 months, 4 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4
Changes since 1.70: +2 -2 lines
Diff to previous 1.70 (colored)

revbump for icu and libffi

Revision 1.70 / (download) - annotate - [select for diffs], Sun Mar 8 16:42:24 2020 UTC (2 years, 11 months ago) by bsiegert
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1
Changes since 1.69: +2 -1 lines
Diff to previous 1.69 (colored)

Revbump packages depending on libffi after .so version change.

Requested by Matthias Ferdinand and Oskar on pkgsrc-users.

Revision 1.69 / (download) - annotate - [select for diffs], Sat Jan 18 23:30:27 2020 UTC (3 years ago) by rillig
Branch: MAIN
Changes since 1.68: +2 -2 lines
Diff to previous 1.68 (colored)

all: migrate several HOMEPAGEs to https

pkglint --only "https instead of http" -r -F

With manual adjustments afterwards since pkglint 19.4.4 fixed a few
indentations in unrelated lines.

This mainly affects projects hosted at SourceForce, as well as
freedesktop.org, CTAN and GNU.

Revision 1.68 / (download) - annotate - [select for diffs], Thu Sep 15 00:01:43 2016 UTC (6 years, 4 months ago) by gdt
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.67: +5 -5 lines
Diff to previous 1.67 (colored)

Update to 1.9.15 and switch to guile20

This package had been held at 1.9.14 because 1.9.15 requires guile
2.0.

Changes from 1.9.14:

  G-Wrap now requires Guile 2.0, allows Guile 2.2;

  Requires autoconf >= 2.61, automake >= 1.12, adding /build-aux

  We no longer update Changelog, see G-Wrap's git logs instead

  No free/mark on WCT objects, and remove use of scm_gc_free

  Use scm_module_variable instead of the deprecated scm_sym2var

  The documentation has been restructured, updated and fixed to work with texinfo >= 5.2;

  Removing doc/version.texi - it is generated/updated

Revision 1.67 / (download) - annotate - [select for diffs], Sun Sep 6 13:48:38 2015 UTC (7 years, 5 months ago) by gdt
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3
Changes since 1.66: +2 -1 lines
Diff to previous 1.66 (colored)

Note that update to 1.9.15 is on hold because it requires guile 2.0.

Revision 1.66 / (download) - annotate - [select for diffs], Wed Oct 31 11:16:58 2012 UTC (10 years, 3 months ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.65: +1 -3 lines
Diff to previous 1.65 (colored)

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

Revision 1.65 / (download) - annotate - [select for diffs], Sat Sep 15 10:04:08 2012 UTC (10 years, 4 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3
Changes since 1.64: +2 -2 lines
Diff to previous 1.64 (colored)

recursive bump from libffi shlib major bump
(additionaly, reset PKGREVISION of qt4-* sub packages from base qt4 update)

Revision 1.64 / (download) - annotate - [select for diffs], Wed May 23 23:11:56 2012 UTC (10 years, 8 months ago) by gdt
Branch: MAIN
CVS Tags: pkgsrc-2012Q2-base, pkgsrc-2012Q2
Changes since 1.63: +3 -3 lines
Diff to previous 1.63 (colored)

not MAKE_JOBS_SAFE

Revision 1.63 / (download) - annotate - [select for diffs], Sun Apr 22 20:30:11 2012 UTC (10 years, 9 months ago) by joerg
Branch: MAIN
Changes since 1.62: +4 -2 lines
Diff to previous 1.62 (colored)

Don't enable -Werror with clang.

Revision 1.62 / (download) - annotate - [select for diffs], Sat Mar 3 00:12:54 2012 UTC (10 years, 11 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2012Q1-base, pkgsrc-2012Q1
Changes since 1.61: +2 -2 lines
Diff to previous 1.61 (colored)

Recursive bump for pcre-8.30* (shlib major change)

Revision 1.61 / (download) - annotate - [select for diffs], Thu Feb 16 18:38:46 2012 UTC (10 years, 11 months ago) by hans
Branch: MAIN
Changes since 1.60: +6 -1 lines
Diff to previous 1.60 (colored)

Don't use -Werror on SunOS.

Revision 1.60 / (download) - annotate - [select for diffs], Mon Feb 6 12:39:49 2012 UTC (11 years ago) by wiz
Branch: MAIN
Changes since 1.59: +2 -1 lines
Diff to previous 1.59 (colored)

Revbump for
a) tiff update to 4.0 (shlib major change)
b) glib2 update 2.30.2 (adds libffi dependency to buildlink3.mk)

Enjoy.

Revision 1.59 / (download) - annotate - [select for diffs], Mon Dec 5 03:34:10 2011 UTC (11 years, 2 months ago) by gdt
Branch: MAIN
CVS Tags: pkgsrc-2011Q4-base, pkgsrc-2011Q4
Changes since 1.58: +3 -4 lines
Diff to previous 1.58 (colored)

Update to 1.9.14.

Drop patch-aa, as
./work/.destdir/usr/pkg/share/guile/site/g-wrap/ws
is created by the install without help.

Version 1.9.14

    - Guile 2.0 is now supported.

    - G-Wrap no longer ships SRFI 34 and SRFI 35 implementations, as
      these have been both provided by Guile since 1.8.3.

Version 1.9.13

    - Fix the dependency declaration on libffi in the g-wrap-2.0-guile
      pkg-config file.

    - An alignment issue leading to testsuite failures on sparc has
      been fixed.

    - The g-wrap-config manpage from the Debian package is now
      included in the source, and installed.

Revision 1.58 / (download) - annotate - [select for diffs], Fri Apr 22 13:43:18 2011 UTC (11 years, 9 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2
Changes since 1.57: +2 -2 lines
Diff to previous 1.57 (colored)

recursive bump from gettext-lib shlib bump.

Revision 1.57 / (download) - annotate - [select for diffs], Wed Mar 24 19:43:22 2010 UTC (12 years, 10 months ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3, pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1
Changes since 1.56: +2 -2 lines
Diff to previous 1.56 (colored)

Recursive revision bump for GMP update.

Revision 1.56 / (download) - annotate - [select for diffs], Tue Dec 15 21:40:00 2009 UTC (13 years, 1 month ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2009Q4-base, pkgsrc-2009Q4
Changes since 1.55: +2 -2 lines
Diff to previous 1.55 (colored)

Recursive bump for libltdl

Revision 1.55 / (download) - annotate - [select for diffs], Wed May 20 00:58:12 2009 UTC (13 years, 8 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2
Changes since 1.54: +2 -1 lines
Diff to previous 1.54 (colored)

Recursive ABI depends update and PKGREVISION bump for readline-6.0 shlib
major change.

Reported by Robert Elz in PR 41345.

Revision 1.54 / (download) - annotate - [select for diffs], Tue Feb 24 02:30:23 2009 UTC (13 years, 11 months ago) by gdt
Branch: MAIN
CVS Tags: pkgsrc-2009Q1-base, pkgsrc-2009Q1
Changes since 1.53: +2 -3 lines
Diff to previous 1.53 (colored)

Update to 1.9.12.  Only listed change is pkgconfig bugfix that was in
patch-ab.

Revision 1.53 / (download) - annotate - [select for diffs], Fri Feb 20 01:16:27 2009 UTC (13 years, 11 months ago) by gdt
Branch: MAIN
Changes since 1.52: +2 -2 lines
Diff to previous 1.52 (colored)

add patch to fix pkg-config file lossage due to incomplete conversion to real libffi

Revision 1.52 / (download) - annotate - [select for diffs], Fri Feb 20 00:50:10 2009 UTC (13 years, 11 months ago) by gdt
Branch: MAIN
Changes since 1.51: +2 -1 lines
Diff to previous 1.51 (colored)

Remove another patch that was for internal ffi linking.

Revision 1.51 / (download) - annotate - [select for diffs], Fri Feb 20 00:42:50 2009 UTC (13 years, 11 months ago) by gdt
Branch: MAIN
Changes since 1.50: +3 -4 lines
Diff to previous 1.50 (colored)

Update to 1.9.11.

Version 1.9.11

    - Fix `double' return value handling on big-endian platforms.

    - libffi is no longer distributed with g-wrap, as it is available
      as a stand-alone package now (instead of being burried in the
      GCC sources).

Version 1.9.10

    - Fix WCT nullable behaviour for 'new' (i.e. non-compat) wrapsets;
      there is now a SRFI-39 parameter 'gw-wcts-nullable?' controlling
      the nullable behaviour; this parameter is #f by default, and set
      to #t when generating compat wrapsets.

Revision 1.50 / (download) - annotate - [select for diffs], Fri Jun 20 01:09:12 2008 UTC (14 years, 7 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3, pkgsrc-2008Q2-base, pkgsrc-2008Q2, cwrapper, cube-native-xorg-base, cube-native-xorg
Changes since 1.49: +4 -3 lines
Diff to previous 1.49 (colored)

Add DESTDIR support.

Revision 1.49 / (download) - annotate - [select for diffs], Thu May 17 23:59:34 2007 UTC (15 years, 8 months ago) by gdt
Branch: MAIN
CVS Tags: pkgsrc-2008Q1-base, pkgsrc-2008Q1, pkgsrc-2007Q4-base, pkgsrc-2007Q4, pkgsrc-2007Q3-base, pkgsrc-2007Q3, pkgsrc-2007Q2-base, pkgsrc-2007Q2
Changes since 1.48: +7 -5 lines
Diff to previous 1.48 (colored)

Update to 1.9.8. This update breaks gnucash, which now uses
devel/g-wrap196 instead.  Changes since 1.9.6:

Version 1.9.8

  - New feature: function flags. At the moment there is a single flag
    specifying whether to leave "Guile mode" when calling the wrapper
    functions. See the Guile manual on "scm_without_guile" for more
    information.

  - Don't rely on libc to provide (v)asprintf, take the implementation
    from gnulib.

  - The minimal GLib bindings now build against GLib 2.x. However,
    their use is deprecated in favour of the much more complete GLib
    bindings in guile-gnome
    (http://www.gnu.org/software/guile-gnome/).

Version 1.9.7

  - The shared libraries now reside in $(pkglibdir)/modules
    (e.g. /usr/lib/g-wrap/modules).

  - Users are now allowed to chose in which module generic functions
    should be defined.

  - New feature: aggregated typespecs.  See the node `Wrapping a C
    Function' of the manual for details.

  - Users can now specify a free and a mark function, as well as an
    equality predicate for wrapped C types (WCTs) in `wrap-as-wct!'.

  - Improved documentation with an API reference (yet to be finished).

  - Several bugfixes.

Revision 1.48 / (download) - annotate - [select for diffs], Thu May 17 17:34:32 2007 UTC (15 years, 8 months ago) by wiz
Branch: MAIN
Changes since 1.47: +2 -2 lines
Diff to previous 1.47 (colored)

Clean up pkglint warning.

Revision 1.47 / (download) - annotate - [select for diffs], Sat May 12 20:56:23 2007 UTC (15 years, 9 months ago) by gdt
Branch: MAIN
Changes since 1.46: +2 -1 lines
Diff to previous 1.46 (colored)

add
MAKE_JOBS_SAFE=		no

Revision 1.46 / (download) - annotate - [select for diffs], Sun Jan 21 12:52:44 2007 UTC (16 years ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2007Q1-base, pkgsrc-2007Q1
Changes since 1.45: +3 -2 lines
Diff to previous 1.45 (colored)

Revert update to 1.9.7, since it breaks gnucash (at least 2.0.[0-4]).
Welcome back, g-wrap-1.9.6nb2!

Revision 1.45 / (download) - annotate - [select for diffs], Sun Jan 14 14:24:31 2007 UTC (16 years ago) by wiz
Branch: MAIN
Changes since 1.44: +3 -4 lines
Diff to previous 1.44 (colored)

Update to 1.9.7:

Version 1.9.7

  - The shared libraries now reside in $(pkglibdir)/modules
    (e.g. /usr/lib/g-wrap/modules).

  - Users are now allowed to chose in which module generic functions
    should be defined.

  - New feature: aggregated typespecs.  See the node `Wrapping a C
    Function' of the manual for details.

  - Users can now specify a free and a mark function, as well as an
    equality predicate for wrapped C types (WCTs) in `wrap-as-wct!'.

  - Improved documentation with an API reference (yet to be finished).

  - Several bugfixes.

Revision 1.44 / (download) - annotate - [select for diffs], Sat Apr 8 23:41:44 2006 UTC (16 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2006Q4-base, pkgsrc-2006Q4, pkgsrc-2006Q3-base, pkgsrc-2006Q3, pkgsrc-2006Q2-base, pkgsrc-2006Q2
Changes since 1.43: +3 -3 lines
Diff to previous 1.43 (colored)

Use glib2 instead of glib. Bump PKGREVISION.

Revision 1.43 / (download) - annotate - [select for diffs], Thu Mar 30 03:44:42 2006 UTC (16 years, 10 months ago) by jlam
Branch: MAIN
Changes since 1.42: +2 -2 lines
Diff to previous 1.42 (colored)

* Honor PKGINFODIR.
* List the info files directly in the PLIST.

Revision 1.42 / (download) - annotate - [select for diffs], Sun Mar 5 16:27:24 2006 UTC (16 years, 11 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.41: +2 -4 lines
Diff to previous 1.41 (colored)

* Teach the tools framework how to supply the pkgsrc version of
  makeinfo if no native makeinfo executable exists.  Honor TEXINFO_REQD
  when determining whether the native makeinfo can be used.

* Remove USE_MAKEINFO and replace it with USE_TOOLS+=makeinfo.

* Get rid of all the "split" argument deduction for makeinfo since
  the PLIST module already handles varying numbers of split info files
  correctly.

NOTE: Platforms that have "makeinfo" in the base system should check
      that the makeinfo entries of pkgsrc/mk/tools.${OPSYS}.mk are
      correct.

Revision 1.41 / (download) - annotate - [select for diffs], Sun Feb 5 23:08:42 2006 UTC (17 years ago) by joerg
Branch: MAIN
Changes since 1.40: +2 -1 lines
Diff to previous 1.40 (colored)

Recursive revision bump / recommended bump for gettext ABI change.

Revision 1.40 / (download) - annotate - [select for diffs], Wed Aug 10 20:56:14 2005 UTC (17 years, 6 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2005Q4-base, pkgsrc-2005Q4, pkgsrc-2005Q3-base, pkgsrc-2005Q3
Changes since 1.39: +2 -3 lines
Diff to previous 1.39 (colored)

Remove the abuse of buildlink that was pkg-config/buildlink3.mk.  That
file's sole purpose was to provide a dependency on pkg-config and set
some environment variables.  Instead, turn pkg-config into a "tool"
in the tools framework, where the pkg-config wrapper automatically
adds PKG_CONFIG_LIBDIR to the environment before invoking the real
pkg-config.

For all package Makefiles that included pkg-config/buildlink3.mk, remove
that inclusion and replace it with USE_TOOLS+=pkg-config.

Revision 1.39 / (download) - annotate - [select for diffs], Wed Aug 10 19:01:23 2005 UTC (17 years, 6 months ago) by gdt
Branch: MAIN
Changes since 1.38: +2 -2 lines
Diff to previous 1.38 (colored)

Change my email address to @NetBSD.org.

Revision 1.38 / (download) - annotate - [select for diffs], Thu Jul 21 16:29:46 2005 UTC (17 years, 6 months ago) by wiz
Branch: MAIN
Changes since 1.37: +2 -2 lines
Diff to previous 1.37 (colored)

Change path from devel/pkgconfig to devel/pkg-config.
No PKGREVISION bump since pkg-config is only a BUILD_DEPENDS.

Revision 1.37 / (download) - annotate - [select for diffs], Sun May 22 20:07:51 2005 UTC (17 years, 8 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2005Q2-base, pkgsrc-2005Q2
Changes since 1.36: +2 -2 lines
Diff to previous 1.36 (colored)

Remove USE_GNU_TOOLS and replace with the correct USE_TOOLS definitions:

	USE_GNU_TOOLS	-> USE_TOOLS
	awk		-> gawk
	m4		-> gm4
	make		-> gmake
	sed		-> gsed
	yacc		-> bison

Revision 1.36 / (download) - annotate - [select for diffs], Tue Apr 19 00:17:40 2005 UTC (17 years, 9 months ago) by wiz
Branch: MAIN
Changes since 1.35: +2 -2 lines
Diff to previous 1.35 (colored)

Update to 1.9.6:
  - Support for size_t and ssize_t data types.

Revision 1.35 / (download) - annotate - [select for diffs], Mon Apr 11 21:45:20 2005 UTC (17 years, 10 months ago) by tv
Branch: MAIN
Changes since 1.34: +1 -2 lines
Diff to previous 1.34 (colored)

Remove USE_BUILDLINK3 and NO_BUILDLINK; these are no longer used.

Revision 1.34 / (download) - annotate - [select for diffs], Wed Mar 2 21:49:45 2005 UTC (17 years, 11 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2005Q1-base, pkgsrc-2005Q1
Changes since 1.33: +5 -2 lines
Diff to previous 1.33 (colored)

Update to 1.9.5.

Changes since 1.9.4:

  - Bugfixes
    + The minimal GLib wrappers are now installed as (g-wrap gw-glib),
      as expected by GnuCash.
    + A problem with generic specializer class lookup has been fixed.
    + A problem with generics specialization and default arguments has
      been fixed.
    + A problem with default arguments, when combined with
      invisible arguments (such as output arguments) has been fixed.

Revision 1.33 / (download) - annotate - [select for diffs], Sun Feb 27 13:19:20 2005 UTC (17 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.32: +2 -2 lines
Diff to previous 1.32 (colored)

Update to 1.9.4:

  - Enhanced generics support: now all arguments of methods are
    specialized, not only the first one.

  - Bugfixes
    + Now ships with (g-wrap gw-wct) compatibilty module needed by
      GnuCash at runtime.
    + Fixes for handling output arguments:
      - Wrapped functions with void return value and output arguments
	now return expected results
      - Optional argument count is now correctly computed in the
        presence of output arguments
    + The libffi alignment requirements are now honored. This fixes bus
      errors on many non-x86 architectures.
    + On big-endian architectures libffi-wrapped functions that return
      char now work correctly.
    + Some "uninitialized variable" warnings were fixed in generated code
      which caused compiles with GCC 4.0 to fail (Debian Bug#290305).

Revision 1.32 / (download) - annotate - [select for diffs], Tue Dec 7 14:25:47 2004 UTC (18 years, 2 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2004Q4-base, pkgsrc-2004Q4
Changes since 1.31: +3 -1 lines
Diff to previous 1.31 (colored)

Add two bl3 files for missing dependencies. Fixes bulk build problem.

Revision 1.31 / (download) - annotate - [select for diffs], Fri Dec 3 17:06:58 2004 UTC (18 years, 2 months ago) by wiz
Branch: MAIN
Changes since 1.30: +9 -15 lines
Diff to previous 1.30 (colored)

Update to 1.9.3, from Greg Troxel via pkgsrc-wip.

Changes since 1.3.4:

Version 1.9.3

  - Comes with a compatibility layer that allows GnuCash to be built
    with it.

  - Reverts the enhanced generics support, which was introduced in
    1.9.2, since that currently breaks guile-gnome

  - Bugfixes
    + g-wrap-2.0-guile.pc is now generated correctly, even if the
      internal libffi is used.
    + Types used by constants are now considered when calculating the
      set of referenced types in a wrapset. This bug led to missing code
      and compile errors when a type defined in another wrapset was used
      by only by a constant.
    + On platforms which lack alloca(), the version shipped with
      G-Wrap should now build correctly.

Version 1.9.2

  - Now comes with libffi included, for systems which lack an libffi
    installation

  - SRFI module checks now work correctly, even if you do an in-tree build

Version 1.9.1

 - API change: destruct-value-cg is now named destroy-value-cg

 - Bugfixes
   + A bug in the latent generic code has been fixed
   + The error message for WCP type errors has been fixed

Version 1.9.0

 - Complete rewrite; too many changes to list, see the manual for the
   new GOOPS-based API and the guile-gnome project for an extended
   example.

  - New features:
    + Output arguments
    + Default arguments

  - G-Wrap should be target-language agnostic, like it was in its
    early days.

Revision 1.30 / (download) - annotate - [select for diffs], Fri Dec 3 15:55:36 2004 UTC (18 years, 2 months ago) by wiz
Branch: MAIN
Changes since 1.29: +2 -2 lines
Diff to previous 1.29 (colored)

Depend on guile14 versions of guile-slib.

Revision 1.29 / (download) - annotate - [select for diffs], Fri Dec 3 14:31:28 2004 UTC (18 years, 2 months ago) by wiz
Branch: MAIN
Changes since 1.28: +2 -2 lines
Diff to previous 1.28 (colored)

Re-point paths to devel/guile14-gtk instead of devel/guile-gtk.

Revision 1.28 / (download) - annotate - [select for diffs], Fri Oct 15 14:50:06 2004 UTC (18 years, 3 months ago) by tv
Branch: MAIN
Changes since 1.27: +2 -2 lines
Diff to previous 1.27 (colored)

Update linkage to libltdl (via guile{,14}), which is now its own package.

Unfortunately, guile{,14}/buildlink3.mk directly includes it, and I don't
know which dependencies actually need libltdl, so it was a recursive bump.
Hopefully this recursive inclusion can be ripped out of
guile{,14}/buildlink3.mk at some point and bubble down to dependencies that
actually use libltdl, avoiding this headache in the future....

Revision 1.27 / (download) - annotate - [select for diffs], Sun Oct 3 00:13:26 2004 UTC (18 years, 4 months ago) by tv
Branch: MAIN
Changes since 1.26: +2 -2 lines
Diff to previous 1.26 (colored)

Libtool fix for PR pkg/26633, and other issues.  Update libtool to 1.5.10
in the process.  (More information on tech-pkg.)

Bump PKGREVISION and BUILDLINK_DEPENDS of all packages using libtool and
installing .la files.

Bump PKGREVISION (only) of all packages depending directly on the above
via a buildlink3 include.

Revision 1.26 / (download) - annotate - [select for diffs], Mon May 3 15:58:55 2004 UTC (18 years, 9 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2004Q3-base, pkgsrc-2004Q3, pkgsrc-2004Q2-base, pkgsrc-2004Q2
Changes since 1.25: +7 -9 lines
Diff to previous 1.25 (colored)

Convert to buildlink3.

Revision 1.25 / (download) - annotate - [select for diffs], Sat Feb 14 17:21:37 2004 UTC (18 years, 11 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2004Q1-base, pkgsrc-2004Q1
Changes since 1.24: +1 -3 lines
Diff to previous 1.24 (colored)

LIBTOOL_OVERRIDE and SHLIBTOOL_OVERRIDE are now lists of shell globs
relative to ${WRKSRC}.  Remove redundant LIBTOOL_OVERRIDE settings that
are automatically handled by the default setting in bsd.pkg.mk.

Revision 1.24 / (download) - annotate - [select for diffs], Thu Jan 22 08:24:29 2004 UTC (19 years ago) by grant
Branch: MAIN
Changes since 1.23: +2 -2 lines
Diff to previous 1.23 (colored)

replace deprecated USE_GMAKE with USE_GNU_TOOLS+=make.

Revision 1.23 / (download) - annotate - [select for diffs], Fri Sep 19 05:18:36 2003 UTC (19 years, 4 months ago) by dent
Branch: MAIN
CVS Tags: pkgsrc-2003Q4-base, pkgsrc-2003Q4
Changes since 1.22: +2 -2 lines
Diff to previous 1.22 (colored)

update HOMEPAGE

Revision 1.22 / (download) - annotate - [select for diffs], Sat Aug 9 10:44:40 2003 UTC (19 years, 6 months ago) by seb
Branch: MAIN
Changes since 1.21: +1 -2 lines
Diff to previous 1.21 (colored)

USE_NEW_TEXINFO is unnecessary now.

Revision 1.21 / (download) - annotate - [select for diffs], Mon Jul 21 16:43:21 2003 UTC (19 years, 6 months ago) by martti
Branch: MAIN
Changes since 1.20: +2 -2 lines
Diff to previous 1.20 (colored)

COMMENT should start with a capital letter.

Revision 1.20 / (download) - annotate - [select for diffs], Thu Jul 17 21:30:33 2003 UTC (19 years, 6 months ago) by grant
Branch: MAIN
Changes since 1.19: +2 -2 lines
Diff to previous 1.19 (colored)

s/netbsd.org/NetBSD.org/

Revision 1.19 / (download) - annotate - [select for diffs], Sun Jul 13 13:51:06 2003 UTC (19 years, 7 months ago) by wiz
Branch: MAIN
Changes since 1.18: +2 -2 lines
Diff to previous 1.18 (colored)

PKGREVISION bump for libiconv update.

Revision 1.18 / (download) - annotate - [select for diffs], Tue Jun 24 14:39:16 2003 UTC (19 years, 7 months ago) by seb
Branch: MAIN
Changes since 1.17: +5 -2 lines
Diff to previous 1.17 (colored)

Convert to USE_NEW_TEXINFO.
Add a patch file so g-wrap.info has @dircategory/@direntry.

Revision 1.17 / (download) - annotate - [select for diffs], Thu Jun 5 05:01:55 2003 UTC (19 years, 8 months ago) by uebayasi
Branch: MAIN
Changes since 1.16: +3 -2 lines
Diff to previous 1.16 (colored)

Bump revisions following the guile14's threaded fix.

Revision 1.16 / (download) - annotate - [select for diffs], Fri May 2 11:54:24 2003 UTC (19 years, 9 months ago) by wiz
Branch: MAIN
Changes since 1.15: +2 -1 lines
Diff to previous 1.15 (colored)

Dependency bumps, needed because of devel/pth's major bump, and related
dependency bumps.

Revision 1.15 / (download) - annotate - [select for diffs], Mon Feb 24 20:50:19 2003 UTC (19 years, 11 months ago) by jschauma
Branch: MAIN
Changes since 1.14: +8 -5 lines
Diff to previous 1.14 (colored)

Update to 1.3.4 using patches provided by roskens at elfin dot net in
PR pkg/20270 with minor nitpicks by myself.
Some of the changes since 1.2.1:

	* configure.in: fix minor problem where we used the guile-gtk
	config program even when it wasn't found.
	* acconfig.h: deleted since deprecated -- replaced by three arg
	AC_DEFINEs in configure.in.
	* doc/.cvsignore: add texinfo.tex.
	* configure.in (AM_INIT_AUTOMAKE): bump version for release.
	* bunch of subversion cleanups.
	* change license to LGPL.
	* g-wrap/gw-glib-spec.scm: coerce to (gpointer) in gw:glist-of and
	gw:gslist-of code where needed.
	* g-wrap/enumeration.scm (gw:wrap-enumeration): make val->int and
	int->val functions static so they don't cause conflicts.
	* configure.in (GW_GUILE_GTK_CFLAGS): delete any occurences of -I
	/usr/include or similar.  Newer gcc's don't like that at all.
	* bin/g-wrap-config.in (c-compile-args): don't output -I if it's
	/usr/include.  The new gcc doesn't like -I /usr/include at all.
	* test/Makefile.am (gw-test-enumeration.scm gw-test-enumeration.h
	gw-test-enumeration.c gw-test-enumeration.html
	gw-test-enumeration-autogen.h): use LD_LIBRARY_PATH.
	(gw-test-parent.scm gw-test-parent.h gw-test-parent.c
	gw-test-parent.html gw-test-parent-autogen.h): use LD_LIBRARY_PATH.
	* doc/g-wrap.texi: minor re-editing -- still needs much more.
	* configure.in (GW_GUILE_GTK_CFLAGS): add and AC_SUBST.
	(GW_GUILE_GTK_LIBFLAGS): add and AC_SUBST.
	* g-wrap/simple-type.scm: new file -- support for simple types.
	* g-wrap/runtime.scm: new file -- scm support for runtime wrapset
	database.
	* g-wrap/gw-wct-spec.scm: new file -- wrapped C pointer types.
	* g-wrap/gw-standard-spec.scm: new file -- standard wrapped types.
	* g-wrap/gw-gtk-spec.scm: new file -- wrappers for gtk.
	* g-wrap/gw-glib-spec.scm: new file -- wrappers for glib.
	* g-wrap/gtkobj.scm: support for wrapping new C ptr types as
	gtkobjects.
	* g-wrap/Makefile.am: major changes -- support gw-glib, gw-wct,
	gw-gtk, etc.
	* g-wrap/g-wrap-wct.h: support header for gw-wct.  Part of
	libgwrap-wct.
	* g-wrap/g-wrap-wct.c: support code for gw-wct.  Part of
	libgwrap-wct.
	* g-wrap/g-wrap-glib.h: support header for gw-glib.  Part of
	libgwrap-glib.
	* g-wrap/g-wrap-glib.c: support code for gw-glib.  Part of
	libgwrap-glib.
	* g-wrap/output-file.scm (flatten-display): make public.
	* g-wrap/g-wrap-compatibility.h: start guile version compatibility
	library.
	* g-wrap/enumeration.scm: break out enumeration support.
	* g-wrap/dummy-main.c: new file - for link testing.
	* bin/g-wrap-config.in (c-link-args): add support for glib, wct,
	etc.
	* g-wrap.scm: major overhaul -- modules -> wrapsets, ccodegens ->
	init/decl/lists, etc.
	* configure.in: remove rscheme (and other dead bits).  Add support
	for glib and gnome-guile.  Handle libruntime reorg/removal.
	* acconfig.h: accomodate reorg/removal of libruntime.
	* g-wrapped/gw-runtime-spec.scm: switch to use of SCM_FALSEP and
	SCM_NFALSEP rather than direct SCM_BOOL_*
	* libruntime-guile/g-wrap-runtime-guile.c: switch to use of
	SCM_FALSEP and SCM_NFALSEP rather than direct SCM_BOOL_*
	comparisons.
	* g-wrap.scm: switch to use of SCM_FALSEP and SCM_NFALSEP rather
	than direct SCM_BOOL_* comparisons.

Revision 1.14 / (download) - annotate - [select for diffs], Fri Jan 24 04:22:42 2003 UTC (20 years ago) by jlam
Branch: MAIN
CVS Tags: netbsd-1-6-1-base, netbsd-1-6-1
Changes since 1.13: +5 -1 lines
Diff to previous 1.13 (colored)

Fix the installed g-wrap-config to invoke ${GUILE14_PREFIX}/bin/guile
instead of the one in the work directory.  Also ensure that we install
guile library files into ${GUILE14_PREFIX}/share/guile instead of into
the same place under ${LOCALBASE}, since we are using guile14.  Bump
PKGREVISION of devel/g-wrap to 1.

Revision 1.13 / (download) - annotate - [select for diffs], Sun Jan 19 04:43:38 2003 UTC (20 years ago) by uebayasi
Branch: MAIN
Changes since 1.12: +2 -2 lines
Diff to previous 1.12 (colored)

Buildlink bin/g-wrap-config too.

Revision 1.12 / (download) - annotate - [select for diffs], Tue Jan 7 03:56:20 2003 UTC (20 years, 1 month ago) by uebayasi
Branch: MAIN
Changes since 1.11: +2 -2 lines
Diff to previous 1.11 (colored)

Rename older (<1.6) Guile as guile14.

Packages using Guile now all depend on guile14.  These packages are
expected to be made depend on newer Guile (1.6.x) when updated in the
future.

Revision 1.11 / (download) - annotate - [select for diffs], Tue Sep 24 09:53:18 2002 UTC (20 years, 4 months ago) by jlam
Branch: MAIN
Changes since 1.10: +2 -2 lines
Diff to previous 1.10 (colored)

buildlink1 -> buildlink2

Revision 1.10 / (download) - annotate - [select for diffs], Tue Sep 24 09:48:51 2002 UTC (20 years, 4 months ago) by jlam
Branch: MAIN
Changes since 1.9: +7 -4 lines
Diff to previous 1.9 (colored)

buildlink1 -> buildlink2

Revision 1.9 / (download) - annotate - [select for diffs], Wed Aug 21 00:21:56 2002 UTC (20 years, 5 months ago) by mjl
Branch: MAIN
Changes since 1.8: +2 -2 lines
Diff to previous 1.8 (colored)

Update g-wrap to 1.2.1. Changes are built-time tweaks only and a
version number bump. 1.2.x is required for gnucash.

Revision 1.8 / (download) - annotate - [select for diffs], Wed Dec 19 10:00:25 2001 UTC (21 years, 1 month ago) by agc
Branch: MAIN
CVS Tags: pkgviews-base, pkgviews, netbsd-1-6-RELEASE-base, netbsd-1-6, netbsd-1-5-PATCH003, buildlink2-base, buildlink2
Changes since 1.7: +2 -2 lines
Diff to previous 1.7 (colored)

Fix typo

Revision 1.7 / (download) - annotate - [select for diffs], Wed Oct 3 09:10:23 2001 UTC (21 years, 4 months ago) by jlam
Branch: MAIN
Changes since 1.6: +2 -2 lines
Diff to previous 1.6 (colored)

Use a wildcard dependency on guile-slib, and depend on the latest one as it
has a proper version number.

Revision 1.6 / (download) - annotate - [select for diffs], Sat Jul 14 13:54:55 2001 UTC (21 years, 6 months ago) by wiz
Branch: MAIN
Changes since 1.5: +2 -2 lines
Diff to previous 1.5 (colored)

Replace dependency on guile with dependency on guile-slib, since that
is required, and depends on guile itself. Closes pkg/13372.

Revision 1.5 / (download) - annotate - [select for diffs], Sun Jul 1 15:12:44 2001 UTC (21 years, 7 months ago) by tron
Branch: MAIN
Changes since 1.4: +7 -7 lines
Diff to previous 1.4 (colored)

Update "g-wrap" package to version 1.1.10. A very extensive list of
changes is available in the "ChangeLog" file.

Revision 1.4 / (download) - annotate - [select for diffs], Thu May 31 10:07:59 2001 UTC (21 years, 8 months ago) by dent
Branch: MAIN
Changes since 1.3: +2 -2 lines
Diff to previous 1.3 (colored)

Fix dead HOMEPAGE.

Revision 1.3 / (download) - annotate - [select for diffs], Fri Feb 16 14:38:24 2001 UTC (21 years, 11 months ago) by wiz
Branch: MAIN
CVS Tags: netbsd-1-5-PATCH001
Changes since 1.2: +2 -1 lines
Diff to previous 1.2 (colored)

Update to new COMMENT style: COMMENT var in Makefile instead of pkg/COMMENT.

Revision 1.2 / (download) - annotate - [select for diffs], Tue Aug 15 02:18:46 2000 UTC (22 years, 5 months ago) by jlam
Branch: MAIN
CVS Tags: netbsd-1-5-RELEASE, netbsd-1-4-PATCH003
Changes since 1.1: +5 -4 lines
Diff to previous 1.1 (colored)

Update g-wrap to 0.9.5.  Changes from version 0.9.4 include not using
deprecated smob functions not present anymore in guile-1.4 and up.

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Mon Jun 26 16:57:07 2000 UTC (22 years, 7 months ago) by rh
Branch: TNF
CVS Tags: pkgsrc-base
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Initial import of g-wrap-0.9.4, a tool for importing types, functions, and
constants into guile.

Revision 1.1 / (download) - annotate - [select for diffs], Mon Jun 26 16:57:07 2000 UTC (22 years, 7 months ago) by rh
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>