File:  [cvs.NetBSD.org] / pkgsrc / devel / exctags / Makefile
Revision 1.16: download - view: text, annotated - select for diffs
Sat Mar 4 21:29:14 2006 UTC (18 years, 9 months ago) by jlam
Branches: MAIN
CVS tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1, HEAD
Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile,v 1.16 2006/03/04 21:29:14 jlam Exp $
#

DISTNAME=	ctags-5.5.4
PKGNAME=	ex${DISTNAME}
CATEGORIES=	devel
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=ctags/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://ctags.sourceforge.net/
COMMENT=	Exuberant (feature-filled) tagfile generator for vi, emacs and clones

PKG_INSTALLATION_TYPES=	overwrite pkgviews

GNU_CONFIGURE=		yes
CONFIGURE_ARGS+=	--enable-macro-patterns
CONFIGURE_ARGS+=	--with-readlib
CONFIGURE_ARGS+=	--enable-custom-config=${PKG_SYSCONFDIR}/ctags.conf

CPPFLAGS+=		-DETAGS="\"exetags\""

SUBST_CLASSES+=		man
SUBST_STAGE.man=	post-patch
SUBST_FILES.man=	ctags.1
SUBST_SED.man=	\
	-e 's|^ctags \\-|exctags \\-|' \
	-e 's|fBctags|fBexctags|g' \
	-e 's|fBetags|fBexetags|g' \
	-e 's|"ctags|"exctags|g' \
	-e 's|"etags|"exetags|g' \
	-e 's|/usr/local|${LOCALBASE}|g'

SUBST_CLASSES+=		rename
SUBST_STAGE.rename=	post-patch
SUBST_FILES.rename=	c.c eiffel.c general.h lregex.c lua.c main.c \
			options.c parse.c routines.c
SUBST_SED.rename=	-e 's|__unused__|__unused_|g'

.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>