[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / distccmon-gnome

File: [cvs.NetBSD.org] / pkgsrc / devel / distccmon-gnome / Attic / Makefile (download)

Revision 1.50, Fri Apr 25 16:13:32 2014 UTC (9 years, 11 months ago) by adam
Branch: MAIN
Changes since 1.49: +3 -4 lines

distcc-3.2 "Back in black"  2011-10-11

FEATURES:
 * IPv6 support
 * Optional support for GSS-API authentication
 * Added an environment variable DISTCC_SKIP_LOCAL_RETRY for skipping
   the local retry in case of a remote compilation failure
 * Some constants that were previously hard-coded in the
   sources are now configurable via environment variables:
   DISTCC_MAX_DISCREPANCY, DISTCC_IO_TIMEOUT

BUG FIXES:
 * Fixed the following 20 issues <http://code.google.com/p/distcc/issues/list>:

   30: 3.0 on OSX: ValueError: Expected absolute path, but got '(framework'.
   33: distcc --scan-includes dumps core
   34: Zeroconf fails if avahi supports IPv6
   35: Include server internal error: '<class 'sre_constants.error'>: ('bogus escape (end of line)',)'
   36: distcc-mon-gnome displays multiple rows for same host/slot
   39: build with gcc 4.1 snprintf.h error "expected declaration specifiers"
   42: distcc --show-hosts fails when using Avahi with IPv6 support and +zeroconf for distcc.
   43: Remove duplicate hosts from zeroconf list
   44: Failed tests on make check (gentoo gcc-4.3.3)
   46: Add TAGS target to Makefile.in
   49: make check fails on PreprocessAsm_Case
   57: Fix warnings
   58: PUMP mode can`t PARSE the HOSTS
   60: CPlusPlus test case fails with GCC 4.4.1
   61: Gdb tests fail in pumped mode on Ubuntu 9.10 amd64
   66: pump mode fails to compile certain KDE-4 packages, finds/looks for incorrect headers
   70: variable overlapping causing errors..
   75: include_server documentation, distcc_fallback flag incorrect
   81: distcc 3.1 will not compile correctly with current version of gcc

# $NetBSD: Makefile,v 1.50 2014/04/25 16:13:32 adam Exp $

PKGNAME=	${DISTNAME:S/-/-gnome-/:S/rc1//}
CATEGORIES+=	gnome
COMMENT=	Graphical monitor for distcc, the distributed C/C++ compiler

.include "../../devel/distcc/Makefile.common"

USE_TOOLS+=		pkg-config
CONFIGURE_ARGS+=	--with-gnome

BUILD_TARGET=		distccmon-gnome
INSTALLATION_DIRS+=	share/distcc

do-install:
	${INSTALL_PROGRAM} ${WRKSRC}/distccmon-gnome ${DESTDIR}${PREFIX}/bin
	${INSTALL_DATA} ${WRKSRC}/gnome/distccmon-gnome-icon.png \
		${DESTDIR}${PREFIX}/share/distcc
	${INSTALL_DATA} ${WRKSRC}/gnome/distccmon-gnome.desktop \
		${DESTDIR}${PREFIX}/share/distcc

.include "../../devel/libgnome/buildlink3.mk"
.include "../../devel/libgnomeui/buildlink3.mk"
.include "../../devel/pango/buildlink3.mk"
.include "../../net/avahi/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"