[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / cvsync

File: [cvs.NetBSD.org] / pkgsrc / devel / cvsync / Makefile (download)

Revision 1.9, Fri Mar 14 17:11:12 2003 UTC (21 years, 1 month ago) by gehenna
Branch: MAIN
Changes since 1.8: +2 -2 lines

cvsync-0.14.5 is out

ChangeLog:

2003-03-15  MAEKAWA Masahide  <maekawa@daemon-systems.org>

        * 0.14.5 is out

        * Scanfile (client)
          Even if very deep unnecessary directories exist on the local disk,
          works properly.

        * doc/FAQ
          Add one item.

                Q. How do I compile/install your tools?
                A. Just type 'gmake'/'gmake install'.

2003-03-11  MAEKAWA Masahide  <maekawa@daemon-systems.org>

        * sock_select @ common/network.c
          Wake up the server listening thread in every seconds.

        * Signal Handling (server)
          If SIGINT or SIGTERM is received, reject new connections and
          the finialization procedure will be deferred until all running
          cvsync threads are done.

        * Signal Handling (client) - well known bug
          If SIGINT or SIGTERM is received, never stop. Please issue SIGKILL.

# $NetBSD: Makefile,v 1.9 2003/03/14 17:11:12 gehenna Exp $
#

DISTNAME=	cvsync-0.14.5
CATEGORIES=	devel
MASTER_SITES=	http://www.daemon-systems.org/cvsync/
EXTRACT_SUFX=	.tgz

MAINTAINER=	gehenna@NetBSD.ORG
HOMEPAGE=	http://www.daemon-systems.org/cvsync/
COMMENT=	portable incremental cvs repository syncer

USE_BUILDLINK2=	YES
USE_PKGINSTALL=	YES
USE_GMAKE=	YES

MAKE_ENV+=	PTHREAD_TYPE=${PTHREAD_TYPE}

EGDIR=		${PREFIX}/share/examples/cvsync
CONF_FILES+=	${EGDIR}/cvsync.conf ${PKG_SYSCONFDIR}/cvsync.conf

post-install:
	${INSTALL_DATA_DIR} ${EGDIR}
	${INSTALL_DATA} ${WRKSRC}/samples/cvsync.conf ${EGDIR}
	${INSTALL_DATA} ${WRKSRC}/samples/cvsyncd.conf ${EGDIR}

.include "../../mk/pthread.buildlink2.mk"
.include "../../mk/bsd.pkg.mk"