[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / cvsgraph

File: [cvs.NetBSD.org] / pkgsrc / devel / cvsgraph / Makefile (download)

Revision 1.22, Thu Dec 29 06:21:37 2005 UTC (18 years, 3 months ago) by jlam
Branch: MAIN
Changes since 1.21: +1 -2 lines

Remove USE_PKGINSTALL from pkgsrc now that mk/install/pkginstall.mk
automatically detects whether we want the pkginstall machinery to be
used by the package Makefile.

# $NetBSD: Makefile,v 1.22 2005/12/29 06:21:37 jlam Exp $
#

DISTNAME=	cvsgraph-1.5.1
CATEGORIES=	devel
MASTER_SITES=	http://www.akhphd.au.dk/~bertho/cvsgraph/release/

MAINTAINER=	adrianp@NetBSD.org
HOMEPAGE=	http://www.akhphd.au.dk/~bertho/cvsgraph/
COMMENT=	Graphically represents CVS/RCS branches and file revisions

USE_TOOLS+=		lex
GNU_CONFIGURE=		YES
CONFIGURE_ARGS+=	--sysconfdir=${PKG_SYSCONFDIR:Q}

DOCDIR=		${PREFIX}/share/doc/${PKGBASE}
EGDIR=		${PREFIX}/share/examples/${PKGBASE}
CONF_FILES=	${EGDIR}/cvsgraph.conf ${PKG_SYSCONFDIR}/cvsgraph.conf
PLIST_SUBST+=	PKGBASE=${PKGBASE:Q}

BUILD_TARGET=	cvsgraph

SUBST_CLASSES+=		man
SUBST_STAGE.man=	pre-install
SUBST_FILES.man= 	cvsgraph.1
SUBST_SED.man=		-e "s|/usr/local/etc|${PKG_SYSCONFDIR}|g"
SUBST_MESSAGE.man=	"Fixing man page paths."

INSTALLATION_DIRS=	bin man/man1 man/man5

do-install:
	${INSTALL_PROGRAM} ${WRKSRC}/cvsgraph ${PREFIX}/bin
	${INSTALL_MAN} ${WRKSRC}/cvsgraph.1 ${PREFIX}/man/man1/
	${INSTALL_MAN} ${WRKSRC}/cvsgraph.conf.5 ${PREFIX}/man/man5

	${INSTALL_DATA_DIR} ${DOCDIR}
	${INSTALL_DATA} ${WRKSRC}/README ${DOCDIR}
	${INSTALL_DATA} ${WRKSRC}/LICENSE ${DOCDIR}

	${INSTALL_DATA_DIR} ${EGDIR}
	${INSTALL_DATA} ${WRKSRC}/cvsgraph.conf ${EGDIR}

.include "../../graphics/gd/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"