[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / cvise

File: [cvs.NetBSD.org] / pkgsrc / devel / cvise / Makefile (download)

Revision 1.1, Fri Jul 23 11:30:16 2021 UTC (2 years, 8 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3

devel/cvise: import cvise-2.3.0

C-Vise is a super-parallel Python port of the C-Reduce. The port
is fully compatible to the C-Reduce and uses the same efficient
LLVM-based C/C++ reduction tool named clang_delta.

C-Vise is a tool that takes a large C, C++ or OpenCL program that
has a property of interest (such as triggering a compiler bug) and
automatically produces a much smaller C/C++ or OpenCL program that
has the same property. It is intended for use by people who discover
and report bugs in compilers and other tools that process C/C++ or
OpenCL code.

# $NetBSD: Makefile,v 1.1 2021/07/23 11:30:16 wiz Exp $

DISTNAME=	cvise-2.3.0
CATEGORIES=	devel
MASTER_SITES=	${MASTER_SITE_GITHUB:=marxin/}
GITHUB_TAG=	v${PKGVERSION_NOREV}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://github.com/marxin/cvise
COMMENT=	Super-parallel Python port of the C-Reduce
LICENSE=	modified-bsd

DEPENDS+=	${PYPKGPREFIX}-pebble-[0-9]*:../../devel/py-pebble
DEPENDS+=	${PYPKGPREFIX}-psutil-[0-9]*:../../sysutils/py-psutil

.include "../../mk/bsd.prefs.mk"

.if ${OPSYS} != "NetBSD"
DEPENDS+=	unifdef-[0-9]*:../../devel/unifdef
.endif
TEST_DEPENDS+=	${PYPKGPREFIX}-test-[0-9]*:../../devel/py-test

USE_CMAKE=	yes
CONFIGURE_DIRS=	build
CMAKE_ARG_PATH=	..

USE_LANGUAGES=	c c++
USE_TOOLS+=	flex
#TEST_TARGET=	check

REPLACE_PYTHON+=	cvise.py
REPLACE_PYTHON+=	cvise-delta.py

pre-configure:
	${MKDIR} ${WRKSRC}/build

.include "../../lang/python/application.mk"
.include "../../lang/clang/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"