[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / cutter

File: [cvs.NetBSD.org] / pkgsrc / devel / cutter / Makefile (download)

Revision 1.35, Wed Jan 1 11:52:11 2014 UTC (10 years, 3 months ago) by wiz
Branch: MAIN
Changes since 1.34: +2 -2 lines

Recursive PKGREVISION bump for libgcrypt-1.6.0 shlib major bump.

# $NetBSD: Makefile,v 1.35 2014/01/01 11:52:11 wiz Exp $
#

DISTNAME=	cutter-1.2.2
PKGREVISION=	11
CATEGORIES=	devel
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=cutter/}

MAINTAINER=	obache@NetBSD.org
HOMEPAGE=	http://cutter.sourceforge.net/
COMMENT=	Unit Testing Framework for C and C++
LICENSE=	gnu-lgpl-v3

GNU_CONFIGURE=	yes
USE_LIBTOOL=	yes
USE_TOOLS+=	gmake intltool pkg-config xgettext msgmerge msgfmt
USE_LANGUAGES=	c c++
USE_PKGLOCALEDIR=	yes

PKGCONFIG_OVERRIDE+=	cppcutter.pc.in
PKGCONFIG_OVERRIDE+=	cutter.pc.in
PKGCONFIG_OVERRIDE+=	gcutter.pc.in
PKGCONFIG_OVERRIDE+=	gdkcutter-pixbuf.pc.in
PKGCONFIG_OVERRIDE+=	libcutter.pc.in
PKGCONFIG_OVERRIDE+=	soupcutter.pc.in

TEST_TARGET=	check

.include "options.mk"

.include "../../mk/compiler.mk"
# XXX: PR#lib/39986?
.if !empty(PKGSRC_COMPILER:Mgcc)
LDFLAGS.NetBSD+=	-lgcc_s
.endif

BUILDLINK_API_DEPENDS.glib2+=	glib2>=2.16.0
.include "../../devel/glib2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"