File:  [cvs.NetBSD.org] / pkgsrc / devel / cutter / Makefile
Revision 1.24: download - view: text, annotated - select for diffs
Sat Jan 26 21:37:19 2013 UTC (11 years, 10 months ago) by adam
Branches: MAIN
CVS tags: HEAD
Revbump after graphics/jpeg and textproc/icu

# $NetBSD: Makefile,v 1.24 2013/01/26 21:37:19 adam Exp $
#

DISTNAME=	cutter-1.2.2
PKGREVISION=	1
CATEGORIES=	devel
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=cutter/}

MAINTAINER=	obache@NetBSD.org
HOMEPAGE=	http://cutter.sourceforge.net/
COMMENT=	Unit Testing Framework for C and C++
LICENSE=	gnu-lgpl-v3

GNU_CONFIGURE=	yes
USE_LIBTOOL=	yes
USE_TOOLS+=	gmake intltool pkg-config xgettext msgmerge msgfmt
USE_LANGUAGES=	c c++
USE_PKGLOCALEDIR=	yes

PKGCONFIG_OVERRIDE+=	cppcutter.pc.in
PKGCONFIG_OVERRIDE+=	cutter.pc.in
PKGCONFIG_OVERRIDE+=	gcutter.pc.in
PKGCONFIG_OVERRIDE+=	gdkcutter-pixbuf.pc.in
PKGCONFIG_OVERRIDE+=	libcutter.pc.in
PKGCONFIG_OVERRIDE+=	soupcutter.pc.in

TEST_TARGET=	check

.include "options.mk"

# XXX: PR#lib/39986?
LDFLAGS.NetBSD+=	-lgcc_s

BUILDLINK_API_DEPENDS.glib2+=	glib2>=2.16.0
.include "../../devel/glib2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>