[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / cproto

File: [cvs.NetBSD.org] / pkgsrc / devel / cproto / Makefile (download)

Revision 1.1.1.1 (vendor branch), Sat Oct 25 06:15:38 2008 UTC (15 years, 4 months ago) by bjs
Branch: TNF
CVS Tags: pkgsrc-base, pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4
Changes since 1.1: +0 -0 lines

Add cproto-4.7f.  TODO: integrate into pkgsrc compiler infrastructure?

Cproto is a program that generates function prototypes and variable
declarations from C source code.  It can also convert function definitions
between the old style and the ANSI C style.  This conversion overwrites the
original files, so make a backup copy of your files in case something goes
wrong.

The program isn't confused by complex function definitions as much as other
prototype generators because it uses a yacc generated parser.  By ignoring all
the input between braces, I avoided implementing the entire C language grammar.

# $NetBSD: Makefile,v 1.1.1.1 2008/10/25 06:15:38 bjs Exp $
#

.include "Makefile.version"

DISTNAME=	cproto
PKGNAME=	cproto-${CPROTO_VERSION}
CATEGORIES=	devel
MASTER_SITES=	ftp://invisible-island.net/cproto/

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://invisible-island.net/cproto/
COMMENT=	Generates function prototypes from C source

PKG_DESTDIR_SUPPORT=	user-destdir

WRKSRC=		${WRKDIR}/${PKGNAME_NOREV}
GNU_CONFIGURE=	yes
###
### XXX I cannot figure out why it won't build without bash.
###	If you can fix this, please do.
###
USE_TOOLS+=	bash bison flex
CONFIG_SHELL=	${BASH}

INSTALL_MAKE_FLAGS+=	prefix=${DESTDIR:Q}${PREFIX:Q}
INSTALL_MAKE_FLAGS+=	mandir=${DESTDIR:Q}${PREFIX:Q}/${PKGMANDIR:Q}/man1

.include "../../mk/bsd.pkg.mk"