The NetBSD Project

CVS log for pkgsrc/devel/cppcheck/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / cppcheck

Request diff between arbitrary revisions


Default branch: MAIN
Current tag: pkgsrc-2012Q3


Revision 1.4 / (download) - annotate - [select for diffs], Sun May 29 11:52:12 2011 UTC (12 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2
Changes since 1.3: +4 -4 lines
Diff to previous 1.3 (colored)

Update to 1.48. Ok reed except for the cmake dependency :)

Release notes for 1.48

There are no major new features in 1.48. There are more and better
checks.

New check: Wrong usage of ! operator in conditions.  Example: if
(!x == 0) {

New check: Use "throw" without arguments to rethrow exceptions.

New check: Comparison of substring with string literal will
always/never match because size doesn't match.

New check: Postfix increment of boolean

New check: Clarify condition with parantheses (when there are
assignment + comparison) Example: if (a = b > 0) {


Release notes for 1.47

It is now possible to exclude files and folders from the analysis.
Use -i on the command line (i=ignore).

Custom rules can now be created using regular expressions. To read
more about creating custom rules, see
http://sourceforge.net/projects/cppcheck/files/Articles/

A new XML format is launched. To use this format, the --xml-version=2
is used. The new xml format is incompatible with the xml format
used in previous versions. The old XML format will still be used
unless --xml-version=2 is given, so your existing scripts, tools
and plugins should still work.

New check: sizeof used on array variable that is a function parameter.
The expected bahaviour is most likely that the sizeof result is
the size of the array, but the actual sizeof result is the size of
the pointer.

New check: catching exception by value. It is better to catch by
reference for various reasons.

New check: memset calls filling 0 bytes. The given size might be
wrong.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>