The NetBSD Project

CVS log for pkgsrc/devel/cppcheck/PLIST

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / cppcheck

Request diff between arbitrary revisions


Default branch: MAIN
Current tag: pkgsrc-2016Q1


Revision 1.5 / (download) - annotate - [select for diffs], Fri May 8 19:35:33 2015 UTC (8 years, 11 months ago) by bsiegert
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2
Changes since 1.4: +4 -1 lines
Diff to previous 1.4 (colored)

Update cppcheck to 1.69. Patch from Jonathan Buschmann in PR pkg/49885.

General changes:
- Added flag --platform=native, when it is used type sizes and behaviour of
  host system are used
- Backward compatibility for Libary files is now working. Future cppcheck
  versions will be able to use libraries written for previous versions
- Windows 32 bit builds now set /LARGEADDRESSAWARE, so that they can use up to
  4 GiB

New checks:
- Detect bad bitmask checks (usage of | where & should be used)
- Suggest usage of "explicit" for constructors with a single parameter
- Suggest usage of make_shared/make_unique
- Warn about usage of malloc with auto_ptr
- Detect redundant pointer operations like &*ptr

Improvements:
- Support std::array (C++11)
- Detect same expressions in both branches of a ternary operator
- New <container>-tags in libraries to configure STL (and similar) container
  types
- Several improvements to ValueFlow analysis (for example support for default
  function arguments)
- Improved buffer overrun and memory leak checking
- Removed a bunch of redundant checking code
- Removed several simplifications
- Stronger matching of library functions
- Lots of additions to std.cfg and posix.cfg
- New library for Microsoft SAL (microsoft_sal.cfg)
- Improved C++11 template parsing (">>" as closing brackets, variadic
  templates)
- Added statistics to htmlreport

GUI:
- Fixed language selection

Additionally, lots of false positives and bugs have been fixed and several
existing checks have been improved.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>