The NetBSD Project

CVS log for pkgsrc/devel/coccinelle/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / coccinelle

Request diff between arbitrary revisions


Default branch: MAIN
Current tag: pkgsrc-2013Q4


Revision 1.11 / (download) - annotate - [select for diffs], Tue Jun 11 14:03:19 2013 UTC (10 years, 10 months ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2
Changes since 1.10: +4 -4 lines
Diff to previous 1.10 (colored)

Update to 1.0.0rc17

Changelog:
Features:
- Try to do better pretty printing when array elements are individually
  replaced
- Just fail quietly on attempt to remove a multi-variable declaration,
  allowing the semantic patch to continue.  A warning message is printed.
- Ignore unknown identifiers around known types.
- Ignore --use-glimpse if multiple directories given
- Added support for c++ namespace syntax in cocci files.
- Improved c++ parsing
- Addition of gcc min and max operators.  Thanks to Holden Karau

Bugfix:
- use arg_expression for printing iterator arguments instead of expression,
  to get the right spacing.  Thanks to Lars-Peter Clausen for the fix.
- Better spacing for generated argument lists.  Thanks to Lars-Peter Clausen
  for reporting the problem.
- Collect all module interfaces for ocaml scripting in a single
  coccilib.cmi file, with the list of exposed internal modules in
  ocaml/exposed_modules.ml. This simplifies the installation of the
  ocaml version of coccilib, and allows us to specify which modules
  can be accessed by an ocaml script. The coccilib.cmi must either
  reside in $COCCI_DIR/ocaml/ or $COCCI_DIR/ocaml/coccilib/.
- Ocamlbuild-based compilation of coccinelle (experimental). In a
  cleaned repository, use the configure option --enable-ocamlbuild to
  enable it. The Makefiles will then use ocamlbuild.
- Ocamlscripts can access more of coccinelle: the file
  ocaml/exposed_modules.ml specifies which modules are accessible.
- Use arg_expression to print macro arguments.  Thanks to Lars-Peter
  Clausen for the fix.
- Remove some trailing whitespace due to unindent or added if braces.
  Thanks to Eric LeBlond for reporting one of the problems.
- Remove undesired newline after if header when body is a metavariable.
  Thanks to Eric LeBlond for reporting the problem.
- Improve macro expansion to take into account variable numbers of
  arguments
- Don't count macros or ifdefs in counting fields
- Better counting of indent size when indent contains multiple tabs
- Get the right annotation on trailing , that is after a nest.  Requires
  avoiding double processing in transformation_c.ml
- Fixed an issue where an 'Impossible' exception could be raised.
- Fixed an issue where some identifiers were incorrectly interpreted as typedef.
- allow __ at the beginning of a struct or union name
- unparsing with precedence
- Type metavariable should not match a case where there is no type in the
  C code.  Thanks to SF Markus Elfring for pointing out the problem.
- Allow an expression list metavariable to be attached to a parameter list
  metavariable, to allow using the parameter names as an argument list.
  Thanks to Michael Stefaniuc for pointing out the need for this feature.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>