The NetBSD Project

CVS log for pkgsrc/devel/cbindgen/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / cbindgen

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.31 / (download) - annotate - [select for diffs], Sat Sep 16 08:06:23 2023 UTC (9 days, 7 hours ago) by adam
Branch: MAIN
CVS Tags: HEAD
Changes since 1.30: +4 -4 lines
Diff to previous 1.30 (colored)

cbindgen: updated to 0.26.0

0.26.0

Fix swapping of >>= and <<= in constants.
Add support for #[deprecated].
Built-in support for bitflags 2.0.
Support for "C-unwind" ABI.
Generate bindings for non-public extern items if they are #[no_mangle].

Revision 1.30 / (download) - annotate - [select for diffs], Tue Sep 12 03:05:19 2023 UTC (13 days, 12 hours ago) by pin
Branch: MAIN
Changes since 1.29: +7 -7 lines
Diff to previous 1.29 (colored)

devel/cbindgen: update to 0.25.0

Ok from ryoon@ upon successful build of firefox115.

  * Re-release of yanked 0.24.6 as a major release
  * Update MSRV to 1.57
  * Support variadic arguments (`...`) (#805)
  * Add --depfile option (#820)
  * Breaking changes: The `Config` struct now has a private member.

Revision 1.29 / (download) - annotate - [select for diffs], Wed Jul 5 20:33:42 2023 UTC (2 months, 2 weeks ago) by he
Branch: MAIN
Changes since 1.28: +3 -1 lines
Diff to previous 1.28 (colored)

cbindgen: make this build with the newly added NetBSD/riscv64 rust.

(I used the not-yet-committed rust-bin package.)

Replicate the "libc" crate patch from the main rust package.
(A corresponding pull request sent upstream.)
Bump PKGREVISION.

Revision 1.28 / (download) - annotate - [select for diffs], Thu Jun 1 07:55:08 2023 UTC (3 months, 3 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2
Changes since 1.27: +82 -79 lines
Diff to previous 1.27 (colored)

cbindgen: updated to 0.24.6

0.24.6
* Update MSRV to 1.57
* Support variadic arguments (`...`)
* Add --depfile option

0.24.5
* Don't enforce tempfile version.

0.24.4
* Move expand infinite recursion fix
* Add with_cpp_compat to the builder
* Handle never type in return position consistently
* Fix warnings
* Updated documentation

Revision 1.27 / (download) - annotate - [select for diffs], Thu Aug 4 00:54:06 2022 UTC (13 months, 3 weeks ago) by gutteridge
Branch: MAIN
CVS Tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3
Changes since 1.26: +4 -4 lines
Diff to previous 1.26 (colored)

cbindgen: update to 0.24.3

(Required for Firefox 103 builds.)

## 0.24.3

      * Make struct expressions correctly generated through typedefs (#768).

## 0.24.2

      * Make bitfield operators use explicit constructors.

## 0.24.1

      * Add support for unary negation (#765).
      * Make more bitfield operators constexpr (#765).

## 0.24.0

      * Basic const generic support (#759, #760 #762).
      * Suffixes on integer literals are now honored to avoid narrowing (#764).

Revision 1.26 / (download) - annotate - [select for diffs], Mon Jun 6 20:53:06 2022 UTC (15 months, 2 weeks ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2
Changes since 1.25: +112 -130 lines
Diff to previous 1.25 (colored)

cbindgen: Update to 0.23.0

Changelog:
0.23.0:
    Better support for constexpr. (#756)
    constexpr is now enabled by default in C++ mode. You can use const.allow_constexpr=false to revert to previous behavior. (#756)
    Minimum syn version no longer parses old rust code. (#754)

0.22.0:
    Support rename rule for union body members (#751).
    constant: Add support for associated constant expressions (#752).
    Fix regression in CamelCase rename rule (should be lowerCamelCase) (#750).
    enumeration: simplify standard types in variants (#749).
    Avoid generating and writing bindings when called recursively (#747).
    Cython: Omit per-variant tags in unions generated for Rust enums (#748).
    Update various dependencies.

0.21.0:
    Update MSRV to 1.54.0
    Update clap to 3.1.
    Update heck to 0.4.0
    unraw identifiers
    Honor documentation_length in Cython.
    Add documentation_style to with short and full options
    Map RawFd to Int
    Respect remove_underscores config when prefixing name to enum

Revision 1.25 / (download) - annotate - [select for diffs], Tue Oct 26 10:14:22 2021 UTC (22 months, 4 weeks ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4
Changes since 1.24: +51 -51 lines
Diff to previous 1.24 (colored)

archivers: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

Could not be committed due to merge conflict:
devel/py-traitlets/distinfo

The following distfiles were unfetchable (note: some may be only fetched
conditionally):

./devel/pvs/distinfo pvs-3.2-solaris.tgz
./devel/eclipse/distinfo eclipse-sourceBuild-srcIncluded-3.0.1.zip

Revision 1.24 / (download) - annotate - [select for diffs], Thu Oct 7 13:39:17 2021 UTC (23 months, 2 weeks ago) by nia
Branch: MAIN
Changes since 1.23: +1 -51 lines
Diff to previous 1.23 (colored)

devel: Remove SHA1 hashes for distfiles

Revision 1.23 / (download) - annotate - [select for diffs], Tue Aug 24 16:56:09 2021 UTC (2 years, 1 month ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3
Changes since 1.22: +5 -5 lines
Diff to previous 1.22 (colored)

cbindgen: Update to 0.20.0

Changelog:
    Add Builder::with_using_namespaces. (#688)
    Ignore PhantomPinned. (#695)
    Simplify Pin to T. (#697)
    Update --pretty=expanded to -Zunpretty=expanded. (#706)

Revision 1.22 / (download) - annotate - [select for diffs], Mon Apr 26 14:34:41 2021 UTC (2 years, 4 months ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.21: +5 -5 lines
Diff to previous 1.21 (colored)

cbindgen: Update to 0.19.0

Changelog:
    Simplify types in generics (#663)
    Use --profile=check for macro expansion (#671)
    Use exported name to prefix enum variants (#672)
    Fix path attribute handling in inline submodules (#679)
    Fix a stack overflow with some recursive typedefs (#680)

Revision 1.21 / (download) - annotate - [select for diffs], Tue Mar 2 13:10:34 2021 UTC (2 years, 6 months ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1
Changes since 1.20: +5 -5 lines
Diff to previous 1.20 (colored)

cbindgen: Update to 0.18.0

Changelog:
* Simplify types in nested types such as pointed-to types and function signatures (#661)

Revision 1.20 / (download) - annotate - [select for diffs], Sat Feb 6 05:21:49 2021 UTC (2 years, 7 months ago) by ryoon
Branch: MAIN
Changes since 1.19: +5 -5 lines
Diff to previous 1.19 (colored)

cbindgen: Update to 0.17.0

* Split cargo depends into cargo-depends.mk file.

Changelog:
    Add with_parse_extra_bindings to builder. (#645)
    Support NonZero and fix incorrect simplification of Option into ptr. (#647)
    Deal with name conflicts correctly in declaration type resolution. (#651)
    Support pointers to ZSTs. (#656)

Revision 1.19 / (download) - annotate - [select for diffs], Fri Jan 1 12:47:48 2021 UTC (2 years, 8 months ago) by ryoon
Branch: MAIN
Changes since 1.18: +41 -5 lines
Diff to previous 1.18 (colored)

cbindgen: Update to 0.16.0

* Fix HOMEPAGE.

Changelog:
     * Remove artificial restriction on lifetime parameters on enums (#604)
     * Add an option for converting usize/isize into size_t/ptrdiff_t. (#606)
     * Allow controlling the cargo profile used for expansion. (#607)
     * Support wider range of expressions in enum discriminants (#614)
     * Support generation of Cython bindings (#590)
     * Fixed some issues with style=tag and recursive structs (#615)
     * Default C style to Both (as specified in docs) (#615)
     * Fix resolution of path dependencies from certain modules. (#629)
     * Support inlined definitions for tuple variants with a single field in C (#631)

Revision 1.18 / (download) - annotate - [select for diffs], Sun Oct 11 13:04:35 2020 UTC (2 years, 11 months ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2020Q4-base, pkgsrc-2020Q4
Changes since 1.17: +117 -105 lines
Diff to previous 1.17 (colored)

cbindgen: Update to 0.15.0

Changelog:
  * Allow customizing mangling of generic parameters in C (#575)
  * Box<T> simplifies to T* in C (4ce324c)
  * ManuallyDrop<T> and MaubeUninit<T> simplify to T in C, and are opaque in C++ (0076a17)
  * C++ supports a derive-ostream annotation to derive serialization of structs, unions and enums (#582)
  * Large character constants have been fixed on Windows (#586)
  * Constants are now generated for typedefs, etc (#589)
  * The `sort_by` configuration option has been made to work for constants (#587)
  * Default sort order is source order now (sort_by = "None"), and can be changed by the above option (#587)

Revision 1.17 / (download) - annotate - [select for diffs], Mon Sep 28 13:21:03 2020 UTC (2 years, 11 months ago) by ryoon
Branch: MAIN
Changes since 1.16: +5 -5 lines
Diff to previous 1.16 (colored)

cbindgen: Update to 0.14.6

Changelog:
Not available.

Revision 1.16 / (download) - annotate - [select for diffs], Sun Sep 27 15:49:41 2020 UTC (2 years, 11 months ago) by ryoon
Branch: MAIN
Changes since 1.15: +5 -5 lines
Diff to previous 1.15 (colored)

cbindgen: Update to 0.14.6

CHangelog:
Not available.

Revision 1.15 / (download) - annotate - [select for diffs], Tue Aug 25 14:30:39 2020 UTC (3 years, 1 month ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3
Changes since 1.14: +5 -5 lines
Diff to previous 1.14 (colored)

cbindgen: Update to 0.14.4

Changelog:
     * Allow to override the mangling separator (#502)

     * cbindgen now handles better having ZSTs in template parameters, and
       default template parameters (#563).

     * Support for annotating nonnull pointers (#558)

     * Fixed bitflags that overflow a signed integer (#556)

     * Support for wildcard argument names (#550)

     * Support for the never return type, with configurable annotation (#549)

     * Properly reject arrays as function arguments (#540)

Revision 1.14 / (download) - annotate - [select for diffs], Fri Jul 31 01:20:43 2020 UTC (3 years, 1 month ago) by maya
Branch: MAIN
Changes since 1.13: +5 -5 lines
Diff to previous 1.13 (colored)

cbindgen: update to 0.14.3

     * Introduce cbindgen:ignore comment annotation, to allow ignoring items or modules. (#519)
     * Support for casts in constant expressions. (#526)
     * Make a non-fatal error a warning message. (#535)
     * Add a --metadata option to the CLI, to allow passing pre-computed cargo metadata. (#538)

Revision 1.13 / (download) - annotate - [select for diffs], Wed Jun 3 08:53:04 2020 UTC (3 years, 3 months ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2
Changes since 1.12: +13 -5 lines
Diff to previous 1.12 (colored)

cbindgen: Update to 0.14.2

Changelog:
0.14.2
 * Fixed minimal dependency versions. (#507)
 * Add an option to write pragma once. (#511)
 * Fix submodule scanning for implicit Rust 2018 modules. (#512)
 * Fix dependency parsing / scanning to handle target-specific versions. (#513)
 * Use heck for case conversion. (#514)
 * Add support for verbatim content after includes. (#416)
 * Allow to add attributes to most generated functions. (#515)

0.14.1
 * Handle mangling pointers. (#508)
 * Unconditionally generate a return statement in partialeq implementations. (#509)

0.14.0
 * Minor tweak at how [export.exclude] is handled to allow excluding
   generic instantiations in C mode. (#501)
 * Documented cpp_compat option. (#496)
 * Fixed a panic when parsing associated constants for a built-in type. (#494)

0.13.2
   * Constants now have suitable documentation. (#471)
   * Fixed some C warnings by emitting void when there are no arguments. (#470)
   * Avoids reading cargo.toml when not needed, which can cause panics in workspace situations.
   * Only write `default` cases if the switch is not exhaustive. (#475)
   * Some warnings have been refined. (#477)
   * Code generation for static arrays has been fixed. (#479)
   * Opt-in support for constexpr in constants. (#481)
   * Fix C code generation and some warnings when extremely large constants are used. (#490)
   * Proper escaping of enum variants and fields. (#483)
   * Added support for RefCell (as an opaque type) and Cell. (#489)

5a4d74b
ir: escape export_name while writing source of EnumVariant

Revision 1.12 / (download) - annotate - [select for diffs], Fri Mar 6 14:22:14 2020 UTC (3 years, 6 months ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1
Changes since 1.11: +5 -5 lines
Diff to previous 1.11 (colored)

cbindgen: Update to 0.13.1

Changelog:
0.13.1
  * Support #[cfg] on individual enum variants. (#469)

0.13.0
 * Support 'swift_name' attributes on generated functions (#449)
 * Add [export.pre_body] to config (#452)
 * Handle new line in doc attribute (#454)
 * Add support for `Self` in tagged enums, structs and unions (#455, #455, #456)
 * Make sentinel variant respect regular config (#459)
 * Fix layout of tagged enums with size under some configurations (#463)
 * Add an option to allow configuring the order of function names in generated headers (#466)

0.12.2
Not available

Revision 1.11 / (download) - annotate - [select for diffs], Thu Jan 9 14:56:28 2020 UTC (3 years, 8 months ago) by ryoon
Branch: MAIN
Changes since 1.10: +105 -141 lines
Diff to previous 1.10 (colored)

cbindgen: Update to 0.12.1

Changelog:
0.12.1
 * Added support for #[repr*64)] on enums. https://github.com/eqrion/cbindgen/pull/441
 * Added support to generate plain enums instead of enum classes for C++. https://github.com/eqrion/cbindgen/pull/443
 * Fixed dependency resolution with lockfile v2. https://github.com/eqrion/cbindgen/pull/438

0.12.0
 * Added support for #[repr(align)] and #[repr(packed)] on structs and unions. https://github.com/eqrion/cbindgen/pull/431
 * Added support to generate copy-assignment operators for enums. https://github.com/eqrion/cbindgen/pull/434

0.11.1
Not available

0.11.0
 * Made rust char map to uint32_t. https://github.com/eqrion/cbindgen/pull/424

Revision 1.10 / (download) - annotate - [select for diffs], Tue Dec 3 16:29:39 2019 UTC (3 years, 9 months ago) by minskim
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4
Changes since 1.9: +181 -181 lines
Diff to previous 1.9 (colored)

lang/rust/cargo.mk: Remove default DIST_SUBDIR

Some packages using cargo.mk have distfiles not from
crates.io.

Revision 1.9 / (download) - annotate - [select for diffs], Tue Dec 3 15:50:09 2019 UTC (3 years, 9 months ago) by minskim
Branch: MAIN
Changes since 1.8: +181 -201 lines
Diff to previous 1.8 (colored)

devel/cbindgen: Update to 0.10.1

Changes:
     * Initialize struct literal with list-initializer for C++11 standard.
     * Surround namespace with __cplusplus ifdef in cpp_compat mode.
     * Add support for --quiet flag.
     * Map char to char32_t.
     * Improve binding_crate_ref() error message.
     * avoid prematurely returning during expansion.
     * Add support for adding "using namespace" statements.
     * Improved error message for missing config file.
     * Add missing header for char32_t.

Revision 1.8 / (download) - annotate - [select for diffs], Fri Sep 6 02:53:19 2019 UTC (4 years ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3
Changes since 1.7: +25 -25 lines
Diff to previous 1.7 (colored)

Update to 0.9.1

Changelog:
## 0.9.1
     * Various improvements to comment output. https://github.com/eqrion/cbindgen/pull/370 / https://github.com/eqrion/cbindgen/pull/375.
     * Fixed expand when ran from build.rs. https://github.com/eqrion/cbindgen/pull/371
     * More debugging output for expansion. https://github.com/eqrion/cbindgen/pull/383
     * New option to add a default private constructor in C++ tagged enums. https://github.com/eqrion/cbindgen/pull/377
     * Syn and related dependencies updated to 1.0. https://github.com/eqrion/cbindgen/pull/379

Revision 1.7 / (download) - annotate - [select for diffs], Thu Jul 4 13:16:07 2019 UTC (4 years, 2 months ago) by ryoon
Branch: MAIN
Changes since 1.6: +121 -105 lines
Diff to previous 1.6 (colored)

Update to 0.9.0

Changelog:
## 0.9.0
     * Support to generate C headers with C++ compatibility.
       https://github.com/eqrion/cbindgen/pull/349
     * Fix include guard generation when no_includes is set.
       https://github.com/eqrion/cbindgen/pull/352
     * Fix crate parsing order so that types from the binding crate
       are preferred in presence of conflicting names.
       https://github.com/eqrion/cbindgen/pull/355
     * Add extra_bindings option to generate bindings for dependencies.
       https://github.com/eqrion/cbindgen/pull/362
     * Clap dependency is optional now so it's feasible to avoid
       building it if cbindgen is used as a library.
       https://github.com/eqrion/cbindgen/pull/363

Revision 1.6 / (download) - annotate - [select for diffs], Wed May 15 12:24:01 2019 UTC (4 years, 4 months ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2
Changes since 1.5: +5 -5 lines
Diff to previous 1.5 (colored)

Update to 0.8.7

Changelog:
* Support for Rust 2018

Revision 1.5 / (download) - annotate - [select for diffs], Wed May 1 09:24:39 2019 UTC (4 years, 4 months ago) by wiz
Branch: MAIN
Changes since 1.4: +5 -5 lines
Diff to previous 1.4 (colored)

cbindgen: update to 0.8.4.

0.8.4

* Support for package renaming in Cargo.toml
* Improved error messages for |cargo metadata| failures
* Replaced 'test.py' harness with |cargo test|
* Char constants will now be escaped properly
* Visibility of constants will now be respected
* Added a C99 doc comment style

0.8.3

Changes not found.

Revision 1.4 / (download) - annotate - [select for diffs], Fri Mar 15 13:05:55 2019 UTC (4 years, 6 months ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1
Changes since 1.3: +5 -5 lines
Diff to previous 1.3 (colored)

Update to 0.8.2

Changelog:
Not available

Revision 1.3 / (download) - annotate - [select for diffs], Tue Feb 19 22:24:12 2019 UTC (4 years, 7 months ago) by he
Branch: MAIN
Changes since 1.2: +133 -105 lines
Diff to previous 1.2 (colored)

Update to version 0.8.0 (from 0.6.8).
Also upgrade the various rust crates according to new requirements.
Sadly, no change log available upstream that I can find...
(The old version uses an old libc crate, which hasn't been adapted
for NetBSD/aarch64.)

Revision 1.2 / (download) - annotate - [select for diffs], Sat Jan 19 12:49:04 2019 UTC (4 years, 8 months ago) by ryoon
Branch: MAIN
Changes since 1.1: +9 -5 lines
Diff to previous 1.1 (colored)

Update to 0.6.8

Compatible with www/firefox-64.0.2 and upcomming -65.0

Changelog:
Not available.

Revision 1.1 / (download) - annotate - [select for diffs], Sun Nov 4 00:28:01 2018 UTC (4 years, 10 months ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4

devel/cbindgen: import cbindgen-0.6.6

This project can be used to generate C bindings for Rust code. It
is currently being developed to support creating bindings for
WebRender, but has been designed to support any project.

cbindgen-0.6.7 is not compatible with www/firefox-63.0.1.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>