The NetBSD Project

CVS log for pkgsrc/devel/catch2/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / catch2

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.17 / (download) - annotate - [select for diffs], Sat Mar 2 12:47:19 2024 UTC (3 weeks, 5 days ago) by adam
Branch: MAIN
CVS Tags: HEAD
Changes since 1.16: +4 -4 lines
Diff to previous 1.16 (colored)

catch2: updated to 3.5.3

3.5.3

Fixes
* Fixed OOB access when computing filename tag (from the `-#` flag) for file without extension
* Fixed the linking against `log` on Android to be `PRIVATE`
* Fixed `Wuseless-cast` in benchmarking internals

Improvements
* Restored compatibility with VS2017
 * The baseline for Catch2 is still C++14 with some reasonable workarounds for specific compilers, so if VS2017 starts acting up again, the support will be dropped again.
* Suppressed clang-tidy's `bugprone-chained-comparison` in assertions
* Improved the static analysis mode to evaluate arguments to `TEST_CASE` and `SECTION`
 * Clang-tidy should no longer warn about runtime arguments to these macros being unused in static analysis mode.
 * Clang-tidy can warn on issues involved arguments to these macros.
* Added support for literal-zero detectors based on `consteval` constructors
 * This is required for compiling `REQUIRE((a <=> b) == 0)` against MSVC's stdlib.
 * Sadly, MSVC still cannot compile this assertion as it does not implement C++20 correctly.
 * You can use `clang-cl` with MSVC's stdlib instead.
 * If for some godforsaken reasons you want to understand this better, read the two relevant commits: [`dc51386b9fd61f99ea9c660d01867e6ad489b403`](https://github.com/catchorg/Catch2/commit/dc51386b9fd61f99ea9c660d01867e6ad489b403), and [`0787132fc82a75e3fb255aa9484ca1dc1eff2a30`](https://github.com/catchorg/Catch2/commit/0787132fc82a75e3fb255aa9484ca1dc1eff2a30).

Miscellaneous
* Disabled tests for FP random generator reproducibility on non-SSE2 x86 targets
* Modified the in-tree Conan recipe to support Conan 2

Revision 1.16 / (download) - annotate - [select for diffs], Thu Jan 18 09:52:27 2024 UTC (2 months, 1 week ago) by nros
Branch: MAIN
Changes since 1.15: +4 -1 lines
Diff to previous 1.15 (colored)

catch2: make sure catch::isnan() is seen on SunOS

Revision 1.15 / (download) - annotate - [select for diffs], Tue Jan 16 06:23:57 2024 UTC (2 months, 1 week ago) by adam
Branch: MAIN
Changes since 1.14: +4 -4 lines
Diff to previous 1.14 (colored)

catch2: updated to 3.5.2

v3.5.2
Fixed -Wsubobject-linkage in the Console reporter
Fixed adding new CLI Options to lvalue parser using |

Revision 1.14 / (download) - annotate - [select for diffs], Mon Jan 15 09:33:46 2024 UTC (2 months, 1 week ago) by nros
Branch: MAIN
Changes since 1.13: +4 -4 lines
Diff to previous 1.13 (colored)

Update catch2 to version 3.5.1

Pkgsrc-changes:
Catch2 version 3 is API incompatible
with catch2 version 2, the header file names
have changed. Update BUILDLINK_API_DEPENDS
due to this. Catch2 users in pkgsrc will
be updated accordingly.
Install the pkg-config files under
lib/pkgconfig since Catch2 now installs
libraries in libs and the pkg-config
files uses them.
Catch2 is now compiled with C++17 so that
all features are available in the package.
Use cmake/build.mk instead of USE_CMAKE.

Changes from release notes:

3.5.1

Improvements
* Significantly improved performance of the CLI parsing.
  * This includes the cost of preparing the CLI parser,
    so Catch2's binaries start much faster.

Miscellaneous
* Added support for Bazel modules
* Added CMake option to disable the build reproducibility settings
* Added `log` library linking to the Meson build


3.5.0

Improvements
* Introduced `CATCH_CONFIG_PREFIX_MESSAGES` to prefix only logging
  macros
  * This means `INFO`, `UNSCOPED_INFO`, `WARN` and `CAPTURE`.
* Section hints in static analysis mode are now `const`
  * This prevents Clang-Tidy from complaining about
    `misc-const-correctness`.
* `from_range` generator supports C arrays and ranges that require ADL
* Stringification support for `std::optional` now also includes
  `std::nullopt`
* The Console reporter flushes output after writing benchmark runtime
  estimate.
  * This means that you can immediately see for how long the benchmark
    is expected to run.
* Added workaround to enable compilation with ICC 19.1
* Compiling Catch2 for XBox should work out of the box
  * Catch2 should automatically disable getenv when compiled for XBox.
* Compiling Catch2 with exceptions disabled no longer triggers
  `Wunused-function`
* `random` Generators for integral types are now reproducible across
   different platforms
  * Unlike `<random>`, Catch2's generators also support 1 byte integral
    types (`char`, `bool`, ...)
* `random` Generators for `float` and `double` are now reproducible
     across different platform
  * `long double` varies across different platforms too much to be
     reproducible
  * This guarantee applies only to platforms with IEEE 754 floats.

Fixes
* UDL declaration inside Catch2 are now strictly conforming to the
  standard
  * `operator "" _a` is UB, `operator ""_a` is fine. Seriously.
* Fixed `CAPTURE` tests failing to compile in C++23 mode
* Fixed missing include in `catch_message.hpp`
* Fixed `CHECK_ELSE` suppressing failure from uncaught exceptions

Miscellaneous
* The documentation for specifying which tests to run through commandline
  has been completely rewritten
* Fixed installation when building Catch2 with meson
* Fixed `catch_discover_tests` when using custom reporter and `PRE_TEST`
  discovery mode
* `catch_discover_tests` supports multi-config CMake generator in
  `PRE_TEST` discovery mode


3.4.0

Improvements
* `VectorEquals` supports elements that provide only `==` and not `!=`
* Catch2 supports compiling with IAR compiler
* Various small internal performance improvements
* Various small internal compilation time improvements
* XMLReporter now reports location info for INFO and WARN
  * This bumps up the xml format version to 3
* Documented that `SKIP` in generator constructor can be used to handle
  empty generator
* Added experimental static analysis support to `TEST_CASE` and `SECTION`
  macros
  * The two macros are redefined in a way that helps the SA tools reason
    about the possible paths through a test case with sections.
  * The support is controlled by the
    `CATCH_CONFIG_EXPERIMENTAL_STATIC_ANALYSIS_SUPPORT` option and
    autodetects clang-tidy and Coverity.
* `*_THROWS`, `*_THROWS_AS`, etc now suppress warning coming from
  `__attribute__((warn_unused_result))` on GCC
  * Unlike plain `[[nodiscard]]`, this warning is not silenced by
    void cast. WTF GCC?

Fixes
* Fixed `assertionStarting` events being sent after the expr is evaluated
* Errors in `TEST_CASE` tags are now reported nicely

Miscellaneous
* Bunch of improvements to `catch_discover_tests`
  * Added DISCOVERY_MODE option, so the discovery can happen either
    post build or pre-run.
  * Fixed handling of semicolons and backslashes in test names
* meson build can disable building tests
* meson build properly sets meson version 0.54.1 as the minimal supported
  version


3.3.2

Improvements
* Further reduced allocations
  * The compact, console, TAP and XML reporters perform less allocations
    in various cases
  * Removed 1 allocation per entered `SECTION`/`TEST_CASE`.
  * Removed 2 allocations per test case exit, if stdout/stderr is captured
* Improved performance
  * Section tracking is 10%-25% faster than in v3.3.0
  * Assertion handling is 5%-10% faster than in v3.3.0
  * Test case registration is 1%-2% faster than in v3.3.0
  * Tiny speedup for registering listeners
  * Tiny speedup for `CAPTURE`, `TEST_CASE_METHOD`, `METHOD_AS_TEST_CASE`,
    and `TEMPLATE_LIST_TEST_*` macros.
* `Contains`, `RangeEquals` and `UnorderedRangeEquals` matchers now support
   ranges with iterator + sentinel pair
* Added `IsNaN` matcher
  * Unlike `REQUIRE(isnan(x))`, `REQUIRE_THAT(x, IsNaN())`
    shows you the value of `x`.
* Suppressed `declared_but_not_referenced` warning for NVHPC (#2637)

Fixes
* Fixed performance regression in section tracking introduced in v3.3.1
  * Extreme cases would cause the tracking to run about 4x slower
    than in 3.3.0


3.3.1

Improvements
* Reduced allocations and improved performance
  * The exact improvements are dependent on your usage of Catch2.
  * For example running Catch2's SelfTest binary performs 8k less
    allocations.
  * The main improvement comes from smarter handling of `SECTION`s,
    especially sibling `SECTION`s


3.3.0

Improvements

* Added `MessageMatches` exception matcher
* Added `RangeEquals` and `UnorderedRangeEquals` generic range matchers
* Added `SKIP` macro for skipping tests from within the test body
  * All built-in reporters have been extended to handle it properly,
    whether your custom reporter needs changes depends on how it was
    written
  * `skipTest` reporter event **is unrelated** to this, and has been
    deprecated since it has practically no uses
* Restored support for PPC Macs in the break-into-debugger functionality
* Made our warning suppression compatible with CUDA toolkit pre 11.5
* Cleaned out some static analysis complaints


Fixes

* Fixed macro redefinition warning when NVCC was reporting as MSVC
* Fixed throws in generator constructor causing the whole binary to abort
  * Now it just fails the test
* Fixed missing transitive include with libstdc++13


3.2.1

Improvements
* Fix the reworked decomposer to work with older (pre 9) GCC versions
  * **This required more significant changes to properly support C++20,
      there might be bugs.**


3.2.0

Improvements
* Catch2 now compiles on PlayStation
* Added `CATCH_CONFIG_GETENV` compile-time toggle
  * This toggle guards whether Catch2 calls `std::getenv`
    when reading env variables
* Added support for more Bazel test environment variables
  * `TESTBRIDGE_TEST_ONLY` is now supported (#2490)
  * Sharding variables, `TEST_SHARD_INDEX`, `TEST_TOTAL_SHARDS`,
    `TEST_SHARD_STATUS_FILE`, are now all supported
* Bunch of small tweaks and improvements in reporters
  * The TAP and SonarQube reporters output the used test filters
  * The XML reporter now also reports the version of its output format
  * The compact reporter now uses the same summary output as the
    console reporter
* Added support for asserting on types that can only be compared with
  literal 0
  * A canonical example is C++20's `std::*_ordering` types, which cannot
    be compared with an `int` variable, only `0`
  * The support extends to any type with this property, not just the
    ones in stdlib
  * This change imposes 2-3% slowdown on compiling files that are heavy
    on `REQUIRE` and friends
  * **This required significant rewrite of decomposition,
      there might be bugs**
* Simplified internals of matcher related macros
  * This provides about ~2% speed up compiling files that are heavy on
    `REQUIRE_THAT` and friends


Fixes
* Cleaned out some warnings and static analysis issues
  * Suppressed `-Wcomma` warning rarely occurring in templated test cases
  * Constified implementation details in `INFO`
  * Made `MatcherGenericBase` copy constructor const
* Fixed serialization of test filters so the output roundtrips
  * This means that e.g. `./tests/SelfTest "aaa bbb", [approx]` outputs
    `Filters: "aaa bbb",[approx]`


Miscellaneous
* Catch2's build no longer leaks `-ffile-prefix-map` setting  to dependees



3.1.1

Improvements
* Added `Catch::getSeed` function that user code can call to retrieve
  current rng-seed
* Better detection of compiler support for `-ffile-prefix-map`
* Catch2's shared libraries now have `SOVERSION` set


Fixes
* Fixed compilation on Universal Windows Platform
* Fixed compilation on VxWorks
* Fixed compilation on Cygwin
* Remove unused variable in reporter registration
* Fixed some symbol visibility issues with dynamic library on Windows
* Suppressed `-Wuseless-cast` warnings in `REQUIRE_THROWS*` macros
  * This was triggered when the potentially throwing expression
    evaluates to `void`
* Fixed "warning: storage class is not first" with `nvc++`
* Fixed handling of `DL_PATHS` argument to `catch_discover_tests` on MacOS
* Suppressed `*-avoid-c-arrays` clang-tidy warning in `TEMPLATE_TEST_CASE`


Miscellaneous
* Fixed CMake install step for Catch2 build as dynamic library
* Raised minimum CMake version to 3.10
  * Expect the minimum CMake version to increase once more in
    next few releases.
* Added support for building Catch2 with Meson



3.1.0

Improvements
* Improved suppression of `-Wparentheses` for older GCCs
  * Turns out that even GCC 9 does not properly handle
    `_Pragma`s in the C++ frontend.
* Added type constraints onto `random` generator
  * These constraints copy what the standard says for
    the underlying `std::uniform_int_distribution`
* Suppressed -Wunused-variable from nvcc
* Suppressed -Wunused-variable from MinGW
* Added All/Any/NoneTrue range matchers
  * These check that all/any/none of boolean values in a range are true.
* The JUnit reporter now normalizes classnames from C++ namespaces to
  Java-like namespaces
  * This provides better support for other JUnit based tools.
* The Bazel support now understands `BAZEL_TEST` environment variable
  * The `CATCH_CONFIG_BAZEL_SUPPORT` configuration option is also
    still supported.
* Returned support for compiling Catch2 with GCC 5
  * This required removing inherited constructors from Catch2's internals.
  * I recommend updating to a newer GCC anyway.
* `catch_discover_tests` now has a new options for setting library
  load path(s) when running the Catch2 binary


Fixes
* Fixed crash when listing listeners without any registered listeners
* Fixed nvcc compilation error in constructor benchmarking helper
* Catch2's CMakeList supports pre-3.12 CMake again
  * The gain from requiring CMake 3.12 was very minor,
    but y'all should really update to newer CMake


Miscellaneous
* Fixed SelfTest build on MinGW
* The in-repo conan recipe exports the CMake helper
* Added experimental CMake script to showcase using test case
  sharding together with CTest
  * Compared to `catch_discover_tests`, it supports very limited number
    of options and customization
* Added documentation page on best practices when running Catch2 tests
* Catch2 can be built as a dynamic library
  * Note that Catch2 does not have visibility annotations,
    and you are responsible for ensuring correct visibility built
    into the resulting library.



3.0.1

Catch2 now uses statically compiled library as its distribution model.
This also means that to get all of Catch2's functionality in a test file,
you have to include multiple headers.

(Potentially) Breaking changes
* Catch2 now uses statically compiled library as its distribution model
  * Including `catch.hpp` no longer works
* Catch2 now uses C++14 as the minimum support language version
* `ANON_TEST_CASE` has been removed, use `TEST_CASE` with no arguments
  instead
* `--list*` commands no longer have non-zero return code
* `--list-test-names-only` has been removed
  * You should use verbosity-modifiers for `--list-tests` instead
* `--list*` commands are now piped through the reporters
  * The top-level reporter interface provides default implementation
    that works just as the old one
  * XmlReporter outputs a machine-parseable XML
* `TEST_CASE` description support has been removed
  * If the second argument has text outside tags, the text will be ignored.
* Hidden test cases are no longer included just because they don't match an
  exclusion tag
  * Previously, a `TEST_CASE("A", "[.foo]")` would be included by asking for
    `~[bar]`.
* `PredicateMatcher` is no longer type erased.
  * This means that the type of the provided predicate is part of the
    `PredicateMatcher`'s type
* `SectionInfo` no longer contains section description as a member
  * You can still write `SECTION("ShortName", "Long and wordy description")`,
    but the description is thrown away
  * The description type now must be a `const char*` or be implicitly
    convertible to it
* The `[!hide]` tag has been removed.
  * Use `[.]` or `[.foo]` instead.
* Lvalues of composed matchers cannot be composed further
* Uses of `REGISTER_TEST_CASE` macro need to be followed by a
  semicolon
  * This does not change `TEST_CASE` and friends in any way
* `IStreamingReporter::IsMulti` member function was removed
  * This is _very_ unlikely to actually affect anyone, as it was
    default-implemented in the interface, and only used internally
* Various classes not designed for user-extension have been made
  final
  * `ListeningReporter` is now `final`
  * Concrete Matchers (e.g. `UnorderedEquals` vector matcher) are
    now `final`
  * All Generators are now `final`
* Matcher namespacing has been redone
  * Matcher types are no longer in deeply nested namespaces
  * Matcher factory functions are no longer brought into `Catch`
    namespace
  * This means that all public-facing matcher-related functionality
    is now in `Catch::Matchers` namespace
* Defining `CATCH_CONFIG_MAIN` will no longer create main in that TU.
  * Link with `libCatch2Main.a`, or the proper CMake/pkg-config target
  * If you want to write custom main, include `catch2/catch_session.hpp`
* `CATCH_CONFIG_EXTERNAL_INTERFACES` has been removed.
  * You should instead include the appropriate headers as needed.
* `CATCH_CONFIG_IMPL` has been removed.
  * The implementation is now compiled into a static library.
* Event Listener interface has changed
  * `TestEventListenerBase` was renamed to `EventListenerBase`
  * `EventListenerBase` now directly derives from `IStreamingReporter`,
    instead of deriving from `StreamingReporterBase`
* `GENERATE` decays its arguments
  * This means that `str` in `auto str = GENERATE("aa", "bb", "cc");`
    is inferred to `char const*` rather than `const char[2]`.
* `--list-*` flags write their output to file specified by the `-o` flag
* Many changes to reporter interfaces
  * With the exception of the XmlReporter, the outputs of first party
    reporters should remain the same
  * New pair of events were added
  * One obsolete event was removed
  * The base class has been renamed
  * The built-in reporter class hierarchy has been redone
* Catch2 generates a random seed if one hasn't been specified by the user
* The short flag for `--list-tests`, `-l`, has been removed.
  * This is not a commonly used flag and does not need to use up valuable
    single-letter space.
* The short flag for `--list-tags`, `-t`, has been removed.
  * This is not a commonly used flag and does not need to use up valuable
    single-letter space.
* The `--colour` option has been replaced with `--colour-mode` option


Fixes
* The `INFO` macro no longer contains superfluous semicolon
* The `--list*` family of command line flags now return 0 on success
* Various ways of failing a benchmark are now counted and reporter
  properly
* The ULP matcher now handles comparing numbers with different signs
  properly
* Universal ADL-found operators should no longer break decomposition
* Reporter selection is properly case-insensitive
  * Previously it forced lower cased name, which would fail for reporters
    with upper case characters in name
* The cumulative reporter base stores benchmark results alongside
  assertion results
* Catch2's SE handling should no longer interferes with ASan on Windows
* Fixed Windows console colour handling for tests that redirect stdout
* Fixed issue with the `random` generators returning the same value
  over and over again


Other changes
* `CATCH_CONFIG_DISABLE_MATCHERS` no longer exists.
  * If you do not want to use Matchers in a TU, do not include their header.
* `CATCH_CONFIG_ENABLE_CHRONO_STRINGMAKER` no longer exists.
  * `StringMaker` specializations for `<chrono>` are always provided
* Catch2's CMake now provides 2 targets, `Catch2` and `Catch2WithMain`.
  * `Catch2` is the statically compiled implementation by itself
  * `Catch2WithMain` also links in the default main
* Catch2's pkg-config integration also provides 2 packages
  * `catch2` is the statically compiled implementation by itself
  * `catch2-with-main` also links in the default main
* Passing invalid test specifications passed to Catch2 are now
  reported before tests are run, and are a hard error.
* Running 0 tests (e.g. due to empty binary,
  or test spec not matching anything) returns non-0 exit code
  * Flag `--allow-running-no-tests` overrides this behaviour.
  * `NoTests` warning has been removed because it is fully subsumed
     by this change.
* Catch2's compile-time configuration options (`CATCH_CONFIG_FOO`)
  can be set through
  CMake options of the same name
  * They use the same semantics as C++ defines, including the
    `CATCH_CONFIG_NO_FOO` overrides,
    * `-DCATCH_CONFIG_DEFAULT_REPORTER=compact` changes default
      reporter to "compact"
    * `-DCATCH_CONFIG_NO_ANDROID_LOGWRITE=ON` forces android
      logwrite to off
    * `-DCATCH_CONFIG_ANDROID_LOGWRITE=OFF` does nothing
      (the define will not exist)

Revision 1.13 / (download) - annotate - [select for diffs], Mon Oct 17 12:10:39 2022 UTC (17 months, 1 week ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4
Changes since 1.12: +4 -4 lines
Diff to previous 1.12 (colored)

catch2: updated to 2.13.10

v2.13.10

Fixes

Fixed issue with catch_discover_tests when there is multiple of 256 tests
Catch2-provided main and wmain are explicitly marked as __cdecl when compiled with MSVC
Improved break-into-debugger behaviour for ARM Macs. It should now be possible to step execution after the break
Replaced deprecated std::aligned_storage

Revision 1.12 / (download) - annotate - [select for diffs], Sun Oct 9 07:24:47 2022 UTC (17 months, 2 weeks ago) by adam
Branch: MAIN
Changes since 1.11: +4 -4 lines
Diff to previous 1.11 (colored)

catch2: updated to 2.13.9

v2.13.9

Fixed issue with -# (filename-as-tag) flag when __FILE__ expands into filename without directories
Fixed CAPTURE macro not being variadic when disabled through CATCH_CONFIG_DISABLE

Revision 1.11 / (download) - annotate - [select for diffs], Sat Apr 9 18:33:11 2022 UTC (23 months, 2 weeks ago) by bsiegert
Branch: MAIN
CVS Tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2
Changes since 1.10: +4 -4 lines
Diff to previous 1.10 (colored)

catch2: update to 2.13.8

v2.13.8

Fixes

  * Made Approx::operator() const
  * Improved pkg-config files
  * Fixed warning suppression leaking out of Catch2 when compiled with
    clang.exe
  * The macro-generated names for things like TEST_CASE no longer create
    reserved identifiers

Improvements

  * Clang-tidy should no longer warn about missing virtual dispatch in
    FilterGenerator's constructor

v2.13.7

Fixes

  * Added missing <iterator> include in benchmarking.
  * Fixed noexcept build with benchmarking enabled
  * Fixed build for compilers with C++17 support but without C++17 library
    support
  * JUnit only uses 3 decimal places when reporting durations
  * !mayfail tagged tests are now marked as skipped in JUnit reporter output

v2.13.6

Fixes

  * Disabling all signal handlers no longer breaks compilation

Miscellaneous

  * catch_discover_tests should handle escaped semicolon (;) better

v2.13.5

Improvements

  * Detection of MAC and IPHONE platforms has been improved
  * Added workaround for bug in XLC 16.1.0.1
  * Add detection for LCC when it is masquerading as GCC
  * Modified posix signal handling so it supports newer libcs
      + MINSIGSTKSZ was no longer usable in constexpr context.

Fixes

  * Fixed compilation of benchmarking when min and max macros are defined
      + Including windows.h without NOMINMAX remains a really bad idea, don't
        do it

Miscellaneous

  * Catch2WithMain target (static library) is no longer built by default
      + Building it by default was at best unnecessary overhead for people not
        using it, and at worst it caused trouble with install paths
      + To have it built, set CMake option CATCH_BUILD_STATIC_LIBRARY to ON
  * The check whether Catch2 is being built as a subproject is now more
    reliable
      + The problem was that if the variable name used internally was defined
        the project including Catch2 as subproject, it would not be properly
        overwritten for Catch2's CMake.

v2.13.4

Improvements

  * Improved the hashing algorithm used for shuffling test cases
      + TEST_CASEs that differ only in the last character should be properly
        shuffled
      + Note that this means that v2.13.4 gives you a different order of test
        cases than 2.13.3, even given the same seed.

Miscellaneous

  * Deprecated ParseAndAddCatchTests CMake integration
      + It is impossible to implement it properly for all the different test
        case variants Catch2 provides, and there are better options provided.
      + Use catch_discover_tests instead, which uses runtime information about
        available tests.
  * Fixed bug in catch_discover_tests that would cause it to fail when used in
    specific project structures
  * Added Bazel build file
  * Added an experimental static library target to CMake

Revision 1.10 / (download) - annotate - [select for diffs], Tue Oct 26 10:14:22 2021 UTC (2 years, 5 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4
Changes since 1.9: +2 -2 lines
Diff to previous 1.9 (colored)

archivers: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

Could not be committed due to merge conflict:
devel/py-traitlets/distinfo

The following distfiles were unfetchable (note: some may be only fetched
conditionally):

./devel/pvs/distinfo pvs-3.2-solaris.tgz
./devel/eclipse/distinfo eclipse-sourceBuild-srcIncluded-3.0.1.zip

Revision 1.9 / (download) - annotate - [select for diffs], Thu Oct 7 13:39:17 2021 UTC (2 years, 5 months ago) by nia
Branch: MAIN
Changes since 1.8: +1 -2 lines
Diff to previous 1.8 (colored)

devel: Remove SHA1 hashes for distfiles

Revision 1.8 / (download) - annotate - [select for diffs], Mon Nov 9 14:25:55 2020 UTC (3 years, 4 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4
Changes since 1.7: +5 -5 lines
Diff to previous 1.7 (colored)

catch2: update to 2.13.3.

Fixes

    Fixed possible infinite loop when combining generators with section filter (-c option) (#2025)

Miscellaneous

    Fixed ParseAndAddCatchTests not finding TEST_CASEs without tags (#2055, #2056)
    ParseAndAddCatchTests supports CMP0110 policy for changing behaviour of add_test (#2057)
        This was the shortlived change in CMake 3.18.0 that temporarily broke ParseAndAddCatchTests

Revision 1.7 / (download) - annotate - [select for diffs], Wed Oct 14 16:20:06 2020 UTC (3 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.6: +5 -5 lines
Diff to previous 1.6 (colored)

catch2: update to 2.13.2.

Improvements

    Implemented workaround for AppleClang shadowing bug (#2030)
    Implemented workaround for NVCC ICE (#2005, #2027)

Fixes

    Fixed detection of std::uncaught_exceptions support under non-msvc platforms (#2021)
    Fixed the experimental stdout/stderr capture under Windows (#2013)

Miscellaneous

    catch_discover_tests has been improved significantly (#2023, #2039)
        You can now specify which reporter should be used
        You can now modify where the output will be written
        WORKING_DIRECTORY setting is respected
    ParseAndAddCatchTests now supports TEMPLATE_TEST_CASE macros (#2031)
    Various documentation fixes and improvements (#2022, #2028, #2034)

Revision 1.6 / (download) - annotate - [select for diffs], Tue Sep 29 10:32:06 2020 UTC (3 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.5: +5 -5 lines
Diff to previous 1.5 (colored)

catch2: update to 2.13.1.

Improvements

    ParseAndAddCatchTests handles CMake v3.18.0 correctly (#1984)
    Improved autodetection of std::byte (#1992)
    Simplified implementation of templated test cases (#2007)
        This should have a tiny positive effect on its compilation throughput

Fixes

    Automatic stringification of ranges handles sentinel ranges properly (#2004)

Revision 1.5 / (download) - annotate - [select for diffs], Fri Jul 31 08:48:23 2020 UTC (3 years, 7 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3
Changes since 1.4: +5 -5 lines
Diff to previous 1.4 (colored)

catch2: update to 2.13.0.

## 2.13.0

### Improvements
* `GENERATE` can now follow a `SECTION` at the same level of nesting (#1938)
  * The `SECTION`(s) before the `GENERATE` will not be run multiple times, the following ones will.
* Added `-D`/`--min-duration` command line flag (#1910)
  * If a test takes longer to finish than the provided value, its name and duration will be printed.
  * This flag is overriden by setting `-d`/`--duration`.

### Fixes
* `TAPReporter` no longer skips successful assertions (#1983)


## 2.12.4

### Improvements
* Added support for MacOS on ARM (#1971)


## 2.12.3

### Fixes
* `GENERATE` nested in a for loop no longer creates multiple generators (#1913)
* Fixed copy paste error breaking `TEMPLATE_TEST_CASE_SIG` for 6 or more arguments (#1954)
* Fixed potential UB when handling non-ASCII characters in CLI args (#1943)

### Improvements
* There can be multiple calls to `GENERATE` on a single line
* Improved `fno-except` support for platforms that do not provide shims for exception-related std functions (#1950)
  * E.g. the Green Hills C++ compiler
* XmlReporter now also reports test-case-level statistics (#1958)
  * This is done via a new element, `OverallResultsCases`

### Miscellaneous
* Added `.clang-format` file to the repo (#1182, #1920)
* Rewrote contributing docs
  * They should explain the different levels of testing and so on much better

Revision 1.4 / (download) - annotate - [select for diffs], Fri Jun 19 10:32:44 2020 UTC (3 years, 9 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2
Changes since 1.3: +5 -5 lines
Diff to previous 1.3 (colored)

catch2: update to 2.12.2.

## 2.12.2

### Fixes
* Fixed compilation failure if `is_range` ADL found deleted function (#1929)
* Fixed potential UB in `CAPTURE` if the expression contained non-ASCII characters (#1925)

### Improvements
* `std::result_of` is not used if `std::invoke_result` is available (#1934)
* JUnit reporter writes out `status` attribute for tests (#1899)
* Suppresed clang-tidy's `hicpp-vararg` warning (#1921)
  * Catch2 was already suppressing the `cppcoreguidelines-pro-type-vararg` alias of the warning

Revision 1.3 / (download) - annotate - [select for diffs], Tue Apr 28 17:31:59 2020 UTC (3 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.2: +5 -5 lines
Diff to previous 1.2 (colored)

catch2: update to 2.12.1.

## 2.12.1

### Fixes
* Vector matchers now support initializer list literals better

### Improvements
* Added support for `^` (bitwise xor) to `CHECK` and `REQUIRE`


## 2.12.0

### Improvements
* Running tests in random order (`--order rand`) has been reworked significantly (#1908)
  * Given same seed, all platforms now produce the same order
  * Given same seed, the relative order of tests does not change if you select only a subset of them
* Vector matchers support custom allocators (#1909)
* `|` and `&` (bitwise or and bitwise and) are now supported in `CHECK` and `REQUIRE`
  * The resulting type must be convertible to `bool`

### Fixes
* Fixed computation of benchmarking column widths in ConsoleReporter (#1885, #1886)
* Suppressed clang-tidy's `cppcoreguidelines-pro-type-vararg` in assertions (#1901)
  * It was a false positive trigered by the new warning support workaround
* Fixed bug in test specification parser handling of OR'd patterns using escaping (#1905)

### Miscellaneous
* Worked around IBM XL's codegen bug (#1907)
  * It would emit code for _destructors_ of temporaries in an unevaluated context
* Improved detection of stdlib's support for `std::uncaught_exceptions` (#1911)

Revision 1.2 / (download) - annotate - [select for diffs], Sun Mar 22 17:55:28 2020 UTC (4 years ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1
Changes since 1.1: +5 -5 lines
Diff to previous 1.1 (colored)

catch2: update to 2.11.3.

## 2.11.3

### Fixes
* Fixed compilation error caused by lambdas in assertions under MSVC


## 2.11.2

### Improvements
* GCC and Clang now issue warnings for suspicious code in assertions (#1880)
  * E.g. `REQUIRE( int != unsigned int )` will now issue mixed signedness comparison warning
  * This has always worked on MSVC, but it now also works for GCC and current Clang versions
* Colorization of "Test filters" output should be more robust now
* `--wait-for-keypress` now also accepts `never` as an option (#1866)
* Reporters no longer round-off nanoseconds when reporting benchmarking results (#1876)
* Catch2's debug break now supports iOS while using Thumb instruction set (#1862)
* It is now possible to customize benchmark's warm-up time when running the test binary (#1844)
  * `--benchmark-warmup-time {ms}`
* User can now specify how Catch2 should break into debugger (#1846)

### Fixes
* Fixes missing `<random>` include in benchmarking (#1831)
* Fixed missing `<iterator>` include in benchmarking (#1874)
* Hidden test cases are now also tagged with `[!hide]` as per documentation (#1847)
* Detection of whether libc provides `std::nextafter` has been improved (#1854)
* Detection of `wmain` no longer incorrectly looks for `WIN32` macro (#1849)
  * Now it just detects Windows platform
* Composing already-composed matchers no longer modifies the partially-composed matcher expression
  * This bug has been present for the last ~2 years and nobody reported it

Revision 1.1 / (download) - annotate - [select for diffs], Mon Feb 3 12:35:13 2020 UTC (4 years, 1 month ago) by bsiegert
Branch: MAIN

New package for Catch2, the successor to devel/catch.

Catch2 is a multi-paradigm test framework for C++. It also supports
Objective-C (and maybe C). It is primarily distributed as a single header file,
although certain extensions may require additional headers.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>