File:  [cvs.NetBSD.org] / pkgsrc / devel / c++gsl / Makefile
Revision 1.4: download - view: text, annotated - select for diffs
Wed Dec 13 11:44:26 2023 UTC (16 months, 1 week ago) by nros
Branches: MAIN
CVS tags: pkgsrc-2025Q1-base, pkgsrc-2025Q1, pkgsrc-2024Q4-base, pkgsrc-2024Q4, pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, HEAD
Update devel/c++gsl to version 4.0.0

Pkgsrc changes:
Use devel/cmake/build.mk
CMake only looks for the c++ compiler so remove c
from USE_LANGAGES.
Due to a breaking change, that gsl/multi_span is not
installed anymore and gsl::narrow is in gsl/narrow not
gsl/util, update BUILDLINK_API_DEPENDS.
Change maintainer, ok'ed by minskim.

Changes from Release Notes:

* Deprecation of gsl::string_span
* Removal of <gsl/multi_span>
* Header files dropped the gsl_ prefix
* Changes to not_null
* gsl::span and std::span now use the correct specialization of gsl::at
* The zstring family no longer requires empty brackets to be used
  - for example, void foo(zstring<> str); should now be
    void foo(zstring str);
* gsl::narrowing_error now has a helpful what() message
* finally and final_action are now [[nodiscard]]
* GSL will work in environments where exceptions are disabled, with
  some caveats
* GSL will work in environments which do not support ios, via the
  addition of the GSL_NO_IOSTREAMS flag
* CMake and build improvements

# $NetBSD: Makefile,v 1.4 2023/12/13 11:44:26 nros Exp $

DISTNAME=	GSL-4.0.0
PKGNAME=	c++${DISTNAME:tl}
CATEGORIES=	devel
MASTER_SITES=	${MASTER_SITE_GITHUB:=Microsoft/}
GITHUB_PROJECT=	GSL
GITHUB_TAG=	v${PKGVERSION_NOREV}

MAINTAINER=	nros@NetBSD.org
HOMEPAGE=	https://github.com/Microsoft/GSL
COMMENT=	C++ Core Guidelines support library
LICENSE=	mit

NO_BUILD=	yes
USE_LANGUAGES+=	c++

USE_CXX_FEATURES+=	c++14

CMAKE_CONFIGURE_ARGS+=	-DGSL_TEST=False

.include "../../devel/cmake/build.mk"

.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>