[BACK]Return to PLIST CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / boost-jam

File: [cvs.NetBSD.org] / pkgsrc / devel / boost-jam / PLIST (download)

Revision 1.3, Sun Jan 22 16:24:29 2023 UTC (14 months ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, HEAD
Changes since 1.2: +1 -2 lines

boost: Update to 1.81.0

Changelog:
Version 1.81.0

New Libraries

  * URL: A library for parsing, modifying, and printing URLs using only C++11,
    from Vinnie Falco and Alan de Freitas. Features include fast compilation,
    strong invariants, and strict compliance using a memory-friendly approach.

Updated Libraries

  * Asio:
      + Added the consign completion token adapter, which can be used to attach
        additional values to a completion handler.
      + Added any_completion_handler<>, which can be used to type-erase
        completion handlers.
      + Added experimental::co_composed to enable lightweight implementations
        of user-defined asynchronous operations using C++20 coroutines.
      + Add range-based experimental::make_parallel_group() overloads.
      + Added any_completion_executor, a type-erased wrapper for executors that
        are associated with completion handlers.
      + Added missing context query to use_future's executor.
      + Added nothrow constructor overloads to execution::any_executor<> and
        any_io_executor.
      + Optimised representation of empty execution::any_executor objects to
        improve the performance of copy and move operations.
      + Added an associated_cancellation_slot specialisation for std::
        reference_wrapper.
      + Changed I/O objects to return their executors by const reference.
      + Changed associated to use deduced return types for all two-argument get
        functions.
      + Fixed spawn implementation to catch unhandled exceptions and rethrow
        them outside of the spawned "thread".
      + Fixed spawn to ensure the completion handler is dispatched through the
        correct executor.
      + Fixed cleanup of of terminal-state spawn "thread" objects.
      + Fixed spawn and co_spawn implementations to dispatch cancellation
        handlers on the correct executor.
      + Changed semantics of 'dispatch' to mean the executor is used as-is.
      + Deprecated the execution::execute customisation point and sender/
        receiver facilities.
      + Added a C++11 parallel_group example.
      + Fixed example code to not use the deprecated resolve conversions.
      + Fixed an ambiguity in experimental::channel_traits specialisations.
      + Added a specialised channel implementation for the for R(error_code)
        signature.
      + Made cancelled() public on the async_compose 'self' object.
      + Added io_executor_type and get_io_executor to the async_compose 'self'
        object.
      + Fixed implementation of release() for Windows overlapped handles.
      + Enabled deferred awaiting for experimental::coro, regularised
        experimental::use_coro, and fixed allocator handling.
      + Cleaned up experimental::promise and made it an asynchronous operation
        object.
      + Constrained post/defer overloads on ability to require blocking.never.
      + Changed descriptor implementation to fall back to fcntl if ioctl fails
        with ENOTTY when setting non-blocking mode.
      + Fixed Xcode deprecation warnings related to use of sprintf.
      + Fixed the arguments passed to select_reactor::run when it is run on an
        internal thread.
      + Fixed compilation errors when BOOST_ASIO_DISABLE_SMALL_BLOCK_RECYCLING
        is defined.
      + Updated detection of C++20 coroutine support on clang 14 and later.
      + Changed standard library feature detection to always enable std::
        invoke_result when targeting C++17 or later.
      + Fixed detection of return type deduction with MSVC.
      + Updated the asynchronous operation requirements to relax the
        requirements on the associated executor.
      + Added io_uring to the implementation notes.
      + Consult the Revision History for further details.
  * Beast:
      + Add buffers_generator
      + Add beast::http::message_generator
      + Added buffer_ref, so beast buffers can be used with asio.
      + Support for per-operation cancellation
      + C++20 awaitable examples.
      + websocket per-message compression options
      + websocket timeout option api
      + multiple content length error
      + Support for default-completion and rebind
  * Container Hash:
      + Major update.
      + The specializations of boost::hash have been removed; it now always
        calls hash_value.
      + Support for BOOST_HASH_NO_EXTENSIONS has been removed. The extensions
        are always enabled.
      + All standard containers are now supported. This includes std::
        forward_list and the unordered associative containers.
      + User-defined containers (types that have begin() and end() member
        functions that return iterators) are now supported out of the box.
      + Described structs and classes (those annotated with
        BOOST_DESCRIBE_STRUCT or BOOST_DESCRIBE_CLASS) are now supported out of
        the box.
      + hash_combine has been improved.
      + The performance (and quality, as a result of the above change) of
        string hashing has been improved. boost::hash for strings now passes
        SMHasher in 64 bit mode.
      + The documentation has been substantially revised to reflect the
        changes.
  * Core:
      + empty_value members are now marked as constexpr.
      + Added fclose_deleter, a deleter that calls std::fclose on a pointer to
        std::FILE.
      + Bit manipulation utilities in boost/core/bit.hpp now explicitly require
        unsigned integers on input. (#129)
      + bit_width now returns int instead of a value of the input argument
        type. This follows resolution of LWG3656.
  * Describe:
      + To allow the inclusion of enumerators.hpp, bases.hpp, and members.hpp
        when the option -pedantic is used, the invocation of
        BOOST_DESCRIBE_ENUM has been moved from modifiers.hpp into a separate
        header, modifier_description.hpp. As a consequence, modifiers.hpp no
        longer includes enum.hpp. Code that has been relying on this implicit
        inclusion may fail, and will need to be fixed to include enum.hpp.
  * DLL:
      + Fixed path_from_handle implementation for Windows platforms, thanks to
        @SaltfishAmi for the bug report 57.
  * Filesystem:
      + Deprecated: path construction, assignment and appending from containers
        of characters, such as std::vector<char> or std::list<wchar_t>, is
        deprecated in v3 and removed in v4. Please use string types or
        iterators instead.
      + Deprecated: boost/filesystem/path_traits.hpp header is deprecated and
        will be removed in a future release. The header contained
        implementation details of path and should not be used in user's code.
      + Previously deprecated APIs will now generate compilation warnings on
        use. To suppress these warnings, BOOST_FILESYSTEM_ALLOW_DEPRECATED
        macro can be defined when compiling user's code.
      + Fixed compilation due to a missing include on POSIX systems that do not
        support *at APIs. (#250)
      + On Windows prior to 10, added a workaround for network share filesystem
        that produces ERROR_INVALID_PARAMETER when constructing directory
        iterators. (PR#246, #245)
      + On Windows, fixed weakly_canonical failing with an
        ERROR_INVALID_FUNCTION error code if the path started with the "\\?\"
        prefix. (#247)
      + Added support for std::string_view, boost::string_view and boost::
        container::string (as well as respective wchar_t counterparts) in path
        constructors, assignment and appending operations. (#208)
      + path constructors, assignment and appending operations taking a pair of
        iterators will no longer accept iterators with value types that are not
        one of the supported path character types.
      + On Windows, improved compatibility of directory_iterator with various
        mounted filesystems and Wine releases prior to 7.21. (#255, #266)
      + On Windows, deduplicated files are now reported as regular files rather
        than reparse files. (#262)
  * Fusion:
      + Added fusion::identity_view (PR#240)
      + Added support for associative sequences on fusion::transform_view (PR#
        239)
      + Fixed compilation for the case when fusion::reverse_view used with an
        associative sequence (PR#237)
      + Fixed Clang 13 -Wdeprecated-copy warnings (PR#261)
      + A small dependency reorganization. Now boost::ref and boost::
        noncopyable are used from Boost.Core (PR#249)
      + Added CI testing on Linux and MacOS for clang and gcc, fixed CI testing
        on Windows (PR#245, PR#236)
      + Improved docs and fixed typos (#234, PR#235, PR#238)
  * Geometry:
      + Solved issues
          o #1048 Index: Fix dangling references when Indexable is returned by
            value by IndexableGetter
          o #1076 Union: in rare cases it might miss one polygon
          o #1081 Union: due to precision it might miss interior rings
      + Bugfixes
          o #1063 Intersection: fix a bug in intersection of simple spherical
            polygons
          o #1064 Formulas: fix a consistency issue in geodesic direct formulas
          o #1088 Point: Fix regression for custom point types
          o Various fixes for missing include files, warnings, C++20
            compilation errors and documentation
  * Histogram:
      + Major update.
      + Added new accumulators::fraction to compute fractions, their variance,
        and confidence intervals
      + Added interval computers for fractions: utility::clopper_pearson,
        utility::wilson_interval, utility::jeffreys_interval, utility::
        wald_interval which can compute intervals with arbitrary confidence
        level
      + Added utility::confidence_level and utility::deviation types to pass
        confidence levels as probabilities or in multiples of standard
        deviation for all interval computers, respectively
      + Fixed internal sub_array and span in C++20
  * Iterator:
      + function_output_iterator now supports perfect forwarding of the
        assigned values to the wrapped function object. (PR#73)
      + Fixed compilation of constructing a function_input_iterator from result
        of post-incrementing another function_input_iterator. (#75)
      + The result of post-incrementing an iterator based on iterator_facade
        now supports operator->. (it++)->foo is equivalent to (*it++).foo,
        which was supported before.
  * JSON:
      + Added object::stable_erase.
      + Added parse overload for std::istream and operator>> for value.
      + Added rvalue ref-qualified accessors for value.
      + Conversion traits were redesigned.
      + Added conversion support for described classes and enums, std::optional
        , std::variant, and null-like types (including std::nullptr_t, std::
        nullopt_t, and std::monotype).
      + Added non-throwing conversion from value to user types.
  * LexicalCast:
      + Fixed compilation while casting volatile arithmetic types. Thanks to
        Giovanni Cerretani for the bug report #50.
      + Removed usage of deprecated headers. Thanks to Michael Ford for the PR
        PR#53.
  * Locale:
      + Major update with some breaking changes.
      + C++11 support is now required, support for C++03 and earlier is dropped
      + Some enums have been converted to enum classes - Avoids name clashes
      + Replace -sICU_LINK_LOCALE & -sICU_LINK by fine-grained configuration
        options as done in Boost.RegEx
      + Fix detection of libiconv allowing Boost.Locale to be build (again) on
        some platforms
      + Remove use of and support for std::auto_ptr
      + Make the codecvt using wchar_t on Windows assume/use UTF-16 enconding
      + Performance improvements: Make basic_format, date_time & hold_ptr
        movable, Fix use of format cache
      + Make Boost.Locale compatible with more ICU versions (especially the
        tests)
      + Fix RTTI definitions for some classes (visibility issues)
      + Fix compatibility of the ICU backend with some libc++ versions
      + Fix return value of some operators to correctly return non-const *this
      + Fix int-overflow on negative roll of years in date_time
      + Handle or suppress many warnings which makes the build log cleaner
      + Add support for more Windows codepages
      + Fix support for Windows codepages like ISO-2022-JP
  * Nowide:
      + Fix build failure of tests on MSVC
  * Stacktrace:
      + The library does not use COM initialization any more. Thanks to Alex
        Guteniev for the bug report, clarifications and PR PR#123!
      + The library now may use BOOST_STACKTRACE_BACKTRACE_INCLUDE_FILE macro
        value while detecting the libbacktrace availability in b2, thanks to
        Ben Gemmill for the bug report #115.
      + Added BOOST_STACKTRACE_BACKTRACE_FORCE_STATIC macro to force a single
        backtrace_state static instance while using the libbacktrace. Thanks to
        the Rasmus Thomsen for the bug report #118!
      + Avoid unresolved references when including only the boost/stacktrace/
        stacktrace.hpp header. Thanks to the Long Deng for the bug report #116.
      + Optimized stacktrace printing by not calling strlen on Windows
        platforms. Thanks to Alex Guteniev for the bug report #122
  * PFR:
      + Improved detection of aggregate initializables in C++14 mode, thanks to
        Denis Mikhailov for the PR PR#97.
      + Suppress clang-tidy warnings, thanks to Alexander Malkov for the PRs PR
        #109, PR#104.
      + Use fold expressions if they are supported by the compiler. Thanks to
        Jean-Micha?l Celerier for the PR PR#96.
  * STLInterfaces:
      + Fix two ill-formed iterator_interface operators in pre-C++20 iterators
        with a const value_type.
  * System:
      + The macro BOOST_SYSTEM_DISABLE_THREADS can now be defined to disable
        the use of <mutex> (e.g. on single-threaded libstdc++).
      + Added value_type, error_type, in_place_value, in_place_error to result
        <>.
      + Added emplace to result<>.
  * Unordered:
      + Major update.
      + Added fast containers boost::unordered_flat_map and boost::
        unordered_flat_set based on open addressing.
      + Added CTAD deduction guides for all containers.
      + Added missing constructors as specified in LWG issue 2713.
  * Variant:
      + Avoid recursive inclusion of headers, thanks to Nathan Sidwell for the
        bug report #101.
      + Removed usage of deprecated headers, thanks to Michael Ford for the PR
        PR#96.
      + Fixed compilation on clang in C++23 mode, thanks to Ed Catmur for the
        PR PR#98.
  * Variant2:
      + Added support for boost::json::value_from and boost::json::value_to.


Version 1.80.0

Known Issues

These are patches from library authors which were found too late to be fixed in
the release.

  * Config
      + Support for libcpp15 which removes std::unary_function and std::
        binary_function. Patch.
  * Filesystem
      + Directory iterators may fail to construct for a network share on
        Windows prior to 10, see PR#246 and #245. Patch.
      + On Windows, weakly_canonical fails to process paths that start with the
        "\\?\" prefix, see #247. Patch.
      + On POSIX systems that don't support *at APIs, compilation fails due to
        a missing include, see #250. Patch.
  * Unordered
      + Containers are not in a valid state after moving, see #139. Patch.
      + Fix MSVC /RTCc build runtime failures. Patch.

New Libraries

  * No new libraries.

Updated Libraries

  * Asio:
      + Added a deduced trailing return type to all asynchronous operations, to
        enable the new form of async_result for C++11.
      + Moved append, prepend, as_tuple, and deferred to the boost::asio
        namespace, and made them compatible with C++11.
      + Made experimental::parallel_group compatible with C++11.
      + Added buffer() overloads for contiguous containers, such as std::span.
      + Added the ability for awaitable<>-based coroutines to directly co_await
        operations that are packaged as function objects.
      + Changed spawn() to be a completion token-based asynchronous operation,
        and added support for cancellation. The basic_yield_context token now
        supports move-only and variadic result types. When targeting C++11 and
        later, spawn() and basic_yield_context are implemented in terms of
        Boost.Context directly.
      + Added the is_async_operation trait and async_operation concept.
      + Added the completion_signature_of trait.
      + Added converting move construction/assignment to posix descriptors,
        serial ports, pipes, Windows object_handle, Windows stream handles, and
        Windows random-access handles.
      + Added release() member functions to pipes, Windows stream handles, and
        Windows random-access handles.
      + Enabled support for Endpoint implementations that return void pointers
        from their data() member functions, as per the documented Endpoint type
        requirements.
      + Removed all() and race() from experimental::promise, as experimental::
        parallel_group covers this functionality.
      + Added source locations to exceptions and error codes produced by the
        synchronous and asynchronous operations.
      + Fixed compatibility with OpenSSL 3.0.4 and later.
      + Fixed compatibility with with -masm=intel.
      + Explicitly stated that socket shutdown() calls are thread-safe with
        respect to certain other synchronous operations on the same socket.
      + Optimised the move construction of I/O objects where only the executor
        type differs.
      + Fixed the detection of std::invoke_result for clang/libc++.
      + Fixed an issue where experimental::parallel_group initiation
        incorrectly moved arguments instead of forwarding them.
      + Fixed a sequencing issue in the implementation of post(), dispatch(),
        and defer().
      + Fixed the awaitable<> implementation to propagate exceptions from
        awaited initiation functions through the current completion handler.
      + Fixed detection of std::aligned_alloc with gcc 7.
      + Changed to avoid using the soon-to-be-deprecated std::aligned_storage
        on newer compilers.
      + Fixed detection of std::aligned_alloc for older Apple platforms.
      + Removed faulty assertions from experimental::coro implementation.
      + Added defence against Qt-defined macros when building with Intel C++.
      + Changed the implementation of the select_reactor, on Windows, to ensure
        that any exception resulting from failure to recreate its interrupter's
        sockets will be allowed to propagate out through io_context::run().
      + Fixed various compiler warnings.
      + Updated all composed operations examples, and the C++11 timeouts
        example, to use the new async_result form.
      + Added composed operation and coroutine examples for C++20.
      + Consult the Revision History for further details.
  * Atomic:
      + Improved portability of endianness checks on ARM, AArch32 and AArch64
        targets. (#59)
      + Fixed compilation with MSVC 14.0 (Visual Studio 2015) in C++17 mode. (#
        61)
  * Filesystem:
      + On Windows, added a fallback implementation for querying file
        attributes in case if the file cannot be opened with
        ERROR_ACCESS_DENIED error. This may allow status and symlink_status to
        succeed for system files and directories that are not reparse points or
        symlinks. (#234)
      + On Windows, added a workaround for FAT/exFAT filesystems that produce
        ERROR_INVALID_PARAMETER when querying file attributes. This affected
        status and symlink_status, which reported that files do not exist, and
        directory iterators, which failed to construct, as well as other
        dependent operations. (#236, #237)
      + Worked around a compilation problem on RTEMS. (PR#240)
      + On Linux, corrected switching to sendfile copy_file implementation if
        copy_file_range failed with ENOSYS in runtime. The sendfile fallback
        implementation used to skip the filesystem type check and could fail
        for some filesystems.
      + On POSIX systems supporting openat and related APIs defined in
        POSIX.1-2008 and on Windows Vista and later, improved protection of
        remove_all against CVE-2022-21658 that was implemented in the previous
        release. The previous fix could still result in removing unintended
        files in certain conditions. Other systems remain vulnerable.
  * GIL: NOTICE: We are planning BREAKING switch to C++17 as minimum required
    C++ language version in one or two releases after Boost 1.80 (#676)
      + Added
          o GSoC 2020: Added Perona-Malik anisotropic diffusion algorithm (PR#
            500)
          o GSoC 2020: Added histogram class and related functionality (PR#499)
          o GSoC 2020: Added histogram equalization feature (PR#514)
          o GSoC 2020: Added histogram matching algorithm (PR#515)
          o GSoC 2020: Added ability to stack images either horizontally (
            hstack) or vertically (vstack) (PR#506)
          o GSoC 2020: Added adaptive histogram equalization algorithm (PR#516)
          o GSoC 2020: Added Standard Hough Transform and circle rasterization
            (PR#512)
          o GSoC 2020: Added Bresenham's algorithm for line rasterization (PR#
            512)
          o GSoC 2021: Added rotation of image by arbitrary angle around its
            center (PR#565)
          o GSoC 2021: Added rasterization support for ellipse based on "An
            Efficient Ellipse-Drawing Algorithm" by Jerry Van Aken (PR#585)
          o Added image constructor from compatible view (PR#520)
          o Added inverse function for affine matrix3x2 (PR#527)
          o Added standard morphological transformations (PR#541)
          o Added for_each_pixel overload for any_image (PR#648)
          o Added C++17 polymorphic memory resource typedefs for image class (
            PR#529)
      + Changed
          o BREAKING: The required minimum C++ version is changed from from
            C++11 to C++14. Currently, large parts of GIL still compile with a
            C++11 compiler. However, there is no guarantee that it stays that
            way, and any compilers that do not support at least C++14 are
            considered unsupported as of now.
          o BREAKING: any_color_converted_view() is deprecated and will be
            removed in the next release. Use color_converted_view() instead,
            which provides the same feature.
          o BREAKING: apply_operation for any_image is deprecated and will be
            removed in the next release. Use variant2::visit instead, which
            provides the same feature. (PR#656)
          o Moved numeric extension to core (PR#573)
          o Added support for C++17's <filesystem> (PR#636) The availability of
            the std::filesystem is detected automatically, unless the
            BOOST_GIL_IO_USE_BOOST_FILESYSTEM macro is defined that forces the
            preference of the Boost.Filesystem.
          o Renamed pixel_multiply_t to pixel_multiplies_t and pixel_divide_t
            to pixel_divides_t (PR#655)
          o Renamed io/dynamic_io_new.hpp to io/detail/dynamic.hpp (PR#653)
          o Moved function construct_matched into boost::gil::detail namespace
            as it was only used by other implementation details (PR#653)
          o Made packed_pixel trivially copyable and assignable (PR#679)
          o Replace deprecated libtiff v4.3 typedefs with C99 fixed-size
            integers (PR#685)
      + Removed
          o BREAKING: Removed support for GCC 5 (PR#572)
          o Removed deprecated.hpp (PR#627)
      + Fixed
          o Fixed conversion from RGB to HSL (PR#505)
          o Fixed conversion from RGB to signed CMYK (PR#522)
          o Removed unnecessary numeric cast in hsv.hpp (PR#530)
          o Fixed default constructor for homogeneous_color_base for reference
            pixel elements (PR#542)
          o Fixed returning reference to local temporary object in
            subchroma_image_view (PR#556)
          o Added missing header guards in diffusion.hpp (PR#568)
          o Fixed any_image_view<>::const_t (PR#526)
          o Fixed C++20 incompatibilities in I/O extensions (PR#617)
          o Ensured all examples build without errors (PR#628)
          o Fixed convolve_2d for images with float32_t channel model (PR#577)
          o Fixed for_each_pixel for non-1d iterable views (PR#621)
          o Fixed: is_equal_to_sixteen in PNG I/O was less-than test (PR#650)
          o Re-allow devicen_t with two components (PR#654) It was
            unintentionally removed in Boost 1.72
          o Fixed memory leak in image class for empty dimensions (PR#649)
      + Acknowledgements
          o Cypre55, Samuel Debionne, Mike-Devel, Edward Diener, Peter Dimov,
            Omar Emara, Dhruva Gole, Nicolas Herry, Eugene K, Avinal Kumar,
            Gaurav Kumar, Marco Langer, Pranam Lashkari, Mateusz ??oskot,
            Giovanni Mascellani, Debabrata Mandal, Gopi Krishna Menon, Ren??
            Ferdinand Rivera Morell, Felix Morgner, Harshit Pant, Paul92, Andr
            ?? Schr?der, Scramjet911, Siddharth, Dirk Stolle, Prathamesh
            Tagore, theroyn, Olzhas Zhumabek
  * Graph:
      + Bug fixes:
          o Fix bug in stoer_wagner_min_cut where vertices are not merged at
            the end of each mincut phase (#286)
          o Fix conversion warning for return type of strong_components (#293)
          o Fix compilation failure of boykov_kolmogorov_max_flow named
            parameter overload (#232)
      + General code improvements:
          o Remove redundant call to combine in astar_search_no_init_tree (#260
            )
          o Remove redundant child_idx argument of d_ary_heap_indirect<>::child
            (#261)
          o Improve documentation for traversal categories (#303)
      + Acknowledgements
          o Viktor Pti, Sebastian Brockmeyer, Etienne dg
  * Histogram:
      + Fixed segfault in indexed when trying to iterate over histogram with
        axes of zero size (physical or logical) under certain conditions
      + Removed previously deprecated API
          o class accumulators::thread_safe: use accumulators::count<T, true>
          o Methods accumulators::sum::large and accumulators::sum::small: use
            accumulators::sum::large_part and accumulators::sum::small_part
          o Type alias algorithm::reduce_option: use algorithm::reduce_command
          o Template function axis::traits::static_options: use axis::traits::
            get_options
          o Template function axis::traits::static_is_inclusive: use axis::
            traits::is_inclusive
          o Type alias indexed::range_iterator: use indexed::iterator
          o Type alias indexed::accessor::reference: use indexed::accessor::
            const_reference
  * Iterator:
      + For C++11 and later, added support for perfect forwarding of values
        written to function_output_iterator. (PR#73)
      + Added protection against writing to function_output_iterator a result
        of dereferencing another function_output_iterator.
  * JSON:
      + Added non-const value::at overloads.
      + Added the ability to manually choose endianness of the platform.
      + Added string::subview() overload.
      + Fixed segfault in array::erase(it).
      + Fixed low performance of serialize on libc++.
      + Fixed ambigious conversion to std::string_view on GCC 8.
      + Fixed parsing on big-endian platforms.
      + Fixed handling of comment after trailing comma.
  * LEAF:
      + API breaking change: throw leaf::exception(....) now becomes
        leaf::throw_exception(....)
      + Fixed a bug in support for a rare build configuration (exception
        handling enabled, diagnostics disabled)
      + Using nullptr instead of 0 throughout
      + Fixed pedantic warnings
  * Locale:
      + Deprecated support for C++03 and earlier, C++11 will be required in the
        next release
      + Provide -sICU_LINK_LOCALE as a temporary replacement for -sICU_LINK
        which is incompatible with Boost.Regex. -sICU_LINK_LOCALE and -
        sICU_LINK are deprecated and will be replaced by ICU_*_NAME options to
        be compatible with Boost.Regex
      + Fix UB/assertion failure in the ICU collator implementation when
        transforming empty strings
      + Fix some issues related to visibility of classes in shared libraries
        (Unix only)
      + Fix compatibility with C++20 mode
      + Fix compatibility with BOOST_USE_WINDOWS_H
      + Fix build failures due to missing includes
      + Handle or suppress many warnings which makes the build log cleaner
  * Log:
      + Bug fixes:
          o Fixed binding incorrect local address in UDP socket-based
            syslog_backend when IPv6 address is used for the syslog server. (#
            181)
          o Added a workaround for a bug in libstdc++ from gcc 11.2. When
            max_size_decor was used on a formatting stream, std::codecvt::
            do_length incorrectly accessed the input buffer and caused a buffer
            overflow.
      + See changelog for more details.
  * Math:
      + Deprecated C++11 support: from 2023 we will require C++14 as a minimum
        standard. This will mean GCC-5 or MSVC-14.1 as a minimal requirement.
      + Add constexpr fma support, see 734.
      + Add support for the Chatterjee Correlation Coefficient, see 770.
      + Added support for the logarithm of the PDF for all the distributions.
      + Improve support for building with no exception or RTTI support.
      + Some minor bug fixes for [sub 1]F[sub 1] corner cases, see 778.
  * Multiprecision:
      + Mark C++11 support as deprecated: from 2023 we will move to requiring
        C++14 as a minimum standard level. That will drop support for GCC
        versions prior to 5 and MSVC prior to 14.1.
      + Fix conflict between boost/cstdfloat.hpp and this library.
      + Clean up lots of gcc and clang warnings.
      + Fix input streaming of composite types (complex, interval rational)
        where there is a trailing delimeter in the stream and no whitespace.
      + Fix constexpr integer square root where the input is 1, 2 or 3.
      + Add missing #include of <memory> to float128.hpp.
      + Correct 2-arg constructor for class number to prevent ambiguity in some
        cases.
      + Correct and make more consistent behaviour of divide-by-zero in
        gmp.hpp.
  * Multi-index Containers:
      + Maintenance work.
  * Nowide:
      + Major performance improvement for Bulk I/O with files
      + basic_filebuf: Fix wrong return value of sync when fflush failed
      + basic_filebuf: Fix possible undefined behavior in a corner case when
        nothing was actually written but buffer is in "write" mode
      + basic_filebuf: Limit putback of characters (i.e. pbackfail) only
        allowing putback of buffered characters (may be only 1 character)
  * Optional:
      + Added specializations for std::hash<boost::optional<T>>. This is a
        breaking change for programs that define such specializations
        themselves. For more details see specs.
  * STLInterfaces:
      + Fix #53: "missing 'typename' prior to dependent type name
        'C::const_iterator'"
      + Fix #54: "Concept check fails on .data() of a view on contiguous
        iterator_interface instantiations"
      + New additions to make it easy to write views and view adaptors that
        work like, and interoperate with, the ones in the standard library:
          o Add workalikes for C++23's std::bind_back() and std::
            range_adaptor_closure for pre-C++23 code.
          o Add templates closure and adaptor to make writing view adaptors
            easier, following the examples in P2387.
  * System:
      + When an error_code is converted to std::error_code and then back to
        error_code, the original is now restored, if possible.
      + Reworked the conversion from error_category to std::error_category to
        avoid the one-time allocation that shows up on leak checkers.
      + Added a constructor that allows replacing the source location of an
        error_code, and a corresponding assign.
      + Added a converting constructor to result.
  * Unordered: Major update:
      + Refactor internal implementation to be dramatically faster
      + Allow final Hasher and KeyEqual objects
      + Update documentation, adding benchmark graphs and notes on the new
        internal data structures
  * Utility:
      + In string_view/string_ref, fixed max_size returning incorrect value. (#
        91)
      + Removed noexcept specifier from string_view::compare as it may throw on
        some input arguments. (#94)
      + In string_view/string_ref, added support for calling substr with no
        arguments. (#96)
      + Added string_view::contains methods that were introduced in C++23. (#93
        )
      + In string_view, added asserts in remove_prefix/remove_suffix methods to
        enforce the precondition that the prefix/suffix length does not exceed
        the string view size. The previous (undocumented) behavior of silently
        clamping the prefix/suffix length is deprecated and will be removed in
        a future release. (#92)
  * Wave: Fixed bugs:
      + #24: Line numbers wrong after conditional section
      + #160: one test fails with error C2660 and error C2440 under msvc /
        permissive- mode
      + #161: BOOST_WAVE_THROW_NAME_CTX does not result in a context callback
        and always throws
      + #162: When Boost headers are included in the preprocessed translation
        unit, Wave fails in boost/integer.hpp(99)

Updated Tools

  * Build:
      + Includes release of B2 version 4.9.2.


Version 1.79.0

Known Issues

These are patches from library authors which were found too late to be fixed in
the release.

  * Boost.JSON array::erase can segfault, see #692. Patch.

New Libraries

  * No new libraries.

Updated Libraries

  * Asio:
      + Added bind_allocator.
      + Added file_base::sync_all_on_write flag.
      + Added missing implementation of basic_file::release().
      + Added per-operation cancellation support to signal sets.
      + Exposed recycling_allocator as part of the public interface.
      + Added the nodiscard attribute to a number of functions.
      + Added OpenSSL 3.0 compatibility.
      + Added support for adopting an existing SSL* into an ssl::stream<>.
      + Enabled executor_work_guard<> in all build configurations.
      + Enabled movable socket iostreams when using clang.
      + Fixed bind_cancellation_slot and bind_executor compatibility with
        legacy completion tokens.
      + Fixed associator specialisations for experimental::append and
        experimental::prepend.
      + Fixed associated_allocator primary template.
      + Fixed io_uring implementations of async_receive_from for sockets and
        write_some_at for files.
      + Fixed io_uring feature detection.
      + Fixed experimental::coro's per-operation cancellation.
      + Fixed memory management in experimental::promise's type-erased
        completion handlers.
      + Fixed move operator= implementation for ssl::stream.
      + Fixed any_io_executor implementation to work when both
        BOOST_ASIO_USE_TS_EXECUTOR_AS_DEFAULT and
        BOOST_ASIO_SEPARATE_COMPILATION are defined.
      + Fixed implementation of basic_socket::at_mark() when using the
        sockatmark() system call.
      + Changed the recycling allocator to use the default alignment as the
        minimum alignment for allocations.
      + Added a workaround for apparent coroutine codegen bug with Apple's
        clang.
      + On Windows, changed the file support to open files using the same
        sharing mode as fopen().
      + On Linux, fixed UNIX domain sockets implementation to correctly handle
        EAGAIN.
      + Fixed implementation of experimental::basic_channel::reset() and
        experimental::basic_concurrent_channel::reset().
      + Fixed potential undefined behaviour in the experimental::promise.
      + Changed the co_spawn implementation to dispatch cancellation signals
        through the executor in some circumstances.
      + Fixed various header inclusion issues.
      + Fixed various warnings.
      + A number of documentation enhancements, including:
          o Added an overview of Asio's asynchronous model.
          o Reworked reference and requirements documentation in terms of
            asynchronous model.
          o Updated documentation for dispatch(), post(), and defer().
          o Documented per-operation cancellation for serial ports.
          o Clarified the non-concurrency guarantees made for allocators.
          o Reverted the io_context reference documentation to use
            executor_work_guard.
          o Added more detailed reference documentation to make_strand(),
            make_work_guard(), ip::address_v4, ip::address_v6, experimental::
            basic_channel, and experimental::basic_concurrent_channel.
          o Re-arranged and extended the Overview documentation to cover
            recently added features.
      + Added a C++11 example showing file descriptor passing over local
        sockets.
      + Added C++14 examples of wrapping callback-based APIs in asynchronous
        operations.
      + Consult the Revision History for further details.
  * Assert:
      + source_location().file_name() and source_location().function_name() now
        return "" instead of "(unknown)".
      + Added a source_location constructor from std::source_location.
      + Changed BOOST_CURRENT_LOCATION to more closely match the behavior of
        std::source_location::current(), such as being usable at top level or
        as a default function argument.
  * Atomic:
      + Fixed compilation for Universal Windows Platform (UWP). (#54)
      + Added BOOST_ATOMIC_NO_DARWIN_ULOCK configuration macro. The macro
        affects compilation on Darwin systems and disables ulock-based
        implementation of waiting and notifying operations. This may be useful
        to comply with Apple App Store requirements. (#55)
  * Beast:
      + Added missing include for file_body test.
      + Fixed WebSocket handshake response on failure.
      + Fixed open append mode for file_posix and file_win32.
      + Fixed file open with append/append_existing flag on Windows
      + Fixed clang-cl UTF8 path handling for file_win32 and file_stdio.
      + Added ARM64 builds to drone CI.
      + Fixed async_base documentation link.
      + Added tests for file open in append/append_existing mode.
      + Updated CI to include gcc 11, clang 12, msvc 14.3.
      + Added individual tests to CMake workflow.
      + We'd love to know how you or your company use Beast, consider adding an
        entry to the Companies and Individuals Using Beast list.
      + See the full Release Notes for a complete list of changes.
  * Core:
      + Made boost::pointer_traits SFINAE friendly, addressing LWG3545. (Glen
        Fernandes)
      + Added boost::allocator_traits that uses the individual allocator access
        traits. This implementation supports C++03 and above. (Glen Fernandes)
      + Updated the allocator access traits to support most of the C++11
        allocator model in C++03. (Glen Fernandes)
      + boost/iterator.hpp is deprecated and will be removed in a future
        release. The header defines boost::iterator template, which is
        equivalent to std::iterator in <iterator> header. However, since std::
        iterator is itself deprecated in C++17, users are advised to remove
        boost::iterator or std::iterator use from their code.
      + Added boost::core::verbose_terminate_handler, a utility function
        intended to be passed to std::set_terminate that prints information
        about the uncaught exception to stderr.
  * Describe:
      + Enabled unions in BOOST_DESCRIBE_STRUCT and updated examples to check
        std::is_union<T>.
      + Added example of defining a fmtlib class formatter.
      + Added example of defining a fmtlib enum formatter.
      + Added example of printing pointers to members.
  * Filesystem:
      + v3: path::replace_extension now works in terms of v3 definition of path
        ::extension rather than v4.
      + Fixed compilation of path appending and concatenation operators with
        arguments of types convertible to path or compatible string type. (#223
        )
      + On POSIX systems that support fdopendir and O_NOFOLLOW and on Windows,
        remove_all is now protected against CVE-2022-21658. The vulnerability
        is a race condition that allows a third party process to replace a
        directory that is being concurrently processed by remove_all with a
        directory symlink and cause remove_all to follow the symlink and remove
        files in the linked directory instead of removing the symlink itself. (
        #224)
      + On Windows, in remove and remove_all implementation, use POSIX
        semantics for file removal, when supported by the OS (Windows 10 1709
        and later). When POSIX semantics is supported, the file name is removed
        from the filesystem namespace as soon as the file is marked for
        deletion, even if it is still open and in use. With legacy Windows
        semantics, the file name remains present in the the filesystem
        namespace until the last file handle to the file is closed, which
        allows the file marked for deletion to be opened and prevents creating
        new files with the same name. (#216)
      + On Windows, remove and remove_all now support deleting read-only
        directories. Support for removing read-only non-directory files was
        added previously.
      + On Windows, directory_iterator internal implementation has been
        reworked to better utilize modern Windows APIs, which may improve
        performance while handling symlinks.
      + On Windows, initialize internal WinAPI function pointers early, if
        possible, to allow Boost.Filesystem operations to be invoked in global
        constructors. This is only supported on MSVC, GCC, Clang and compatible
        compilers.
      + On Windows, resize_file should no longer fail with an error if the file
        to be resized is opened.
      + Disabled use of the statx syscall on Android prior to 11.0 (API version
        30). The syscall is blacklisted by seccomp and causes process
        termination in runtime. (#229)
      + Deprecated: boost/filesystem/string_file.hpp header is deprecated and
        will be removed in a future release. The header is no longer included
        by boost/filesystem.hpp by default. Users are advised to implement the
        functionality themselves or migrate to other implementations.
      + Deprecated: Windows CE support is deprecated and will be removed in a
        future release. Windows CE has been untested for many years and is
        likely non-functional.
  * Geometry:
      + Major change
          o PR#977 Rescaling is turned off by default. This avoids many related
            bugs in set operations and buffer.
      + Improvements
          o PR#923 Added algorithm closest_points for cartesian point/geometry.
          o PR#939 Added algorithm closest_points for other coordinate systems
            and geometry combinations excl. boxes.
          o PR#961 Added Web Mercator projection.
          o PR#966 More efficient cartesian distance strategy used in simplify.
      + Solved issues
          o #956 Result of simplify algorithm with incorrect closure.
          o #962 Runtime error in R-tree deserialization due to load factor.
          o #971 R-tree insertion time impacted by use of long double on ARM
            platforms.
      + Bugfixes
          o PR#936 Envelope of polygon containing pole.
          o PR#948 Spherical and geographic envelope for near meridian
            segments.
          o PR#974 Spheroidal normalization utilities for NaN coordinates.
          o Various fixes in set operations and buffer.
  * Integer:
      + Optimized integer_log2 implementation to use bit operations internally.
        This allows to employ bit instructions available on most modern CPUs. (
        #31)
  * IO:
      + Added boost::io::basic_nullbuf, a null stream buffer, and boost::
        basic_onullstream, a null output stream (Glen Fernandes).
  * Iterator:
      + In counting_iterator, added support for built-in 128-bit integer types
        supported by gcc and clang and compatible compilers on some target
        platforms.
      + Silenced gcc warnings about deprecated implicit copy assignment
        operator in counting_iterator.
  * JSON:
      + Standalone mode of the library is removed. Users who wish to continue
        using standalone JSON can switch to the C++ Alliance fork.
      + Add std::error_code overloads.
      + Add boost::source_location to error_codes.
      + Add support for JSON Pointer.
      + Naturally grow string during serialization.
  * LEAF:
      + Support for FreeRTOS and other embedded platforms
      + Improved diagnostic information
      + Improved configuration macros
      + BOOST_LEAF_CHECK using statement expressions under __GNUC__
      + Fixed symbol demangling bug
  * Log:
      + General changes:
          o In text_file_backend, added support for appending to a previously
            written log file, when file rotation is used and log file names use
            file counters.
          o Breaking change: The file_collector interface has changed:
              # scan_for_files method returns a scan_result structure that
                contains information collected during the scan;
              # is_in_storage method added for testing if a path refers to a
                file within the target storage directory.
          o Added a new invoke_manip stream manipulator that can be used for
            injecting user's function into a stream output expression.
      + Bug fixes:
          o Fixed file counter being set to zero if the user calls
            text_file_backend::scan_for_files multiple times, and the second
            and the following calls don't find any new files. (#179)
      + See changelog for more details.
  * Multi-index Containers:
      + Improved the efficiency of count operations in ranked indices from O(
        log(n) + count) to O(log(n)). Contributed by Damian Sawicki.
      + Maintenance work.
  * Nowide:
      + Fix compilation issues on some platforms (e.g. GCC 11 on MinGW-w64 and
        Cygwin)
      + Fix missing include when using BOOST_USE_WINDOWS_H and
        WIN32_LEAN_AND_MEAN
      + Add sanity check when using boost::nowide::stat with boost::nowide::
        stat_t
  * Optional:
      + Fixed issue #98.
      + Fixed issue #92.
      + Added support for BOOST_NO_IOSTREAM.
      + Now aligned storage uses unsigned char rather than char to avoid UB.
      + Now using cv-unqualified value_type with placement new to avoid UB.
  * Predef:
      + Version 1.14.0
      + Add detection of LoongArch (from Zhang Na).
  * QVM:
      + Added constexpr under C++17
      + Improved single header distribution
  * Smart Pointers:
      + Added boost::get_allocator_pointer to obtain the Allocator pointer from
        the result of boost::allocate_unique (Glen Fernandes).
  * System:
      + Added a boost::source_location parameter to throw_exception_from_error.
      + Added throw_exception_from_error overloads for errc::errc_t, std::
        error_code, std::errc, std::exception_ptr.
      + result<T>::value now automatically supplies BOOST_CURRENT_LOCATION to
        throw_exception_from_error via a default argument.
      + Added an errc::make_error_code overload taking a source location.
  * ThrowException:
      + Added boost::throw_with_location, a more lightweight alternative of
        BOOST_THROW_EXCEPTION for programs that do not use Boost.Exception.
  * Unordered:
      + All containers have been updated to support heterogeneous count,
        equal_range and find.
      + All containers now implement the member function contains.
      + erase_if has been implemented for all containers.
      + All containers have been updated to support heterogeneous erase and
        extract.
      + Changed behavior of reserve to eagerly allocate.
      + Various warning fixes in the test suite.
      + Update code to internally use boost::allocator_traits.
      + Switch to Fibonacci hashing.
      + Update documentation to be written in AsciiDoc instead of QuickBook.
  * Variant2:
      + Added operator<< for monostate.
  * Wave:
      + C++11 now required for building Wave itself
      + Fixed bugs:
          o #135: Comma operators in array subscripts are deprecated in C++20
          o #137: Simple unknown directive => found_unknown_directive is not
            called, stripped of pound.
          o #138: Empty ifdef block does not emit line directive for missing
            whitespace
          o #143: Parsing __has_include() fails with trailing tokens
          o #145: Sanitizer complains about reset_version()
          o #147: bitwise operations between different enumeration types are
            deprecated

Updated Tools

  * Build:
      + Includes release of B2 version 4.8.2.

@comment $NetBSD: PLIST,v 1.3 2023/01/22 16:24:29 ryoon Exp $
bin/b2