[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / boost-build

File: [cvs.NetBSD.org] / pkgsrc / devel / boost-build / Makefile (download)

Revision 1.15, Wed Aug 13 10:56:35 2014 UTC (9 years, 8 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3
Changes since 1.14: +5 -5 lines

Changes 1.56.0:
Modularization
Boost version control has migrated to a system using git submodules. This shouldn't make too much of a difference to users, although the directory structure is now a bit different.

Parts of some libraries have been moved into different modules, and several new modules have been extracted from existing code. All header paths should remain the same. The new modules are:

Assert:
Customizable assert macros. Maintained by Peter Dimov.
Core:
Core utilities used by other libraries, with minimal dependencies. Maintained by Peter Dimov, Glen Fernandes and Andrey Semashev.
Lexical_Cast:
General literal text conversions, such as an int represented a string, or vice-versa, from Kevlin Henney.
Throw_Exception:
A common infrastructure for throwing exceptions from Boost libraries, from Emil Dotchevski.
Winapi:
Windows API declarations without <windows.h>, for internal Boost use.
New Libraries
Align:
Memory alignment functions, allocators, and adaptors, from Glen Fernandes.
Type_Index:
Runtime/Compile time copyable type info, from Antony Polukhin.

# $NetBSD: Makefile,v 1.15 2014/08/13 10:56:35 adam Exp $

BOOST_PACKAGE=		build
BOOST_COMMENT=		(Boost.Build framework)
BOOST_CONFIG=		no

USE_TOOLS+=	pax

.include "../../meta-pkgs/boost/Makefile.common"

SUBST_CLASSES+=		confdir
SUBST_MESSAGE.confdir=	Fixing path to site-config.jam.
SUBST_STAGE.confdir=	pre-build
SUBST_FILES.confdir=	tools/build/src/build-system.jam
SUBST_SED.confdir=	-e 's,/etc,${PKG_SYSCONFDIR},g'

EGDIR=			${PREFIX}/share/examples/boost-build
CONF_FILES=		${EGDIR}/site-config.jam \
			${PKG_SYSCONFDIR}/site-config.jam

# contains /usr/bin/python
CHECK_INTERPRETER_SKIP=	share/boost-build/example/customization/inline_file.py
CHECK_INTERPRETER_SKIP+=share/boost-build/tools/doxproc.py
CHECK_INTERPRETER_SKIP+=share/boost-build/test/*.py
# contains /bin/bash
CHECK_INTERPRETER_SKIP+=share/boost-build/nightly.sh
CHECK_INTERPRETER_SKIP+=share/boost-build/roll.sh

INSTALLATION_DIRS+=	share/boost-build

.include "toolset.mk"

post-extract:
	${FIND} ${WRKSRC}/tools/build/src -type d -exec ${CHMOD} 755 {} \;
	${FIND} ${WRKSRC}/tools/build/src -type f -exec ${CHMOD} 644 {} \;

do-build:
	{ ${ECHO} '# System wide configuration file for Boost.Build.' ; \
	  ${ECHO} ; \
	  ${ECHO} 'using ${BOOST_TOOLSET} ;' ; } >${WRKDIR}/site-config.jam

do-install:
	cd ${WRKSRC}/tools/build/src && pax -r -w -p pm -s ':^./engine.*$$::' \
		-s ':^.*\.orig$$::' . ${DESTDIR}${PREFIX}/share/boost-build
	${INSTALL_DATA_DIR} ${DESTDIR}${EGDIR}
	${INSTALL_DATA} ${WRKDIR}/site-config.jam ${DESTDIR}${EGDIR}

.include "../../mk/bsd.pkg.mk"