[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / astyle

File: [cvs.NetBSD.org] / pkgsrc / devel / astyle / Makefile (download)

Revision 1.18, Mon Jul 11 18:26:52 2016 UTC (7 years, 9 months ago) by schmonz
Branch: MAIN
CVS Tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.17: +2 -2 lines

Update to 2.05.1. From the changelog:

- Fix incorrectly reporting files containing disabled formatting as
  being formatted.
- Fix incorrect handling of quoted arguments in the options file (#321).
- Fix error in identifying an enum return type as an enumeration
  (#322, 323).
- Fix error in identifying an enum argument as an enumeration (#327).
- Fix recognition of Qt keywords when used as variables in C++ (#329).
- Fix recognition of a pointer in a C++ cast (#316).
- Fix removing trailing whitespace after a changed pointer or
  reference cast.

- Add new bracket style option "style=vtk" (#155).
- Add new option "indent-preproc-block" to indent blocks of preprocessor
  directives (#21, #114, #229, #242, #294).
- Add new option, "dry-run", to run AStyle without updating the files
  (#184, #285).
- Add new options, "html" (-!") and "html=###", to display the HTML help
  documentation in the default browser.
- Add tags "*INDENT-OFF*" and "*INDENT_ON*" to disable formatting of
  source code blocks (#2, #47, #55, #78, #110, #176).
- Add tag *NOPAD* to disable selected formatting on a single line.
- Add '__attribute__ ((visibility ("default")))' to Linux exported functions.
- Remove option "style=ansi" and make it depreciated (#146).
- Remove fix for broken 'case' statements from release 2.02.1, Nov 21, 2011.
- Improve Korean translation (#256).
- Change shared libraries to include the version number as part of the
  file name (#264)
- Change "help" display to stdout to allow piping and redirection (#63).
- Change "version" display to stdout.
- Change headers to include foreach, forever, Q_FOREACH, and Q_FOREVER
  (#98, #154).
- Change compiler definition ASTYLE_NO_VCX (no Visual Studio exports) to
  ASTYLE_NO_EXPORTS.
- Change shared library error handler argument from "char*" to "const char*".
- Fix not recognizing noexcept, interrupt, and autoreleasepool as
  pre-command headers (#225, #259).
- Fix formatting of C++11 uniform initializer brackets (#253, #257,
  #260, #284).
- Fix to not automatically space pad C++11 uniform initializer
  brackets (#275).
- Fix formatting of enums with leading commas (#159, #179, #270).
- Fix formatting of logical && operator in class initializers (#290).
- Fix flagging a 'const' variable as a 'const' method (#275).
- Fix piping and redirection adding an extra character to the output
  (#245, #252, #305).
- Fix "indent-modifiers" to attach class access modifiers to Horstmann
  style brackets.
- Fix ASFormatter to correctly recognize the end of a C++ raw string
  literal (#261).
- Fix to recognize C++11 "enum class" as an enum (#303).
- Fix indent of C++11 "noexecpt" statements within a class (#260, #304).
- Fix not resetting templateDepth when a template was not found (#295).
- Fix formatting of multiplication in a block paren (#144).
- Fix whitespace padding when formatting an rvalue references (#297).
- Fix to recognize an rvalue reference without a name (#265).
- Fix to not identify an operator overload method as a calculation (#296).
- Fix concatenating multiplication with a pointer dereference (#291).
- Fix recognition of a pointer dereference following a question mark (#213).
- Fix extra space after a trailing reference type (#300).
- Fix _asm blocks not being identified as a block opener and the
  variable not cleared on exit (#163).
- Fix indentation of line comments before a "class" opening bracket.
- Fix indentation of line comments before a "namespace" opening bracket.
- Fix isBracketType() method to correctly process a NULL_TYPE.
- Fix unpad-paren to recognize additional variables (#43, #132, #143).
- Fix indentation of C# "let" statements.
- Fix a few omissions with "fill-empty-lines".
- Fix file read to read 64K blocks of data.
- Refactor to un-obfuscate (clarify) the code, and improve design and
  decomposition::
    - Extract class Utf8_16 from ASConsole.
    - Replace Linux dependency on iconv with a Utf8_16 class for ASLibrary.
    - Move global "using" statements to the astyle namespace in astyle.h
      and ASLocalizer.h.
    - Move shared library declarations from astyle.h to astyle_main.h.
    - Move indentable macros from ASEnhancer to ASResource and create
      static pairs.
    - Simplify ASBeautifier procedure to identify the colon (:) type.
    - Major refactoring in ASBeautifier to create separate variables for
      an enum, a class statement and a class initializer.
    - This was needed to fix the processing of C++11 uniform
      initializers in a class initializer.
    - Minor changes to ASFormatter and ASBeautifier based on results of
      the Clang analyzer.
    - Change several methods in astyle_main to "const".

# $NetBSD: Makefile,v 1.18 2016/07/11 18:26:52 schmonz Exp $

DISTNAME=	astyle_2.05.1_linux
PKGNAME=	${DISTNAME:S/_linux//:S/_/-/}
CATEGORIES=	textproc devel
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=astyle/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://astyle.sourceforge.net/
COMMENT=	Free, Fast and Small Automatic Formatter for C, C++, C++/CLI, C#, and Java
LICENSE=	gnu-lgpl-v3

WRKSRC=		${WRKDIR}/astyle
BUILD_DIRS=	build/gcc
USE_TOOLS+=	gmake
USE_LANGUAGES=	c++

HTMLDIR=	${PREFIX}/share/doc/html/astyle
INSTALLATION_DIRS=	bin ${HTMLDIR}

do-install:
	${INSTALL_PROGRAM} ${WRKSRC}/build/gcc/bin/astyle ${DESTDIR}${PREFIX}/bin
	cd ${WRKSRC}/doc && ${INSTALL_DATA} * ${DESTDIR}${HTMLDIR}

.include "../../converters/libiconv/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"