[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / adocman

File: [cvs.NetBSD.org] / pkgsrc / devel / adocman / Makefile (download)

Revision 1.29, Sun Jan 26 05:26:21 2020 UTC (4 years, 2 months ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1
Changes since 1.28: +2 -2 lines

all: migrate some SourceForge homepage URLs back from https to http

https://mail-index.netbsd.org/pkgsrc-changes/2020/01/18/msg205146.html

In the above commit, the homepage URLs were migrated from http to https,
assuming that SourceForge would use the same host names for both http and
https connections. This assumption was wrong. Their documentation at
https://sourceforge.net/p/forge/documentation/Custom%20VHOSTs/ states
that the https URLs use the domain sourceforge.io instead.

To make the homepages from the above commit reachable again, pkglint has
been extended to check for reachable homepages. This check is only
enabled when the --network command line option is given.

Each of the homepages that referred to https://$project.sourceforge.net
before was migrated to https://$project.sourceforge.io (27), and if that
was not reachable, to the fallback URL http://$project.sourceforge.net
(163).

# $NetBSD: Makefile,v 1.29 2020/01/26 05:26:21 rillig Exp $
#

DISTNAME=	adocman-0.10
PKGREVISION=	13
CATEGORIES=	devel
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=sitedocs/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://sitedocs.sourceforge.net/
COMMENT=	DocManager operation automation tool

DEPENDS+=	p5-Term-ReadKey>=2.21:../../devel/p5-Term-ReadKey
DEPENDS+=	p5-Crypt-SSLeay>=0.47:../../security/p5-Crypt-SSLeay

NO_BUILD=		yes
PERL5_CONFIGURE=	no
REPLACE_PERL=		adocman xml_export
AUTO_MKDIRS=		yes

do-install:
	${INSTALL_SCRIPT} ${WRKSRC}/adocman ${DESTDIR}${PREFIX}/bin
	${INSTALL_SCRIPT} ${WRKSRC}/xml_export ${DESTDIR}${PREFIX}/bin
	${INSTALL_SCRIPT_DIR} ${DESTDIR}${PERL5_INSTALLVENDORLIB}/Alexandria
	cd ${WRKSRC}/Alexandria && ${INSTALL_SCRIPT} \
		Client.pm Docman.pm \
		${DESTDIR}${PERL5_INSTALLVENDORLIB}/Alexandria
	cd ${WRKSRC} && ${INSTALL_DATA} \
		LICENSE README TODO adocman.html xml_export.html \
		${DESTDIR}${PREFIX}/share/doc/adocman

.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"