Up to [cvs.NetBSD.org] / pkgsrc / devel / R-roxygen2
Request diff between arbitrary revisions
Default branch: MAIN
Revision 1.6 / (download) - annotate - [select for diffs], Sun Dec 18 04:51:33 2022 UTC (9 months, 1 week ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base,
pkgsrc-2023Q3,
pkgsrc-2023Q2-base,
pkgsrc-2023Q2,
pkgsrc-2023Q1-base,
pkgsrc-2023Q1,
pkgsrc-2022Q4-base,
pkgsrc-2022Q4,
HEAD
Changes since 1.5: +4 -4
lines
Diff to previous 1.5 (colored)
(devel/R-roxygen2) Updated 7.1.2 to 7.2.3 # roxygen2 7.2.3 * roxygen2 now supports HTML blocks in markdown. They are only included in the HTML manual. They can also be produced as the output of code chunks. * Improved support for RStudio IDE. # roxygen2 7.2.2 * `@includeRmd` calls `local_reproducible_output()` to make code run in included `.Rmd`s more consistent with other sources (#1431). * Fix duplicated argument in `roxy_block()` to avoid CRAN removal. # roxygen2 7.2.1 ## Tags * All built-in tags are now documented so that you can do (e.g.) `?"@param"` to get a basic description of `@param` and a pointer where to learn more (#1165). This is powered by a new `tags_list()` lists all tags defined by roxygen2 and `tags_metadata()` provides some useful information about them for use by (e.g.) IDEs (#1375). * `@describeIn` can now be used to combine more types of functions (generics, methods and other functions) into a single topic. The resulting section organises the functions by type (#1181) and displays methods like function calls. Methods are recognized only if they extend the generic in the destination,or if the destination can heuristically be identified as a constructor. * Code evaluated in inline markdown code chunks and `@eval`/`@evalRd`/ `@evalNamespace` is now evaluated in an environment designed to be more reproducible and to suppress output that won't work in Rd (e.g. turning off colour and unicode support in cli) (#1351). They now also set knitr options `comment = #>` (#1380) and `collapse = TRUE` (#1376). * `@export` will now export both the class and constructor function when applied to expressions like `foo <- setClass("foo")` (#1216). * `@includeRmd` now gives better feedback when it fails (#1089). ## (R)markdown * New `knitr_chunk_options` option (in the `Roxygen` entry of `DESCRIPTION` or in `man/roxygen/meta.R`) is added to the knitr chunk options that roxygen2 uses for markdown code blocks and inline code (#1390). * PDF figures are only included the PDF manual, and SVG figures are only included in the HTML manual (#1399). * You can now use alternative knitr engines in markdown code blocks (#1149). * Generated HTML for code blocks never includes "NA" for language (#1251). * Using a level 1 heading in the wrong tag now gives a more useful warning (#1374). * Fix bug interpolating the results of indented inline RMarkdown (#1353). ## Other * If you have a daily build of RStudio, the lists of changed Rd files are now clickable so you can immediately see the rendered development documentation (#1354). * R6 documentation no longer shows inherited methods if there aren't any (#1371), and only links to superclass docs if they're actually available (#1236). * Automated usage no longer mangles nbsp in default arguments (#1342). # roxygen2 7.2.0 ## New features * The NAMESPACE roclet now preserves all existing non-import directives during it's first pre-processing pass. This eliminates the "NAMESPACE has changed" messages and reduces the incidence of namespace borking (#1254). * `@inheritParams` now only inherits exact multiparameter matches, so if you're inheriting from a function with `@param x,y` you'll only get the parameter documentation if your function needs docs for both x and y (#950). * All warning messages have been reviewed to be more informative and actionable (#1317). `@title` now checks for multiple paragraphs. `@export` gives a more informative warning if it contains too many lines. (#1074). All tags warn now if only provide whitespace (#1228), and problems with the first tag in each block are reported with the correct line number (#1235). * If you have a daily build of RStudio, roxygen2 warnings will now include a clickable hyperlink that will take you directly to the problem (#1323). This technology is under active development across the IDE and the cli package but is extremely exciting. ## Minor improvements and bug fixes * roxygen2 can once again read UTF-8 paths on windows (#1277). * `@author`s are de-duplicated in merged documentation (@DanChaltiel, #1333). * `@exportS3method pkg::generic` now works when `pkg::generic` isn't imported by your package (#1085). * `@includeRmd` is now adapted to change in rmarkdown 2.12 regarding math support in `github_document()` (#1304). * `@inherit` and friends perform less aggressive link tweaking, eliminating many spurious warnings. Additionally, when you do get a warning, you'll now always learn which topic it's coming from (#1135). Inherited `\ifelse{}{}{}` tags are now inserted correctly (without additional `{}`) (#1062). * `@inherit` now supports inheriting "Notes" with `@inherit pkg::fun note` (@pat-s, #1218) * Automatic `@usage` now correctly wraps arguments containing syntactically significant whitespace (e.g anonymous functions) (#1281) and non-syntactic values surrounded by backticks (#1257). * Markdown: * Code blocks are always wrapped in `<div class="sourceCode">` even if the language is unknown (#1234). * Links with markup (e.g. ``[foo `bar`][target]``) now cause an informative warning instead of generating invalid Rd. * Curly braces in links are now escaped (#1259). * Inline R code is now powered by knitr. Where available, (knit) print methods are applied (#1179). This change alters outputs and brings roxygen in line with console and R markdown behavior. `x <- "foo"` no longer inserts anything into the resulting documentation, but `x <- "foo"; x` will. This also means that returning a character vector will insert commas between components, not newlines. * roxygen2 no longer generates invalid HTML (#1290). * DOIs, arXiv links, and urls in the `Description` field of the `DESCRIPTION` are now converted to the appropriate Rd markup (@dieghernan, #1265, #1164). DOIs in the `URL` field of the `DESCRIPTION` are now converted to Rd's special `\doi{}` tag (@ThierryO, #1296).
Revision 1.5 / (download) - annotate - [select for diffs], Sat Apr 30 14:39:03 2022 UTC (17 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2022Q3-base,
pkgsrc-2022Q3,
pkgsrc-2022Q2-base,
pkgsrc-2022Q2
Changes since 1.4: +4 -4
lines
Diff to previous 1.4 (colored)
(devel/R-roxygen2) Updated 7.1.1 to 7.1.2 # roxygen2 7.1.2 * The new `@examplesIf` tag can be used to create conditional examples. These examples only run if a specified condition holds (#962). * roxygen2 is now licensed as MIT (#1163). * Bug fix for upcoming stringr 2.0.0 release. * Code blocks with language now add `sourceCode` to the generated div; this makes syntax highlighting more consistent across downlit/pandoc/knitr/roxygen2. * Percent signs in markdown link targets, e.g. `[text](https://foo/ba%20r)` are now handled correctly (#1209).
Revision 1.4 / (download) - annotate - [select for diffs], Tue Oct 26 10:14:08 2021 UTC (23 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2022Q1-base,
pkgsrc-2022Q1,
pkgsrc-2021Q4-base,
pkgsrc-2021Q4
Changes since 1.3: +2 -2
lines
Diff to previous 1.3 (colored)
archivers: Replace RMD160 checksums with BLAKE2s checksums All checksums have been double-checked against existing RMD160 and SHA512 hashes Could not be committed due to merge conflict: devel/py-traitlets/distinfo The following distfiles were unfetchable (note: some may be only fetched conditionally): ./devel/pvs/distinfo pvs-3.2-solaris.tgz ./devel/eclipse/distinfo eclipse-sourceBuild-srcIncluded-3.0.1.zip
Revision 1.3 / (download) - annotate - [select for diffs], Thu Oct 7 13:39:02 2021 UTC (23 months, 3 weeks ago) by nia
Branch: MAIN
Changes since 1.2: +1 -2
lines
Diff to previous 1.2 (colored)
devel: Remove SHA1 hashes for distfiles
Revision 1.2 / (download) - annotate - [select for diffs], Sun Sep 20 04:29:28 2020 UTC (3 years ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base,
pkgsrc-2021Q3,
pkgsrc-2021Q2-base,
pkgsrc-2021Q2,
pkgsrc-2021Q1-base,
pkgsrc-2021Q1,
pkgsrc-2020Q4-base,
pkgsrc-2020Q4,
pkgsrc-2020Q3-base,
pkgsrc-2020Q3
Changes since 1.1: +5 -5
lines
Diff to previous 1.1 (colored)
(devel/R-roxygen) Updated 6.1.1 to 7.1.1, make test fails, missing TEST_DEPENDS # roxygen2 7.1.1 ---------------- * When processing cross package markdown links (e.g. `[pkg::fun()]`), roxygen2 now looks up the file it needs to link to, instead of linking to the topic, to avoid "Non-file package-anchored links" `R CMD check` warnings. * R6 methods and re-exported functions are always sorted in the C locale; this ensures they're always sorted the same way in every environment (#1077). * roxygen2 now supports inline markdown code and code chunks inside Rd tags. In particular in `\out{}` (#1115). # roxygen2 7.1.0 ## New features * roxygen2 now supports inline markdown code and also code chunks, using the same notation as the knitr package. For example: ```R #' This manual was generated at: `r Sys.time()`. #' ... #' `mtcars` is a data frame with `r ncol(mtcars)` columns, here #' is a summary of them: #' #' ```{r} #' summary(mtcars) #' ``` ``` See `vignette("rd-formatting")` for details. * roxygen2 now keeps using Windows (CR LF) line endings for files that already have CR LF line endings, and uses LF for new files (#989). ## Minor improvements and bug fixes * Auto-generated package documentation can now handle author ORCID comments containing full url (#1040). * Hyperlinks to R6 methods are also added in the PDF manual (#1006). * Empty annotations (alternate text) for figures added via markdown are now omitted. This caused issues when generating pkgdown web sites (#1051). * Roxygen metadata can now have a `packages` element, giving a character vector of package names to load. This makes it easier to use extension package that provide new tags for existing roclets (#1013). See `?load_options` for more details. ```yaml Roxygen: list(markdown = TRUE, packages = "roxygenlabs") ``` * `@evalNamespace()` works again (#1022). * `@description NULL` and `@details NULL` no longer fail; instead, these tags are ignored, except for `@description NULL` in package level documentation, where it can be used to suppress the auto-generated Description section (#1008). * Multiple `@format` tags are now combined (#1015). * The warning for `@section` titles spanning multiple lines now includes a hint that you're missing a colon (@maelle, #994). * Can now document objects created with `delayedAssign()` by forcing evaluation at documentation time (#1041) # roxygen2 7.0.2 ---------------- * `\example{}` escaping has been improved (again!) so that special escapes within strings are correctly escaped (#990). # roxygen2 7.0.1 ---------------- * `@includeRmd` has now an optional second argument, the top level section the included file will go to. It defaults to the details section (#970). Code chunks are now evaluated in a child of the global environment (#972). * `@inheritParams` does a better job of munging links. Links of the form `\link[=topic]{text}` are now automatically converted to `\link[pkg:topic]{text}` when inherited from other packages (#979). Internal `has_topic()` helper has a better implementation; this means that links should no longer be munged unnecessarily (#973). * `\example{}` escaping has been considerably simplified (#967), and is now documented in `escape_example()`. * In `\usage{}`, S3/S4 methods are no longer double-escaped (#976). * Markdown tables with cells that contain multiple elements (e.g. text and code) are now rendered correctly (#985). * Markdown code blocks containing operators and other special syntax (e.g. `function`, `if`, `+`) now converted to `\code{}` not `\verb{}` (#971). # roxygen2 7.0.0 ---------------- ## New features ### New tags * `@includeRmd {path.Rmd}` converts an `.Rmd`/`.md` file to `.Rd` and includes it in the manual page. This allows sharing text between vignettes, `README.Rmd`, and the documentation. See `vignette("rd")` for details (#902). * `@order {n}` tag controls the order in which blocks are processed. You can use it to override the usual ordering which proceeds from the top of each file to the bottom. `@order 1` will be processed before `@order 2`, and before any blocks that don't have an explicit order set (#863). * `@exportS3Method` tag allows you to generate `S3method()` namespace directives (note the different in capitalisation) (#796). Its primary use is for "delayed" method registration, which allows you to define methods for generics found in suggested packages (available in R 3.6 and greater). For example, ```R #' @exportS3Method package::generic generic.foo <- function(x, ...) { } ``` will generate ``` S3method(package::generic, foo) ``` (See [`vctrs::s3_register()`](https://vctrs.r-lib.org/reference/s3_register.html) you need a version that works for earlier versions of R). It also has a two argument form allows you generate arbitrary `S3method()` directives: ```R #' @exportS3Method generic class NULL ``` ``` S3method(generic, class) ``` * New `@returns` is an alias for `@return` (#952).
Revision 1.1 / (download) - annotate - [select for diffs], Fri Aug 9 19:12:14 2019 UTC (4 years, 1 month ago) by brook
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base,
pkgsrc-2020Q2,
pkgsrc-2020Q1-base,
pkgsrc-2020Q1,
pkgsrc-2019Q4-base,
pkgsrc-2019Q4,
pkgsrc-2019Q3-base,
pkgsrc-2019Q3
R-roxygen2: initial commit Generate your Rd documentation, 'NAMESPACE' file, and collation field using specially formatted comments. Writing documentation in-line with code makes it easier to keep your documentation up-to-date as your requirements change. 'Roxygen2' is inspired by the 'Doxygen' system for C++.