The NetBSD Project

CVS log for pkgsrc/devel/R-fs/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / R-fs

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.7 / (download) - annotate - [select for diffs], Sun Jun 11 15:12:14 2023 UTC (3 months, 1 week ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2, HEAD
Changes since 1.6: +4 -4 lines
Diff to previous 1.6 (colored)

(devel/R-fs) Updated 1.5.2 to 1.6.2

# fs 1.6.2

* `path_ext_set()` can now handle extensions that contain a `.`,
  e.g. `csv.gz` (@mgirlich, #415).

# fs 1.6.1

No user visible changes.

# fs 1.6.0

* inputs to `path_real()` and `path_join()` are coerced to character
  for consistency with other functions (@raymondben, #370)

* fs uses libuv 1.44.2 now.

Revision 1.6 / (download) - annotate - [select for diffs], Tue Apr 19 12:46:05 2022 UTC (17 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2
Changes since 1.5: +5 -5 lines
Diff to previous 1.5 (colored)

(devel/R-fs) Updated 1.5.0 to 1.5.2

# fs 1.5.2
* `file_create()` and `dir_create()` now return the correct path when
  `...` arguments are used (@davidchall, #333).

* `dir_create(recurse = FALSE)` now correctly handles `...` arguments
  (@davidchall, #333).

* `file_exists()` now expands `~` again (#325).

* `dir_copy()` works when `path` has length >1 (#360).

# fs 1.5.1
* Gábor Csárdi is now the maintainer.

* fs is now licensed as MIT (#301).

* `dir_create()` now restores the previous umask (#293)

* `file_exists()` is now much faster (#295)

* `options(fs.fs_path.shorten)` can now be used to control how paths
  are shortened in tibbles.  The default value is "front", valid
  alternatives are "back", "middle" and "abbreviate". (#335)

* `options(fs.use_tibble = FALSE)` can now be used to disable use of
  tibbles (#295).

* `path_tidy()` now works with non-UTF8 encoded paths (@shrektan, #321).

Revision 1.5 / (download) - annotate - [select for diffs], Tue Oct 26 10:14:04 2021 UTC (22 months, 4 weeks ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4
Changes since 1.4: +2 -2 lines
Diff to previous 1.4 (colored)

archivers: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

Could not be committed due to merge conflict:
devel/py-traitlets/distinfo

The following distfiles were unfetchable (note: some may be only fetched
conditionally):

./devel/pvs/distinfo pvs-3.2-solaris.tgz
./devel/eclipse/distinfo eclipse-sourceBuild-srcIncluded-3.0.1.zip

Revision 1.4 / (download) - annotate - [select for diffs], Thu Oct 7 13:38:58 2021 UTC (23 months, 2 weeks ago) by nia
Branch: MAIN
Changes since 1.3: +1 -2 lines
Diff to previous 1.3 (colored)

devel: Remove SHA1 hashes for distfiles

Revision 1.3 / (download) - annotate - [select for diffs], Sat Sep 19 21:39:43 2020 UTC (3 years ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3
Changes since 1.2: +5 -5 lines
Diff to previous 1.2 (colored)

(devel/R-fs) Updated 1.3.1 to 1.5.0

(pkgsrc)
 - Add  TEST_DEPENDS+, but still fails at pdLaTeX

(upstream)
# fs 1.5.0
----------

* The libuv release used by fs was updated to 1.38.1

* `dir_create()` now consults the process umask so the mode during
  directory creation works like `mkdir` does (#284).

* `fs_path`, `fs_bytes` and `fs_perms` objects are now compatible with vctrs 0.3.0 (#266)

* `fs_path` objects now sort properly when there is a mix of ASCII and
  unicode elements (#279)

# fs 1.4.2
----------
* `file_info(..., follow = TRUE)`, `is_dir()`, and `is_file()`
  follow relative symlinks in non-current directories (@heavywatal, #280)

* `dir_map()` now grows its internal list safely, the 1.4.0 release
  introduced an unsafe regression (#268)

* `file_info()` returns a tibble if the tibble package is installed,
  and subsets work when it is a `data.frame` (#265)

* `path_real()` always fails if the file does not exist. Thus it can no longer
  be used to resolve symlinks further up the path hierarchy for files that do not
  yet exist. This reverts the feature introduced in 1.2.7 (#144, #221, #231)

# fs 1.4.1
----------
* Fix compilation on Solaris.

# fs 1.4.0
----------
* `[[.fs_path`, `[[.fs_bytes` and `[[.fs_perms` now preserve their
  classes after subsetting (#254).

* `path_has_parent()` now recycles both the `path` and `parent` arguments (#253).
* `path_ext_set()` now recycles both the `path` and `ext` arguments (#250).
* Internally fs no longer depends on Rcpp

# fs 1.3.2
----------
* fs now passes along `CPPFLAGS` during compilation of libuv, fixing an issue that could
  prevent compilation from source on macOS Catalina. (@kevinushey, #229)

* fs now compiles on alpine linux (#210)

* `dir_create()` now works with absolute paths and `recurse = FALSE` (#204).

* `dir_tree()` now works with paths that need tilde expansion (@dmurdoch, @jennybc, #203).

* `file_info()` now returns file sizes with the proper classes
  ("fs_bytes" and "numeric"), rather than just "fs_bytes" (#239)

* `get_dirent_type()` gains a `fail` argument (@bellma-lilly, #219)

* `Is_Dir()`, `is_file()`, `is_file_empty()` and `file_info()` gain a
  `follow` argument, to follow links and return information about the
  linked file rather than the link itself (#198)

* `path()` now follows "tidy" recycling rules, namely only consistent
  or length 1 inputs are recycled. (#238)

* `path()` now errors if the path given or constructed will exceed `PATH_MAX` (#233).

* `path_ext_set()` now works with multiple paths (@maurolepore, #208).

Revision 1.2 / (download) - annotate - [select for diffs], Wed Sep 11 12:20:40 2019 UTC (4 years ago) by cherry
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3
Changes since 1.1: +2 -1 lines
Diff to previous 1.1 (colored)

Add -lkvm to build so that the package builds and runs with NetBSD.

Revision 1.1 / (download) - annotate - [select for diffs], Fri Aug 9 18:28:06 2019 UTC (4 years, 1 month ago) by brook
Branch: MAIN

R-fs: initial commit

A cross-platform interface to file system operations, built on top of
the 'libuv' C library.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>