[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / databases / unixodbc

File: [cvs.NetBSD.org] / pkgsrc / databases / unixodbc / Attic / Makefile.common (download)

Revision 1.21, Sat Mar 4 21:29:11 2006 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2007Q4-base, pkgsrc-2007Q4, pkgsrc-2007Q3-base, pkgsrc-2007Q3, pkgsrc-2007Q2-base, pkgsrc-2007Q2, pkgsrc-2007Q1-base, pkgsrc-2007Q1, pkgsrc-2006Q4-base, pkgsrc-2006Q4, pkgsrc-2006Q3-base, pkgsrc-2006Q3, pkgsrc-2006Q2-base, pkgsrc-2006Q2, pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.20: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile.common,v 1.21 2006/03/04 21:29:11 jlam Exp $

DISTNAME=	unixODBC-${ODBC_DIST_VERS}
CATEGORIES=	databases
MASTER_SITES=	http://www.unixodbc.org/

MAINTAINER?=	pkgsrc-users@NetBSD.org
HOMEPAGE?=	http://www.unixodbc.org/

# Version numbering scheme:
#
# ODBC_DIST_VERS	version number on the php distfile
# ODBC_BASE_VERS	pkgsrc-mangled version number (convert pl -> .)
#
ODBC_DIST_VERS=		2.2.11
ODBC_BASE_VERS=		${ODBC_DIST_VERS}

USE_LIBTOOL=		YES

GNU_CONFIGURE=		YES
CONFIGURE_ARGS+=	--sysconfdir=${PKG_SYSCONFDIR:Q}
CONFIGURE_ARGS+=	--enable-threads
PTHREAD_OPTS+=		require

# Override the local definitions that point to the self-contained libtool
# convenience library.  We want the one installed by pkgsrc.  Also override
# the variable pointing to the (static) libfl.a, which won't link with a
# shared library.  The sources define all the relevant symbols (yywrap), so
# libfl.a isn't needed.
#
MAKE_FLAGS+=		LEXLIB=""
MAKE_ENV+=		AM_MAKEFLAGS=${MAKE_FLAGS:Q}

UNIXODBC_DRIVERS_DIR=	lib/unixodbc

post-patch: fix-ltdl-and-lexlib

fix-driver-installation:
	cd ${WRKSRC};							\
	files=`${FIND} ODBCConfig DRVConfig Drivers -name Makefile.in -print`;\
	for file in $${files}; do					\
		${SED}  -e "s|^\(libdir =\).*|\1 ${PREFIX}/${UNIXODBC_DRIVERS_DIR}|g" \
			$${file} >> $${file}.fixed;			\
		${MV} -f $${file}.fixed $${file};			\
	done

fix-ltdl-and-lexlib:
	cd ${WRKSRC};							\
	files=`${FIND} . -name Makefile.in -print`;			\
	for file in $${files}; do					\
		${SED}	-e "/DEPENDENCIES/s|\$$(LIBLTDL)||g"		\
			-e "/LIBADD/s|@LEXLIB@|\$$(LEXLIB)|g"		\
			$${file} >> $${file}.fixed;			\
		${MV} -f $${file}.fixed $${file};			\
	done

.include "../../devel/libltdl/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"

.if defined(PTHREAD_TYPE) && (${PTHREAD_TYPE} == "pth")
CONFIGURE_ARGS+=	--enable-gnuthreads
CONFIGURE_ARGS+=	--with-pth=${PTHREADBASE:Q}
.endif