[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / databases / skytools

File: [cvs.NetBSD.org] / pkgsrc / databases / skytools / Makefile (download)

Revision 1.7, Sun Aug 28 15:48:29 2016 UTC (2 years, 7 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.6: +1 -2 lines

Remove unnecessary PLIST_SUBST and FILES_SUBST that are now provided
by the infrastructure.

Mark a couple more packages as not ready for python-3.x.

# $NetBSD: Makefile,v 1.7 2016/08/28 15:48:29 wiz Exp $

DISTNAME=	skytools-3.2
PKGREVISION=	1
CATEGORIES=	databases
MASTER_SITES=	http://pgfoundry.org/frs/download.php/3622/

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://pgfoundry.org/projects/skytools
COMMENT=	Tools for PostgreSQL for queueing, replication and failover
LICENSE=	isc

DEPENDS+=	${PYPKGPREFIX}-psycopg2-[0-9]*:../../databases/py-psycopg2
DEPENDS+=	rsync-[0-9]*:../../net/rsync

USE_LANGUAGES=	c
GNU_CONFIGURE=	yes

USE_TOOLS+=	awk gmake grep sed

PY_PATCHPLIST=	yes
PY_NO_EGG=	no
PYTHON_VERSIONS_INCOMPATIBLE=	34 35 # not yet ported as of 3.2

REPLACE_PYTHON+=	scripts/*.py
REPLACE_PYTHON+=	python/*.py
REPLACE_PYTHON+=	python/skytools/*.py
REPLACE_PYTHON+=	python/pgq/*.py
REPLACE_PYTHON+=	python/pgq/cascade/*.py
REPLACE_PYTHON+=	python/londiste/*.py
REPLACE_PYTHON+=	python/londiste/handlers/*.py
REPLACE_PYTHON+=	misc/*.py
REPLACE_PYTHON+=	*.py
REPLACE_PYTHON+=	tests/setadm/*.py
REPLACE_PYTHON+=	tests/londiste/*.py
REPLACE_PYTHON+=	tests/skylog/*.py
REPLACE_PYTHON+=	tests/cascade/*.py
REPLACE_PYTHON+=	tests/localconsumer/*.py
REPLACE_PYTHON+=	tests/quoting/*.py

.include "../../mk/pgsql.buildlink3.mk"
.include "../../lang/python/application.mk"
.include "../../lang/python/extension.mk"
.include "../../mk/bsd.pkg.mk"