The NetBSD Project

CVS log for pkgsrc/databases/ruby-sequel/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / databases / ruby-sequel

Request diff between arbitrary revisions


Default branch: MAIN
Current tag: pkgsrc-2017Q2


Revision 1.51 / (download) - annotate - [select for diffs], Sun Jun 4 15:03:09 2017 UTC (6 years, 10 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2
Changes since 1.50: +5 -5 lines
Diff to previous 1.50 (colored)

Update ruby-sequel to 4.47.0.

=== 4.47.0 (2017-06-01)

* Deprecate pg_typecast_on_load plugin, only useful on deprecated do and swift
  adapters (jeremyevans)
* Deprecate association_autoreloading and many_to_one_pk_lookup plugins, which
  were made the default model behavior in Sequel 4 (jeremyevans)
* Deprecate setting invalid datasets for models unless required_valid_table =
  false (jeremyevans)
* Make Model.require_valid_table = true not raise for datasets where
  Database#schema raises an error but Dataset#columns works (jeremyevans)
* Make Database#with_server in the server_block extension accept a second
  argument for a different read_only shard (jeremyevans) (#1355)
* Make schema_dumper extension handle Oracle 11g XE inclusion of not null in
  the db_type (StevenCregan, jeremyevans) (#1351)
* Add Model.default_association_type_options for changing default association
  options per association type (jeremyevans)
* Add :materialized option to Database#views on PostgreSQL to return
  materialized views (Blargel) (#1348)
* Make defaults_setter plugin inherit custom default values when subclassing
  (jeremyevans)

=== 4.46.0 (2017-05-01)

* Recognize additional disconnect error on MySQL (jeremyevans)
* Deconstantize dataset SQL generation, speeding up ruby 2.3+, slowing down
  earlier versions (jeremyevans)
* Deprecate calling Dataset#set_graph_aliases before Dataset#graph
  (jeremyevans)
* Don't swallow exception if there is an exception when rolling back a
  transaction when using :rollback=>:always option (jeremyevans)
* Deprecate passing 2 arguments to Database#alter_table (jeremyevans)
* Deprecate passing Schema::CreateTableGenerator instance as second argument
  to Database#create_table (jeremyevans)
* Deprecate Database::DatasetClass as a way for getting default dataset
  classes for datasets (jeremyevans)
* Deprecate SQLite pragma getting and setting methods (jeremyevans)
* Remove handling of EMULATED_FUNCTION_MAP from adapter dataset classes,
  overide Dataset#native_function_name instead (jeremyevans)
* Deprecate {Integer,Timestamp}Migrator::DEFAULT_SCHEMA_{COLUMN,TABLE}
  (jeremyevans)
* Deprecate Database#jdbc_* methods for jdbc/db2 adapter Database instances
  (jeremyevans)
* Remove addition of Database#jdbc_* to JDBC::Database in jdbc/db2 adapter
  (jeremyevans)
* Deprecate many internal Database and Dataset string/regexp constants in core
  and included adapters (jeremyevans)
* Remove use of Fixnum in sqlanywhere shared adapter (jeremyevans)
* Deprecate Sequel::Schema::Generator constant, use
  Sequel::Schema::CreateTableGenerator instead (jeremyevans)
* Deprecate Database#log_yield (jeremyevans)
* Deprecate the set_overrides extension (jeremyevans)
* If passing an empty array or hash and a block to a filtering method, ignore
  the array or hash and just use the block (jeremyevans)
* Deprecate ignoring explicit nil argument when there is no existing filter
  (jeremyevans)
* Deprecate ignoring explicit nil argument to filtering methods when passing a
  block (jeremyevans)
* Deprecate ignoring empty strings and other empty? arguments passed to the
  filtering methods without a block (jeremyevans)
* Deprecate calling filtering methods without an argument or a block
  (jeremyevans)
* Deprecate Sequel::VirtualRow#` to create literal SQL, use Sequel.lit instead
  (jeremyevans)
* Add auto_literal_strings extensions for treating plain strings passed to
  filtering/update methods as literal SQL (jeremyevans)
* Deprecate automatically treating plain strings passed to filtering/update
  methods as literal SQL (jeremyevans)
* Passing a PlaceholderLiteralString to a filtering method now uses
  parentheses around the expression (jeremyevans)
* Make Dataset#full_text_search work on Microsoft SQL Server when
  no_auto_literal_strings extension is used (jeremyevans)
* Fix Database#disconnect when using the single connection pool without an
  active connection (jeremyevans) (#1339)
* Handle conversion of datetimeoffset values when using the jdbc/sqlserver
  adapter in some configurations (iaddict, jeremyevans) (#1338)
* Fix conversion of some time values when using the jdbc/sqlserver adapter in
  some configurations (iaddict, jeremyevans) (#1337)
* Use microsecond precision for time values on Microsoft SQL Server, instead
  of millisecond precision (jeremyevans)
* Add Dataset#sqltime_precision private method for adapters to use different
  precision for Sequel::SQLTime than Time and Date (jeremyevans)
* Use utc timezone in Sequel::SQLTime.create if Sequel.application_timezone is
  :utc (jeremyevans) (#1336)
* Include migration filename in message about migration file without a single
  migration (jmettraux) (#1334)
* Deprecate conversion of - to _ in adapter schemes (jeremyevans)
* Don't quote function names that are SQL::Identifiers, unless
  SQL::Function#quoted is used (jeremyevans)
* Deprecate splitting virtual row method names (jeremyevans)
* Deprecate passing blocks to virtual row methods, move to
  virtual_row_method_block extension (jeremyevans)
* Deprecate Sequel::SQL::Expression#sql_literal and #lit (jeremyevans)
* Don't issue deprecation warnings on ruby 1.8.7, as Sequel 5 is dropping
  support for it (jeremyevans)
* Deprecate Sequel::BasicObject#remove_methods! (jeremyevans)
* Deprecate sequel/no_core_ext file (jeremyevans)
* Deprecate model dataset #insert_sql accepting model instances (jeremyevans)
* Deprecate model dataset #join_table and #graph accepting model classes
  (jeremyevans)
* Support :alias option to class_table_inheritance plugin, wrapping subclass
  datasets in a subquery to fix ambiguous column issues (jeremyevans)
* Deprecate Model.set_allowed_columns and
  Model#{set_all,set_only,update_all,update_only}, move to whitelist security
  plugin (jeremyevans)
* Do not raise MassAssignmentRestriction when setting nested attributes and
  using the :fields option, only check for fields given (jeremyevans)
* Do not add class methods for private methods definined in dataset_module
  (jeremyevans)
* Deprecate Model.def_dataset_method and Model.subset, move to
  def_dataset_method plugin (jeremyevans)
* Deprecate Model.finder and Model.prepared_finder, move to finder plugin
  (jeremyevans)
* Deprecate calling Model.db= on a model with a dataset (jeremyevans)
* Deprecate splitting symbols to look for qualified/aliased identifiers
  (e.g. :table__column) (jeremyevans)
* Allow optimized lookups and deletes for models using SQL::Identifier and
  SQL::QualifiedIdentifier values as the FROM table (jeremyevans)

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>