The NetBSD Project

CVS log for pkgsrc/databases/ruby-sequel/PLIST

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / databases / ruby-sequel

Request diff between arbitrary revisions


Default branch: MAIN
Current tag: pkgsrc-2011Q2


Revision 1.7 / (download) - annotate - [select for diffs], Fri Jun 17 14:13:50 2011 UTC (12 years, 9 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2011Q2-base, pkgsrc-2011Q2
Changes since 1.6: +23 -1 lines
Diff to previous 1.6 (colored)

Update ruby-sequel package to 3.24.1.

3.24.1 (2011-06-03)

* Ignore index creation errors if using create_table? with the IF NOT EXISTS syntax (jeremyevans) (362)

3.24.0 (2011-06-01)

* Add prepared_statements_association plugin, for using prepared statements by default for regular association loading (jeremyevans)
* Add prepared_statements_safe plugin, for making prepared statement use with models more safe (jeremyevans)
* Add prepared_statements_with_pk plugin, for using prepared statements for dataset lookups by primary key (jeremyevans)
* Fix bug in emulated prepared statement support not supporting nil or false as bound values (jeremyevans)
* Add Dataset#unbind for unbinding values from a dataset, for use with creating prepared statements (jeremyevans)
* Add prepared_statements plugin for using prepared statements for updates, inserts, deletes, and lookups by primary key (jeremyevans)
* Make Dataset#[] for model datasets consider a single integer argument as a lookup by primary key (jeremyevans)
* Add Dataset#with_pk for model datasets, for finding first record with matching primary key value (jeremyevans)
* Add defaults_setter plugin for setting default values when initializing model instances (jeremyevans)
* Add around hooks (e.g. around_save) to Sequel::Model (jeremyevans)
* Add Model#initialize_set private method to ease extension writing (jeremyevans)
* Only typecast bit fields to booleans on MSSQL, the MySQL bit type is a bitfield, not a boolean (jeremyevans)
* Set SQL_AUTO_IS_NULL=0 by default when connecting to MySQL via the swift and jdbc adapters (jeremyevans)
* Fix bug in multiple column IN/NOT IN emulation when a model dataset is used (jeremyevans)
* Add support for filtering and excluding by association datasets (jeremyevans)
* Fix literalization of boolean values in filters on SQLite and MSSQL (jeremyevans)
* Add support for filtering and excluding by multiple associations (jeremyevans)
* Add support for inverting some SQL::Constant instances such as TRUE, FALSE, NULL, and NOTNULL (jeremyevans)
* Add support for excluding by associations to model datasets (jeremyevans)
* The Sequel::Postgres.use_iso_date_format setting now only affects future Database objects (jeremyevans)
* Add Sequel::Postgres::PG_NAMED_TYPES hash for extensions to register type conversions for non-standard types (jeremyevans, pvh)
* Make create_table? use IF NOT EXISTS instead of using SELECT to determine existence, if supported (jeremyevans)
* Fix bug in association_pks plugin when associated table has a different primary key column name (jfirebaugh)
* Fix limiting rows when connecting to DB2 (semmons99)
* Exclude columns from tables in the INFORMATION_SCHEMA when parsing table schema on JDBC (jeremyevans)
* Fix limiting rows when connecting to Microsoft Access (jeremyevans)
* Add Database#views for getting an array of symbols of view names for the database (jeremyevans, christian.michon)
* Make Datbase#tables no longer include view names on MySQL (jeremyevans)
* Convert Java CLOB objects to ruby strings when using the JDBC JTDS subadapter (christian.michon)
* If Thread#kill is called on a thread with an open transaction, roll the transaction back on ruby 1.8 and rubinius (jeremyevans)
* Split informix adapter into shared/specific parts, add JDBC informix subadapter (jeremyevans)

3.23.0 (2011-05-02)

* Migrate issue tracker from Google Code to GitHub Issues (jeremyevans)
* Add support for filtering by associations to model datasets (jeremyevans)
* Don¡Çt call insert_select when saving a model that doesn¡Çt select all columns of the table (jeremyevans)
* Fix bug when using :select=>[] option for a many_to_many association (jeremyevans)
* Add a columns_introspection extension that attempts to skip database queries by introspecting selected columns (jeremyevans)
* When combining old integer migrations and new timestamp migrations, make sure old integer migrations are all applied first (jeremyevans)
* Support dynamic callbacks to customize regular association loading at query time (jeremyevans)
* Support cascading of eager loading with dynamic callbacks for both eager and eager_graph (jeremyevans)
* Make the xml_serializer plugin handle namespaced models by using __ instead of / as a separator (jeremyevans)
* Allow the :eager_grapher association proc to accept a single hash instead of 3 arguments (jfirebaugh)
* Support dynamic callbacks to customize eager loading at query time (jfirebaugh, jeremyevans)
* Fix bug in the identity_map plugin for many_to_one associations when the association reflection hadn¡Çt been filled in yet (funny-falcon)
* Add serialization_modification_detection plugin for detecting changes in serialized columns (jeremyevans) (333)

3.22.0 (2011-04-01)

* Add disconnect detection to tinytds adapter, though correct behavior may require an update to tiny_tds (cult_hero)
* Add Dataset/Database#mssql_unicode_strings accessor when connecting to MSSQL to control string literalization (semmons99, jeremyevans)
* Fix ODBC::Time instance handling in the odbc adapter (jeremyevans)
* Use Sequel.application_timezone when connecting in the oracle adapter to set the connection¡Çs session¡Çs timezone (jmthomas)
* In the ADO adapter, assume access to SQL Server if a :conn_string option is given that doesn¡Çt indicate Access/Jet (damir.si) (332)
* Use the correct class when loading instances for descendents of model classes that use single table inheritance (jeremyevans)
* Support for COLLATE in column definitions (jfirebaugh)
* Don¡Çt use a schema when creating a temporary table (jeremyevans)
* Make migrator work correctly when a default_schema is set (jeremyevans) (331)

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>