The NetBSD Project

CVS log for pkgsrc/databases/ruby-sequel/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / databases / ruby-sequel

Request diff between arbitrary revisions


Default branch: MAIN
Current tag: pkgsrc-2013Q4-base


Revision 1.28 / (download) - annotate - [select for diffs], Sun Dec 8 16:51:45 2013 UTC (10 years, 4 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4
Changes since 1.27: +2 -2 lines
Diff to previous 1.27 (colored)

Update ruby-sequel to 4.5.0.

=== 4.5.0 (2013-12-02)

* Support :on_commit=>(:drop|:delete_rows|:preserve_rows) options when creating temp tables on PostgreSQL (rosenfeld) (#737)

* Make Dataset#insert work on PostgreSQL if the table name is a SQL::PlaceholderLiteralString (jeremyevans) (#736)

* Copy unique constraints when emulating alter_table operations on SQLite (jeremyevans) (#735)

* Don't return clob column values as SQL::Blob instances in the db2 and ibmdb adapters unless use_clob_as_blob is true (jeremyevans)

* Make use_clob_as_blob false by default on DB2 (jeremyevans)

* Fix usage of Sequel::SQL::Blob objects as prepared statement arguments in jdbc/db2 adapter when use_clob_as_blob is false (jeremyevans)

* Add mssql_optimistic_locking plugin, using a timestamp/rowversion column to protect against concurrent updates (pinx, jeremyevans) (#731)

* Make Model.primary_key array immutable for composite keys (chanks) (#730)

=== 4.4.0 (2013-11-01)

* Make Database#tables not show tables in the recycle bin on Oracle (jeremyevans) (#728)

* Don't automatically order on all columns when emulating offsets for unordered datasets on DB2 (jeremyevans)

* Improve PostgreSQL type support in the jdbc/postgresql adapter (jeremyevans)

* Make offset emulation on Oracle work when using columns that can't be ordered (jeremyevans, sdeming) (#724, #725)

* Make filter by associations support handle associations with :conditions or block (jeremyevans)

* Make association cloning handle :block correctly for clones of clones (jeremyevans)

* Make association cloning handle :eager_block option correctly (jeremyevans)

* Make add_primary_key work on h2 (jeremyevans)

* Add support for foreign key parsing on Oracle (jeremyevans)

* Add support for foreign key parsing to the jdbc adapter (jeremyevans)

* Make add_foreign_key work on HSQLDB (jeremyevans)

* Add table_select plugin for selecting table.* instead of * for model datasets (jeremyevans)

* Issue constraint_validation table deletes before inserts, so modifying constraint via drop/add in same alter_table block works (jeremyevans)

* Support add_*/remove_*/remove_all_* pg_array_to_many association methods on unsaved model objects (jeremyevans)

* Add Sybase SQLAnywhere support via new sqlanywhere and jdbc/sqlanywhere adapters (gditrick, jeremyevans)

* Add Dataset#offset for setting the offset separately from the limit (Paul Henry, jeremyevans) (#717)

=== 4.3.0 (2013-10-02)

* Fix literalization of empty blobs on MySQL (jeremyevans) (#715)

* Ensure Dataset#page_count in pagination extension is at least one
  (jeremyevans) (#714)

* Recognize another disconnect error in the jdbc/as400 adapter (jeremyevans)

* Make Dataset#qualify and Sequel.delay work together (jeremyevans)

* Recognize citext type as string on PostgreSQL (isc) (#710)

* Support composite keys in the rcte_tree plugin (jeremyevans)

* Support composite keys in the tree plugin (jeremyevans)

* Make Migrator.migrator_class public (robertjpayne, jeremyevans) (#708)

* Make PostgreSQL empty array literalization work correctly on PostgreSQL <8.4
  (jeremyevans)

* Add Sequel extensions guide (jeremyevans)

* Add model plugins guide (jeremyevans)

* Add error_sql Database extension, allowing DatabaseError#sql to return SQL
  query that caused underlying exception (jeremyevans)

* Make Dataset#each_page in pagination extension return enumerator if no block
  is given (justinj) (#702)

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>