[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / databases / ruby-postgresql

File: [cvs.NetBSD.org] / pkgsrc / databases / ruby-postgresql / Attic / Makefile (download)

Revision 1.29, Sat Mar 4 21:29:11 2006 UTC (18 years, 1 month ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q3-base, pkgsrc-2006Q3, pkgsrc-2006Q2-base, pkgsrc-2006Q2, pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.28: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile,v 1.29 2006/03/04 21:29:11 jlam Exp $

DISTNAME=		ruby-postgres-${VERSION}
PKGNAME=		${RUBY_PKGPREFIX}-postgresql-${VERSION}
PKGREVISION=		7
CATEGORIES=		databases ruby
MASTER_SITES=		http://raa.ruby-lang.org/cache/postgres/ \
			http://ruby.scripting.ca/postgres/archive/ \
			http://www.postgresql.jp/interfaces/ruby/archive/

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://ruby.scripting.ca/postgres/
COMMENT=		Ruby extension for postgresql

RUBY_HAS_ARCHLIB=	yes
USE_RUBY_EXTCONF= 	yes
VERSION=		0.7.1
INSTALL_TARGET=		site-install
CONFIGURE_ARGS+= --with-pgsql-include-dir=${PGSQL_PREFIX}/include/postgresql \
		 --with-pgsql-lib-dir=${PGSQL_PREFIX}/lib

DOC=			README README.ja doc/postgres.html doc/postgres.ja.html
EXAMPLE_LIBS=		losample.rb psqlHelp.rb
EXAMPLE_SCRIPTS=	psql.rb test1.rb test2.rb test4.rb
REPLACE_RUBY=		sample/psql.rb sample/test1.rb sample/test2.rb \
			sample/test4.rb

pre-install:
	@cd ${WRKSRC}; \
		${CP} -p doc/postgres.jp.html doc/postgres.ja.html

post-install:
	${INSTALL_DATA_DIR} ${RUBY_DOCDIR}/postgresql
.for f in ${DOC}
	${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/postgresql
.endfor
	${INSTALL_DATA_DIR} ${RUBY_EXAMPLESDIR}/postgresql
.for f in ${EXAMPLE_LIBS}
	${INSTALL_DATA} ${WRKSRC}/sample/${f} ${RUBY_EXAMPLESDIR}/postgresql
.endfor
.for f in ${EXAMPLE_SCRIPTS}
	${INSTALL_SCRIPT} ${WRKSRC}/sample/${f} ${RUBY_EXAMPLESDIR}/postgresql
.endfor

.include "../../lang/ruby/modules.mk"
.include "../../mk/pgsql.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"