[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / databases / ruby-postgresql

Annotation of pkgsrc/databases/ruby-postgresql/Makefile, Revision 1.15

1.15    ! recht       1: # $NetBSD: Makefile,v 1.14 2004/04/27 05:44:22 snj Exp $
1.1       mjl         2:
1.5       taca        3: DISTNAME=              ruby-postgres-${VERSION}
                      4: PKGNAME=               ${RUBY_PKGNAMEPREFIX}postgresql-${VERSION}
1.13      wiz         5: PKGREVISION=           1
1.12      taca        6: CATEGORIES=            databases ruby
1.5       taca        7: MASTER_SITES=          http://www.postgresql.jp/interfaces/ruby/archive/
                      8:
1.8       grant       9: MAINTAINER=            tech-pkg@NetBSD.org
1.5       taca       10: HOMEPAGE=              http://www.postgresql.jp/interfaces/ruby/
                     11: COMMENT=               Ruby extension for postgresql
                     12:
1.14      snj        13: USE_BUILDLINK3=                yes
1.11      taca       14:
1.9       taca       15: VERSION=               0.7.1
1.5       taca       16: DIST_SUBDIR=           ruby
                     17: USE_RUBY_EXTCONF=      yes
1.15    ! recht      18: CONFIGURE_ARGS+=       --with-pgsql-include-dir=${PGSQL_PREFIX}/include/postgresql \
        !            19:                        --with-pgsql-lib-dir=${PGSQL_PREFIX}/lib
1.5       taca       20: INSTALL_TARGET=                site-install
                     21:
                     22: DOC=                   README README.ja doc/postgres.html doc/postgres.ja.html
                     23: EXAMPLE_LIBS=          losample.rb psqlHelp.rb
                     24: EXAMPLE_SCRIPTS=       psql.rb test1.rb test2.rb test4.rb
                     25: REPLACE_RUBY=          sample/psql.rb sample/test1.rb sample/test2.rb \
                     26:                        sample/test4.rb
                     27:
                     28: pre-install:
                     29:        @cd ${WRKSRC}; \
                     30:                ${CP} -p doc/postgres.jp.html doc/postgres.ja.html
1.3       taca       31:
                     32: post-install:
1.5       taca       33:        ${INSTALL_DATA_DIR} ${RUBY_DOCDIR}/postgresql
1.3       taca       34: .for f in ${DOC}
                     35:        ${INSTALL_DATA} ${WRKSRC}/$f ${RUBY_DOCDIR}/postgresql
                     36: .endfor
                     37:        ${INSTALL_DATA_DIR} ${RUBY_EXAMPLESDIR}/postgresql
                     38: .for f in ${EXAMPLE_LIBS}
                     39:        ${INSTALL_DATA} ${WRKSRC}/sample/$f ${RUBY_EXAMPLESDIR}/postgresql
                     40: .endfor
                     41: .for f in ${EXAMPLE_SCRIPTS}
                     42:        ${INSTALL_SCRIPT} ${WRKSRC}/sample/$f ${RUBY_EXAMPLESDIR}/postgresql
                     43: .endfor
1.1       mjl        44:
                     45: .include "../../lang/ruby-base/Makefile.common"
1.14      snj        46: .include "../../lang/ruby-base/buildlink3.mk"
1.15    ! recht      47: .include "../../mk/pgsql.buildlink3.mk"
1.1       mjl        48: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>