The NetBSD Project

CVS log for pkgsrc/databases/ruby-mysql/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / databases / ruby-mysql

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.41 / (download) - annotate - [select for diffs], Thu Sep 1 15:29:29 2022 UTC (14 months, 3 weeks ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, HEAD
Changes since 1.40: +7 -22 lines
Diff to previous 1.40 (colored)

databases/ruby-mysql: update to 3.0.1

pkgsrc change:
* Switch to use gem, 3.0 release.
* Change HOMEPAGE to github page.

[3.0.1] - 2022-06-18

* LICENSE: correct author
* FIX: correct LOAD DATA LOCAL INFILE result information.
* FIX: reset SERVER_MORE_RESULTS_EXISTS when error packet is received.
* FIX: close the socket when the connection is disconnected.
* FIX: allow multiple results by default.

[3.0.0] - 2021-11-16

* Mysql.new no longer connect. use Mysql.connect or Mysql#connect.
* Mysql.init is removed. use Mysql.new instead.

* Mysql.new, Mysql.conncet and Mysql#connect takes URI object or URI string
  or Hash object.

  example:
  Mysql.connect('mysql://user:password@hostname:port/dbname?charset=ascii')
  Mysql.connect('mysql://user:password@%2Ftmp%2Fmysql.sock/dbname?charset=ascii') # for UNIX socket
  Mysql.connect('hostname', 'user', 'password', 'dbname')
  Mysql.connect(host: 'hostname', username: 'user', password: 'password', database: 'dbname')

* Mysql.options is removed. use Mysql#param = value instead. For example:

	m = Mysql.init m.options(Mysql::OPT_LOCAL_INFILE, true)
	m.connect(host, user, passwd)

  change to

	m = Mysql.new m.local_infile = true
	m.connect(host, user, passwd)

  or

	m = Mysql.connect(host, user, passwd, local_infile: true)

* Mysql::Time is removed. Instead, Time object is returned for the DATE,
  DATETIME, TIMESTAMP data, and Integer object is returned for the TIME
  data.  If DATE, DATETIME, TIMESTAMP are invalid values for Time, nil is
  returned.

* meaningless methods are removed:

     bind_result
     client_info
     client_version
     get_proto_info
     get_server_info
     get_server_version
     proto_info
     query_with_result

* alias method are removed:

     get_host_info: use host_info
     real_connect: use connect
     real_query: use query

* methods corresponding to deprecated APIs in MySQL are removed:

     list_dbs: use SHOW DATABASES
     list_fields: use SHOW COLUMNS
     list_processes: use SHOW PROCESSLIST
     list_tables: use SHOW TABLES

Revision 1.40 / (download) - annotate - [select for diffs], Wed Jun 23 20:33:09 2021 UTC (2 years, 5 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3
Changes since 1.39: +2 -1 lines
Diff to previous 1.39 (colored)

Revbump for MySQL default change

Revision 1.39 / (download) - annotate - [select for diffs], Mon Sep 18 02:48:08 2017 UTC (6 years, 2 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.38: +3 -3 lines
Diff to previous 1.38 (colored)

databases/ruby-mysql: udpate to 2.9.14

Better support for MySQL 5.7.

* avoid warning
* add collations and constants from MySQL 5.7.10
* support JSON type on MySQL 5.7

Revision 1.38 / (download) - annotate - [select for diffs], Tue May 19 13:32:38 2015 UTC (8 years, 6 months ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2
Changes since 1.37: +11 -11 lines
Diff to previous 1.37 (colored)

Update to 2.9.13

* Fix build with Ruby 2.2.
* Use setup.rb instead of extconf.rb.
* Use GITHUB framework.

Changelog:
Not available.

Revision 1.37 / (download) - annotate - [select for diffs], Sat Mar 2 20:33:24 2013 UTC (10 years, 8 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1
Changes since 1.36: +2 -2 lines
Diff to previous 1.36 (colored)

Bump PKGREVISION for mysql default change to 55.

Revision 1.36 / (download) - annotate - [select for diffs], Tue Oct 2 21:25:51 2012 UTC (11 years, 1 month ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.35: +1 -3 lines
Diff to previous 1.35 (colored)

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

Revision 1.35 / (download) - annotate - [select for diffs], Sat Sep 15 15:03:23 2012 UTC (11 years, 2 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3
Changes since 1.34: +2 -2 lines
Diff to previous 1.34 (colored)

Recursive bump from mysql51-client library changed to use openssl.

Revision 1.32.4.1 / (download) - annotate - [select for diffs], Sun Feb 27 00:26:13 2011 UTC (12 years, 9 months ago) by tron
Branch: pkgsrc-2010Q4
Changes since 1.32: +2 -2 lines
Diff to previous 1.32 (colored) next main 1.33 (colored)

Pullup ticket #3361 - requested by taca
archivers/ruby-libarchive: dependence update
comms/ruby-termios: dependence update
converters/ruby-uconv: dependence update
databases/ruby-do_sqlite3: dependence update
databases/ruby-ldap: dependence update
databases/ruby-mysql: dependence update
databases/ruby-odbc: dependence update
databases/ruby-pg: dependence update
databases/ruby-postgresql: dependence update
databases/ruby-qdbm: dependence update
databases/ruby-sqlite: dependence update
databases/ruby-sqlite3: dependence update
databases/ruby-tokyocabinet: dependence update
devel/ruby-SDL: dependence update
devel/ruby-debug-base: dependence update
devel/ruby-eet: dependence update
devel/ruby-eventmachine: dependence update
devel/ruby-ffi: dependence update
devel/ruby-gnome2-atk: dependence update
devel/ruby-gnome2-bonobo: dependence update
devel/ruby-gnome2-bonoboui: dependence update
devel/ruby-gnome2-gconf: dependence update
devel/ruby-gnome2-gio: dependence update
devel/ruby-gnome2-glib: dependence update
devel/ruby-gnome2-libglade: dependence update
devel/ruby-gnome2-pango: dependence update
devel/ruby-linecache: dependence update
devel/ruby-memcache: dependence update
devel/ruby-ncurses: dependence update
devel/ruby-priority-queue: dependence update
devel/ruby-racc: dependence update
devel/ruby-rbtree: dependence update
devel/ruby-rcov: dependence update
devel/ruby-rcsparse: dependence update
devel/ruby-subversion: dependence update
devel/ruby-thrift: dependence update
graphics/ruby-RMagick: dependence update
graphics/ruby-clutter-cairo: dependence update
graphics/ruby-clutter-core: dependence update
graphics/ruby-clutter-gtk: dependence update
graphics/ruby-gd: dependence update
graphics/ruby-gnome2-gdkpixbuf: dependence update
graphics/ruby-gnome2-gnomecanvas: dependence update
graphics/ruby-gnome2-goocanvas: dependence update
graphics/ruby-gnome2-gtkglext: dependence update
graphics/ruby-gnome2-libart: dependence update
graphics/ruby-gnome2-rsvg: dependence update
graphics/ruby-imlib2: dependence update
graphics/ruby-opengl: dependence update
graphics/ruby-rcairo: dependence update
inputmethod/ruby-zinnia: dependence update
lang/ruby: dependence update
lang/ruby18-base: security update
lang/ruby19-base: security update
mail/ruby-tmail: dependence update
math/ruby-rb-gsl: dependence update
multimedia/ruby-clutter-gst: dependence update
multimedia/ruby-gnome2-gstreamer: dependence update
multimedia/ruby-ming: dependence update
print/ruby-gnome2-gnomeprint: dependence update
print/ruby-gnome2-gnomeprintui: dependence update
print/ruby-gnome2-poppler: dependence update
security/ruby-password: dependence update
security/ruby-tcpwrap: dependence update
sysutils/ruby-quota: dependence update
textproc/ruby-bluecloth: dependence update
textproc/ruby-cabocha: dependence update
textproc/ruby-eruby: dependence update
textproc/ruby-ferret: dependence update
textproc/ruby-hpricot: dependence update
textproc/ruby-itex2MML: dependence update
textproc/ruby-json: dependence update
textproc/ruby-libxml: dependence update
textproc/ruby-mecab: dependence update
textproc/ruby-native-hyperestraier: dependence update
textproc/ruby-nokogiri: dependence update
textproc/ruby-oniguruma: dependence update
textproc/ruby-redcloth: dependence update
textproc/ruby-sary: dependence update
textproc/ruby-xmlparser: dependence update
textproc/ruby-xslt: dependence update
textproc/ruby-yamcha: dependence update
www/mongrel: dependence update
www/ruby-clearsilver: dependence update
www/ruby-fcgi: dependence update
www/ruby-gnome2-gtkhtml2: dependence update
www/ruby-gnome2-gtkmozembed: dependence update
www/ruby-patron: dependence update
www/thin: dependence update
x11/ruby-gnome2-gnome: dependence update
x11/ruby-gnome2-gtk: dependence update
x11/ruby-gnome2-gtksourceview: dependence update
x11/ruby-gnome2-gtksourceview2: dependence update
x11/ruby-gnome2-panelapplet: dependence update
x11/ruby-gnome2-vte: dependence update

Revisions pulled up:
- archivers/ruby-libarchive/Makefile				1.2
- comms/ruby-termios/Makefile					1.23
- converters/ruby-uconv/Makefile				1.19
- databases/ruby-do_sqlite3/Makefile				1.2
- databases/ruby-ldap/Makefile					1.7
- databases/ruby-mysql/Makefile					1.34 via patch
- databases/ruby-odbc/Makefile					1.10 via patch
- databases/ruby-pg/Makefile					1.6
- databases/ruby-postgresql/Makefile				1.37
- databases/ruby-qdbm/Makefile					1.12
- databases/ruby-sqlite/Makefile				1.3
- databases/ruby-sqlite3/Makefile				1.15
- databases/ruby-tokyocabinet/Makefile				1.24
- devel/ruby-SDL/Makefile					1.9 via patch
- devel/ruby-debug-base/Makefile				1.7
- devel/ruby-eet/Makefile					1.8
- devel/ruby-eventmachine/Makefile				1.7
- devel/ruby-ffi/Makefile					1.3
- devel/ruby-gnome2-atk/Makefile				1.8
- devel/ruby-gnome2-bonobo/Makefile				patch
- devel/ruby-gnome2-bonoboui/Makefile				patch
- devel/ruby-gnome2-gconf/Makefile				patch
- devel/ruby-gnome2-gio/Makefile				1.3 via patch
- devel/ruby-gnome2-glib/Makefile				1.11
- devel/ruby-gnome2-libglade/Makefile				patch
- devel/ruby-gnome2-pango/Makefile				1.18 via patch
- devel/ruby-linecache/Makefile					1.5
- devel/ruby-memcache/Makefile					1.4
- devel/ruby-ncurses/Makefile					1.9
- devel/ruby-priority-queue/Makefile				1.6
- devel/ruby-racc/Makefile					1.18
- devel/ruby-rbtree/Makefile					1.6
- devel/ruby-rcov/Makefile					1.5
- devel/ruby-rcsparse/Makefile					1.10
- devel/ruby-subversion/Makefile				1.28
- devel/ruby-thrift/Makefile					1.4 via patch
- graphics/ruby-RMagick/Makefile				1.76 via patch
- graphics/ruby-clutter-cairo/Makefile				1.8 via patch
- graphics/ruby-clutter-core/Makefile				1.11 via patch
- graphics/ruby-clutter-gtk/Makefile				1.8 via patch
- graphics/ruby-gd/Makefile					1.34 via patch
- graphics/ruby-gnome2-gdkpixbuf/Makefile			1.20 via patch
- graphics/ruby-gnome2-gnomecanvas/Makefile			patch
- graphics/ruby-gnome2-goocanvas/Makefile			1.12 via patch
- graphics/ruby-gnome2-gtkglext/Makefile			patch
- graphics/ruby-gnome2-libart/Makefile				patch
- graphics/ruby-gnome2-rsvg/Makefile				1.21 va patch
- graphics/ruby-imlib2/Makefile					1.24 va patch
- graphics/ruby-opengl/Makefile					1.31
- graphics/ruby-rcairo/Makefile					1.22 via patch
- inputmethod/ruby-zinnia/Makefile				1.3
- lang/ruby/buildlink3.mk					1.13
- lang/ruby/rubyversion.mk					1.58-1.59
- lang/ruby18-base/distinfo					1.47
- lang/ruby19-base/DEINSTALL					1.2
- lang/ruby19-base/Makefile					1.7
- lang/ruby19-base/PLIST					1.4
- lang/ruby19-base/distinfo					1.4
- lang/ruby19-base/patches/patch-string.c			1.1
- mail/ruby-tmail/Makefile					1.19
- math/ruby-rb-gsl/Makefile					1.9
- multimedia/ruby-clutter-gst/Makefile				1.9 via patch
- multimedia/ruby-gnome2-gstreamer/Makefile			1.7
- multimedia/ruby-ming/Makefile					1.15 via patch
- print/ruby-gnome2-gnomeprint/Makefile				patch
- print/ruby-gnome2-gnomeprintui/Makefile			patch
- print/ruby-gnome2-poppler/Makefile				1.19 via patch
- security/ruby-password/Makefile				1.5
- security/ruby-tcpwrap/Makefile				1.18
- sysutils/ruby-quota/Makefile					1.21
- textproc/ruby-bluecloth/Makefile				1.5
- textproc/ruby-cabocha/Makefile				1.3
- textproc/ruby-eruby/Makefile					1.26
- textproc/ruby-ferret/Makefile					1.6
- textproc/ruby-hpricot/Makefile				1.8
- textproc/ruby-itex2MML/Makefile				1.7
- textproc/ruby-json/Makefile					1.9
- textproc/ruby-libxml/Makefile					1.7
- textproc/ruby-mecab/Makefile					1.6
- textproc/ruby-native-hyperestraier/Makefile			1.6
- textproc/ruby-nokogiri/Makefile				1.4
- textproc/ruby-oniguruma/Makefile				1.6
- textproc/ruby-redcloth/Makefile				1.14
- textproc/ruby-sary/Makefile					1.7
- textproc/ruby-xmlparser/Makefile				1.15
- textproc/ruby-xslt/Makefile					1.7
- textproc/ruby-yamcha/Makefile					1.3
- www/mongrel/Makefile						1.13 via patch
- www/ruby-clearsilver/Makefile					1.15
- www/ruby-fcgi/Makefile					1.15
- www/ruby-gnome2-gtkhtml2/Makefile				patch
- www/ruby-gnome2-gtkmozembed/Makefile				1.17 via patch
- www/ruby-patron/Makefile					1.5
- www/thin/Makefile						1.8 via patch
- x11/ruby-gnome2-gtk/Makefile					1.25 via patch
- x11/ruby-gnome2-gtksourceview/Makefile			patch via 1.12
- x11/ruby-gnome2-gtksourceview2/Makefile			patch
- x11/ruby-gnome2-panelapplet/Makefile				patch
- x11/ruby-gnome2-vte/Makefile					1.16 via patch
---
Module Name:	pkgsrc
Module Name:	pkgsrc
Committed By:	taca
Date:		Mon Feb 21 14:31:06 UTC 2011

Modified Files:
	pkgsrc/lang/ruby: rubyversion.mk

Log Message:
* Start upate of ruby18 and ruby19 packags.
* Remove redundant GEM_HOME definition from PLIST.
---
Module Name:	pkgsrc
Module Name:	pkgsrc
Committed By:	taca
Date:		Mon Feb 21 14:35:38 UTC 2011

Modified Files:
	pkgsrc/lang/ruby18-base: distinfo

Log Message:
Update ruby18-base package to 1.8.7.334 (Ruby 1.8.7p334).

* The FileUtils Vulnerability

	http://www.ruby-lang.org/en/news/2011/02/18/fileutils-is-vulnerable-to-symlink-race-attacks/

* The $SAFE Vulnerability

Fri Feb 18 21:18:55 2011  Shugo Maeda  <shugo@ruby-lang.org>

	* test/ruby/test_exception.rb (TestException::test_to_s_taintness_propagation):
	  Test for below.

Fri Feb 18 21:18:55 2011  URABE Shyouhei  <shyouhei@ruby-lang.org>

	* error.c (exc_to_s): untainted strings can be tainted via
	  Exception#to_s, which enables attackers to overwrite sane strings.
	  Reported by: Yusuke Endoh <mame at tsg.ne.jp>.

	* error.c (name_err_to_s): ditto.

Fri Feb 18 21:17:22 2011  Shugo Maeda  <shugo@ruby-lang.org>

	* lib/fileutils.rb (FileUtils::remove_entry_secure): there is a
	  race condition in the case where the given path is a directory,
	  and some other user can move that directory, and create a
	  symlink while this method is executing.
	  Reported by: Nicholas Jefferson <nicholas at pythonic.com.au>

Fri Feb 18 19:46:46 2011  NAKAMURA Usaku  <usa@ruby-lang.org>

	* win32/win32.c (init_stdhandle): backport mistake of r29382.
	  some code are needless in ruby 1.8.
	  [ruby-core:34579]

Fri Feb 18 19:22:17 2011  URABE Shyouhei  <shyouhei@ruby-lang.org>

	* configure.in: revert revision r29854.	 This revision introduced
	  binary incompatibilities on some circumstances.  The bug that
	  revision was fixing gets reopened by this reversion.
	  [ruby-dev:43152] cf. [Bug #2553]
---
Module Name:	pkgsrc
Module Name:	pkgsrc
Committed By:	taca
Date:		Mon Feb 21 14:44:11 UTC 2011

Modified Files:
	pkgsrc/lang/ruby19-base: DEINSTALL Makefile PLIST distinfo
Added Files:
	pkgsrc/lang/ruby19-base/patches: patch-string.c

Log Message:
Update ruby19-base package to 1.9.2pl180 (Ruby 1.9.2 p180).

* The FileUtils Vulnerability

    http://www.ruby-lang.org/en/news/2011/02/18/fileutils-is-vulnerable-to-symlink-race-attacks/

* Add a patch r30779 from repository; a bug of utf-8 string handling.

For more detail changes of Ruby 1.9.2pl180, please refer:
	http://svn.ruby-lang.org/repos/ruby/tags/v1_9_2_180/ChangeLog
---
Module Name:	pkgsrc
Module Name:	pkgsrc
Committed By:	taca
Date:		Mon Feb 21 15:00:34 UTC 2011

Modified Files:
	pkgsrc/lang/ruby: buildlink3.mk rubyversion.mk

Log Message:
Introduce RUBY_ABI_VERSION and use it BUILDLINK_ABI_DEPENDS.

There are ABI incompatibility amaong Ruby 1.8.7 patchlevel 302, 330 and 334,
So it would be handle if such problem in future.
---
Module Name:	pkgsrc
Module Name:	pkgsrc
Committed By:	taca
Date:		Mon Feb 21 16:01:24 UTC 2011

Modified Files:
	pkgsrc/archivers/ruby-libarchive: Makefile
	pkgsrc/comms/ruby-termios: Makefile
	pkgsrc/converters/ruby-uconv: Makefile
	pkgsrc/databases/ruby-do_sqlite3: Makefile
	pkgsrc/databases/ruby-ldap: Makefile
	pkgsrc/databases/ruby-mysql: Makefile
	pkgsrc/databases/ruby-odbc: Makefile
	pkgsrc/databases/ruby-pg: Makefile
	pkgsrc/databases/ruby-postgresql: Makefile
	pkgsrc/databases/ruby-qdbm: Makefile
	pkgsrc/databases/ruby-sqlite: Makefile
	pkgsrc/databases/ruby-sqlite3: Makefile
	pkgsrc/databases/ruby-tokyocabinet: Makefile
	pkgsrc/devel/ruby-SDL: Makefile
	pkgsrc/devel/ruby-debug-base: Makefile
	pkgsrc/devel/ruby-eet: Makefile
	pkgsrc/devel/ruby-eventmachine: Makefile
	pkgsrc/devel/ruby-ffi: Makefile
	pkgsrc/devel/ruby-gnome2-atk: Makefile
	pkgsrc/devel/ruby-gnome2-gio: Makefile
	pkgsrc/devel/ruby-gnome2-glib: Makefile
	pkgsrc/devel/ruby-gnome2-pango: Makefile
	pkgsrc/devel/ruby-linecache: Makefile
	pkgsrc/devel/ruby-memcache: Makefile
	pkgsrc/devel/ruby-ncurses: Makefile
	pkgsrc/devel/ruby-priority-queue: Makefile
	pkgsrc/devel/ruby-racc: Makefile
	pkgsrc/devel/ruby-rbtree: Makefile
	pkgsrc/devel/ruby-rcov: Makefile
	pkgsrc/devel/ruby-rcsparse: Makefile
	pkgsrc/devel/ruby-subversion: Makefile
	pkgsrc/devel/ruby-thrift: Makefile
	pkgsrc/graphics/ruby-RMagick: Makefile
	pkgsrc/graphics/ruby-clutter-cairo: Makefile
	pkgsrc/graphics/ruby-clutter-core: Makefile
	pkgsrc/graphics/ruby-clutter-gtk: Makefile
	pkgsrc/graphics/ruby-gd: Makefile
	pkgsrc/graphics/ruby-gnome2-gdkpixbuf: Makefile
	pkgsrc/graphics/ruby-gnome2-goocanvas: Makefile
	pkgsrc/graphics/ruby-gnome2-rsvg: Makefile
	pkgsrc/graphics/ruby-imlib2: Makefile
	pkgsrc/graphics/ruby-opengl: Makefile
	pkgsrc/graphics/ruby-rcairo: Makefile
	pkgsrc/inputmethod/ruby-zinnia: Makefile
	pkgsrc/mail/ruby-tmail: Makefile
	pkgsrc/math/ruby-rb-gsl: Makefile
	pkgsrc/multimedia/ruby-clutter-gst: Makefile
	pkgsrc/multimedia/ruby-gnome2-gstreamer: Makefile
	pkgsrc/multimedia/ruby-ming: Makefile
	pkgsrc/print/ruby-gnome2-poppler: Makefile
	pkgsrc/security/ruby-password: Makefile
	pkgsrc/security/ruby-tcpwrap: Makefile
	pkgsrc/sysutils/ruby-quota: Makefile
	pkgsrc/textproc/ruby-bluecloth: Makefile
	pkgsrc/textproc/ruby-cabocha: Makefile
	pkgsrc/textproc/ruby-eruby: Makefile
	pkgsrc/textproc/ruby-ferret: Makefile
	pkgsrc/textproc/ruby-hpricot: Makefile
	pkgsrc/textproc/ruby-itex2MML: Makefile
	pkgsrc/textproc/ruby-json: Makefile
	pkgsrc/textproc/ruby-libxml: Makefile
	pkgsrc/textproc/ruby-mecab: Makefile
	pkgsrc/textproc/ruby-native-hyperestraier: Makefile
	pkgsrc/textproc/ruby-nokogiri: Makefile
	pkgsrc/textproc/ruby-oniguruma: Makefile
	pkgsrc/textproc/ruby-redcloth: Makefile
	pkgsrc/textproc/ruby-sary: Makefile
	pkgsrc/textproc/ruby-xmlparser: Makefile
	pkgsrc/textproc/ruby-xslt: Makefile
	pkgsrc/textproc/ruby-yamcha: Makefile
	pkgsrc/www/mongrel: Makefile
	pkgsrc/www/ruby-clearsilver: Makefile
	pkgsrc/www/ruby-fcgi: Makefile
	pkgsrc/www/ruby-gnome2-gtkmozembed: Makefile
	pkgsrc/www/ruby-patron: Makefile
	pkgsrc/www/thin: Makefile
	pkgsrc/x11/ruby-gnome2-gtk: Makefile
	pkgsrc/x11/ruby-gnome2-gtksourceview2: Makefile
	pkgsrc/x11/ruby-gnome2-vte: Makefile

Log Message:
Bump PKGREVISION due to ABI change of ruby18-base.

Revision 1.34 / (download) - annotate - [select for diffs], Mon Feb 21 16:01:11 2011 UTC (12 years, 9 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1
Changes since 1.33: +2 -2 lines
Diff to previous 1.33 (colored)

Bump PKGREVISION due to ABI change of ruby18-base.

Revision 1.33 / (download) - annotate - [select for diffs], Mon Feb 7 14:55:55 2011 UTC (12 years, 9 months ago) by taca
Branch: MAIN
Changes since 1.32: +1 -2 lines
Diff to previous 1.32 (colored)

Remove RUBY_REQD which specify older version of
current supported version of Ruby.

No functional change.

Revision 1.32 / (download) - annotate - [select for diffs], Thu Sep 30 10:49:16 2010 UTC (13 years, 2 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2010Q4-base, pkgsrc-2010Q3-base, pkgsrc-2010Q3
Branch point for: pkgsrc-2010Q4
Changes since 1.31: +2 -1 lines
Diff to previous 1.31 (colored)

Bump PKGREVISION by default mysql version changed from 5.0 to 5.1.

Revision 1.31 / (download) - annotate - [select for diffs], Fri Sep 10 04:34:12 2010 UTC (13 years, 2 months ago) by taca
Branch: MAIN
Changes since 1.30: +6 -6 lines
Diff to previous 1.30 (colored)

Update databases/ruby-mysql to 2.8.2.

* Use lang/ruby/gem.mk instead of misc/rubygems/rubygem.mk.
* Add LICENSE.
* Remove RUBY_HAS_ARCHLIB.
* Add PKG_DESTDIR_SUPPORT.
* Private patch isn't needed any more.

version 2.8.2

    * Fix: Mysql#insert_id returns invalid value when larger than 2**32.

Revision 1.30 / (download) - annotate - [select for diffs], Sat Oct 17 06:59:26 2009 UTC (14 years, 1 month ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4
Changes since 1.29: +2 -2 lines
Diff to previous 1.29 (colored)

Enable LICENSE.

Revision 1.29 / (download) - annotate - [select for diffs], Sat Oct 17 06:31:41 2009 UTC (14 years, 1 month ago) by taca
Branch: MAIN
Changes since 1.28: +7 -4 lines
Diff to previous 1.28 (colored)

Update ruby-mysql package to 2.8.1.

pkgsrc change:
	* Add commented out LICENSE (not sure GPL's version).
	* Enable DESTDIR support.


2009-02-01
  version 2.8.1
     * correspond to Ruby 1.9.1

2008-09-29
  version 2.8
  version 2.7.7
     * When connecting to MySQL, EINTR is occurred sometimes ([ruby-dev:31842])
     * MySQL/Ruby 2.7.* can not be compiled on Ruby 1.8.5.

Revision 1.28 / (download) - annotate - [select for diffs], Sun Jun 22 15:51:14 2008 UTC (15 years, 5 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3, pkgsrc-2008Q2-base, pkgsrc-2008Q2, cwrapper, cube-native-xorg-base, cube-native-xorg
Changes since 1.27: +3 -4 lines
Diff to previous 1.27 (colored)

Update ruby-mysql package to 2.7.6.

2008-06-17
    version 2.7.6
     * On 64bit machine, Mysql::Stmt#execute raise error on large numeric
        value(>= 2**30).
2008-03-08
    version 2.7.5
     * On 64bit machine, Mysql::Stmt#fetch return invalid numeric value.
2007-12-26
    version 2.8pre1
     * for Ruby 1.9.0
     * Incompat: Mysql::Result#each_hash don't create column name string each
        row. it's shared.
     * Incompat: Mysql#query with block no longer turn on multi-statements
        mode automatically.
2007-08-22
    version 2.7.4
     * BUG: Mysql::Stmt#execute memory leak.

Revision 1.27 / (download) - annotate - [select for diffs], Thu Jun 19 14:44:39 2008 UTC (15 years, 5 months ago) by taca
Branch: MAIN
Changes since 1.26: +5 -5 lines
Diff to previous 1.26 (colored)

Switch to use vendor_dir with Ruby 1.8.7.

Bump PKGREVISION.

Revision 1.26 / (download) - annotate - [select for diffs], Thu Feb 22 19:26:19 2007 UTC (16 years, 9 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2008Q1-base, pkgsrc-2008Q1, pkgsrc-2007Q4-base, pkgsrc-2007Q4, pkgsrc-2007Q3-base, pkgsrc-2007Q3, pkgsrc-2007Q2-base, pkgsrc-2007Q2, pkgsrc-2007Q1-base, pkgsrc-2007Q1
Changes since 1.25: +2 -2 lines
Diff to previous 1.25 (colored)

Whitespace cleanup, courtesy of pkglint.
Patch provided by Sergey Svishchev in private mail.

Revision 1.25 / (download) - annotate - [select for diffs], Sun Jan 28 15:21:06 2007 UTC (16 years, 10 months ago) by taca
Branch: MAIN
Changes since 1.24: +3 -4 lines
Diff to previous 1.24 (colored)

Update ruby-mysql package to 2.7.3.

2006-12-20
    version 2.7.3
     - BUG: Mysql#query with block is stopped when last query failed.
2006-10-28
    version 2.7.2
     - BUG: Mysql::Stmt#result_metadata don't return nil. (Thanks to
        Hidetoshi)
     - BUG: Mysql#close check mysql_errno.
     - BUG: multistatement Mysql#query with block ignore error.
     - extconf.rb for Visual C++. (Thanks to Shugo Maeda)
     - support MySQL BIT type.
     - add Mysql::Field::TYPE_BIT, TYPE_NEWDECIMAL.

Revision 1.24 / (download) - annotate - [select for diffs], Wed Sep 13 13:12:54 2006 UTC (17 years, 2 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2006Q4-base, pkgsrc-2006Q4, pkgsrc-2006Q3-base, pkgsrc-2006Q3
Changes since 1.23: +3 -3 lines
Diff to previous 1.23 (colored)

- Use "--with-mysql-config" option to CONFIGURE_ARGS.
- Include my_global.h header to make sure to define "ulong" on FreeBSD
  and DragonFly BSD.

Bump PKGREVISION.

Revision 1.23 / (download) - annotate - [select for diffs], Mon Aug 7 16:13:52 2006 UTC (17 years, 3 months ago) by taca
Branch: MAIN
Changes since 1.22: +3 -4 lines
Diff to previous 1.22 (colored)

Update ruby-mysql to 2.7.1.

o change free() to xfree(). To avoid crash on Windows. (Thanks Tobias Grimm)

Revision 1.22 / (download) - annotate - [select for diffs], Sun Feb 5 23:08:37 2006 UTC (17 years, 9 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2006Q2-base, pkgsrc-2006Q2, pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.21: +2 -2 lines
Diff to previous 1.21 (colored)

Recursive revision bump / recommended bump for gettext ABI change.

Revision 1.21 / (download) - annotate - [select for diffs], Sun Jan 8 18:35:08 2006 UTC (17 years, 10 months ago) by xtraeme
Branch: MAIN
Changes since 1.20: +2 -2 lines
Diff to previous 1.20 (colored)

Bump PKGREVISION due to mysql.buildlink3.mk changes (default mysql
pkg has been changed to 5.x). Reminded by wiz... thanks.

Revision 1.20 / (download) - annotate - [select for diffs], Tue Jan 3 15:07:29 2006 UTC (17 years, 10 months ago) by taca
Branch: MAIN
Changes since 1.19: +2 -2 lines
Diff to previous 1.19 (colored)

Bump PKGREVISION by update of ruby18-base package.

Revision 1.19 / (download) - annotate - [select for diffs], Thu Nov 3 07:17:39 2005 UTC (18 years ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2005Q4-base, pkgsrc-2005Q4
Changes since 1.18: +1 -2 lines
Diff to previous 1.18 (colored)

Remove specifying RUBY_VERSION_SUPPORTED.

Revision 1.18 / (download) - annotate - [select for diffs], Wed Nov 2 09:48:33 2005 UTC (18 years, 1 month ago) by taca
Branch: MAIN
Changes since 1.17: +2 -1 lines
Diff to previous 1.17 (colored)

Bump PKGREVISION of packages including ruby extention library
by  Ruby 1.8.3 updates.

Revision 1.17 / (download) - annotate - [select for diffs], Wed Nov 2 08:32:44 2005 UTC (18 years, 1 month ago) by taca
Branch: MAIN
Changes since 1.16: +3 -1 lines
Diff to previous 1.16 (colored)

- Mark this package ruby18-base only.
- And Ruby 1.8.2 and lator.

Revision 1.16 / (download) - annotate - [select for diffs], Sun Sep 4 06:30:08 2005 UTC (18 years, 2 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2005Q3-base, pkgsrc-2005Q3
Changes since 1.15: +4 -4 lines
Diff to previous 1.15 (colored)

Update ruby-mysql pacakge to 2.7.

Changes:

2005-08-22
    version 2.7

	* add constants for Mysql#options: Mysql::OPT_GUESS_CONNECTION,
	  Mysql::OPT_USE_EMBEDDED_CONNECTION,
	  Mysql::OPT_USE_REMOTE_CONNECTION, Mysql::SET_CLIENT_IP
	* test.rb: for 4.0.x, 5.0.x

2005-08-16
    version 2.7-beta3

	* add Mysql::Stmt#bind_result

2005-08-02
    version 2.7-beta2

	* BUG: mysql.c.in: fetch_hash: nil value doesn't exist in
	  hash. (Thanks Stefan Kaes)
	* add constant Mysql::VERSION.
	* add Mysql#prepare

2005-07-24
    version 2.7-beta

	* add Mysql#stmt_init method
	* add Mysql::Stmt, Mysql::Time, Mysql::RowOffset class
	* add Mysql::Error#sqlstate method
	* change offset value to Mysql::RowOffset object that is used
	  by Mysql::Result#row_seek,row_tell

2005-07-31
    version 2.6.3

	* add constant Mysql::VERSION.

2005-07-26
    version 2.6.2

	* BUG: mysql.c.in: fetch_hash: nil value doesn't exist in
          hash. (Thanks Stefan Kaes)

2005-06-28
    version 2.6.1

	* mysql.c.in: fix to compile error on MacOSX.

Revision 1.15 / (download) - annotate - [select for diffs], Sun Jun 12 15:23:03 2005 UTC (18 years, 5 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2005Q2-base, pkgsrc-2005Q2
Changes since 1.14: +5 -6 lines
Diff to previous 1.14 (colored)

Update ruby-mysql package to 2.6.  (not security fix but leaf pacakge.)

pkgsrc changes:
- Change HOMEPAGE in English.
- Add style sheet to installed documents.

distribution changes:

2005-04-25: version 2.6

	* add constants for Mysql#option(): Mysql::OPT_PROTOCOL,
	  Mysql::OPT_READ_TIMEOUT, Mysql::OPT_WRITE_TIMEOUT,
	  Mysql::SET_CHARSET_DIR, Mysql::SET_CHARSET_NAME,
	  Mysql::SHARED_MEMORY_BASE_NAME, Mysql::SECURE_AUTH
	* add methods: Mysql#more_results?(), Mysql#next_result(),
	  Mysql#set_server_option(), Mysql#sqlstate()
	* add constants for Mysql#connect(): Mysql::CLIENT_MULTI_STATEMENTS,
	  Mysql::CLIENT_MULTI_RESULTS
	* add constants for Mysql#set_server_option():
	  Mysql::OPTION_MULTI_STATEMENTS_ON, Mysql::OPTION_MULTI_STATEMENTS_OFF
	* add Mysql#query() with block
	* add Mysql#reconnect(), Mysql#reconnect=()
	* When connection was closed, it don't try to reconnect by default.

2005-02-12: version 2.5.2

	* BUG: Mysql#connect make object to not close. (Thanks Andres Salomon)

Revision 1.14 / (download) - annotate - [select for diffs], Mon Apr 11 21:45:16 2005 UTC (18 years, 7 months ago) by tv
Branch: MAIN
Changes since 1.13: +1 -2 lines
Diff to previous 1.13 (colored)

Remove USE_BUILDLINK3 and NO_BUILDLINK; these are no longer used.

Revision 1.13 / (download) - annotate - [select for diffs], Sun Mar 6 17:19:05 2005 UTC (18 years, 8 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2005Q1-base, pkgsrc-2005Q1
Changes since 1.12: +2 -2 lines
Diff to previous 1.12 (colored)

Bump PKGREVISION with introduce of ruby16-base/ruby18-base pacakge.

Revision 1.12 / (download) - annotate - [select for diffs], Sun Mar 6 12:58:04 2005 UTC (18 years, 8 months ago) by taca
Branch: MAIN
Changes since 1.11: +2 -2 lines
Diff to previous 1.11 (colored)

Cosmetic change with pkglint(1).

Revision 1.11 / (download) - annotate - [select for diffs], Fri Jan 28 14:08:01 2005 UTC (18 years, 10 months ago) by taca
Branch: MAIN
Changes since 1.10: +4 -3 lines
Diff to previous 1.10 (colored)

Add RUBY_HAS_ARCHLIB which have machine dependent extention libraries.

Bump PKG_REVISION.

Revision 1.10 / (download) - annotate - [select for diffs], Sat Nov 27 15:45:57 2004 UTC (19 years ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2004Q4-base, pkgsrc-2004Q4
Changes since 1.9: +9 -21 lines
Diff to previous 1.9 (colored)

Update ruby-mysql package to 2.5.1 migrating to use new framework
for Ruby packages.

2004-09-20
    version 2.5.1
        * add Mysql#set_ssl().

2004-08-31
    version 2.5
        * correspond to MySQL 4.1.x.
        * change MysqlRes, MysqlField, MysqlError to Mysql::Result,
	  Mysql::Field, Mysql::Error.
        * add Mysql.client_version(), Mysql.get_client_version(),
	  Mysql#client_version(), Mysql#get_client_version(),
	  Mysql#server_version(), Mysql#get_server_version(),
	  Mysql#warning_count(), Mysql#commit(), Mysql#rollback(),
	  Mysql#autocommit().
        * add Mysql::Field#is_not_null?(), Mysql::Field#is_pri_key?(),
	  Mysql::Field#is_num?().
        * add MysqlField::TYPE_VAR_STRING.

Revision 1.9 / (download) - annotate - [select for diffs], Fri Oct 29 05:59:24 2004 UTC (19 years, 1 month ago) by jdolecek
Branch: MAIN
Changes since 1.8: +2 -2 lines
Diff to previous 1.8 (colored)

use mk/mysql.buildlink3.mk instead of databases/mysql-client/buildlink3.mk,
so that we'd not force dependance on specific MySQL version, and instead pick
the currently installed mysql*-client (or install the default if there
is no mysql-client package installed yet)

this makes package buildable with arbitrary MySQL version, such as 3.23.x,
4.0.x or 4.1.x

Revision 1.8 / (download) - annotate - [select for diffs], Sun Oct 3 00:13:23 2004 UTC (19 years, 2 months ago) by tv
Branch: MAIN
Changes since 1.7: +2 -1 lines
Diff to previous 1.7 (colored)

Libtool fix for PR pkg/26633, and other issues.  Update libtool to 1.5.10
in the process.  (More information on tech-pkg.)

Bump PKGREVISION and BUILDLINK_DEPENDS of all packages using libtool and
installing .la files.

Bump PKGREVISION (only) of all packages depending directly on the above
via a buildlink3 include.

Revision 1.7 / (download) - annotate - [select for diffs], Tue Apr 27 05:44:22 2004 UTC (19 years, 7 months ago) by snj
Branch: MAIN
CVS Tags: pkgsrc-2004Q3-base, pkgsrc-2004Q3, pkgsrc-2004Q2-base, pkgsrc-2004Q2
Changes since 1.6: +4 -4 lines
Diff to previous 1.6 (colored)

Convert to buildlink3.

Revision 1.6 / (download) - annotate - [select for diffs], Tue Mar 16 02:01:10 2004 UTC (19 years, 8 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2004Q1-base, pkgsrc-2004Q1
Changes since 1.5: +2 -2 lines
Diff to previous 1.5 (colored)

Add ruby to CATEGORIES.

Revision 1.5 / (download) - annotate - [select for diffs], Thu Sep 11 15:34:02 2003 UTC (20 years, 2 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2003Q4-base, pkgsrc-2003Q4
Changes since 1.4: +3 -4 lines
Diff to previous 1.4 (colored)

Update ruby-mysql pacakge to 2.4.5.

Changes from web page:

  2003-08-10	2.4.5
    * extconf.rb: correspond to MySQL 4.1.
    * mysql.c.in: correspond to Ruby 1.8.

  2003-02-23	2.4.4a
    * make extconf.rb to correspond to Ruby 1.8.0

  2003-01-29	2.4.4
    * add Mysql::OPT_LOCAL_INFILE.
    * add --with-mysql-config option to extconf.rb.
    * extconf.rb automatically detect typical library.

  2003-01-05	2.4.3c
    * modified English README. Thanks to Paul DuBois.

  2002-12-24	2.4.3b
    * make extconf.rb to correspond to Ruby 1.6.8.

  2002-11-07	2.4.3a
    * fix bug duplicating constant.

  2002-09-10	2.4.3
    * for error number with prefix ER_ .
    * get error constant from errmsg.h and mysqld_error.h automatically.

  2002-03-31	2.4.2a
    * change extconf.rb.

Revision 1.4 / (download) - annotate - [select for diffs], Sun Jul 13 13:50:59 2003 UTC (20 years, 4 months ago) by wiz
Branch: MAIN
Changes since 1.3: +2 -2 lines
Diff to previous 1.3 (colored)

PKGREVISION bump for libiconv update.

Revision 1.3 / (download) - annotate - [select for diffs], Thu Oct 10 11:55:09 2002 UTC (21 years, 1 month ago) by wiz
Branch: MAIN
CVS Tags: netbsd-1-6-1-base, netbsd-1-6-1
Changes since 1.2: +6 -5 lines
Diff to previous 1.2 (colored)

buildlink1 -> buildlink2.

Revision 1.2 / (download) - annotate - [select for diffs], Thu Mar 21 04:48:05 2002 UTC (21 years, 8 months ago) by fredb
Branch: MAIN
CVS Tags: pkgviews-base, pkgviews, netbsd-1-6-RELEASE-base, netbsd-1-6, netbsd-1-5-PATCH003, buildlink2-base, buildlink2
Changes since 1.1: +4 -1 lines
Diff to previous 1.1 (colored)

Bump dependency on ruby-base and ${PKGREVISION} as a result of the
fix to ${MACHINE_GNU_PLATFORM} causing ${RUBY_SITEARCHLIBDIR} to be
moved on certain ports.

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Sun Jan 27 15:19:06 2002 UTC (21 years, 10 months ago) by taca
Branch: TNF
CVS Tags: pkgsrc-base
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Importing ruby-mysql package, extension library to access a MySQL database
from Ruby.

Based on PR pkg/14302 with slightly modification and newer version, 2.4.2.

Revision 1.1 / (download) - annotate - [select for diffs], Sun Jan 27 15:19:06 2002 UTC (21 years, 10 months ago) by taca
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>