The NetBSD Project

CVS log for pkgsrc/databases/ruby-awesome_nested_set/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / databases / ruby-awesome_nested_set

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.20 / (download) - annotate - [select for diffs], Sat Nov 11 09:47:04 2023 UTC (3 months, 2 weeks ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, HEAD
Changes since 1.19: +2 -3 lines
Diff to previous 1.19 (colored)

databases/ruby-awesome_nested_set: update to 3.6.0

3.6.0 (2023-10-05)

* Support Rails 7.1 [Harshal Bhakta](https://github.com/harshalbhakta)
* Improve ImpossibleMove error message
  [AlejandroFernandesAntunes](https://github.com/AlejandroFernandesAntunes)

Revision 1.19 / (download) - annotate - [select for diffs], Sun Sep 3 15:42:31 2023 UTC (5 months, 3 weeks ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3
Changes since 1.18: +2 -1 lines
Diff to previous 1.18 (colored)

Bump revision RUBY_RAILS_DEFAULT change.

Revision 1.18 / (download) - annotate - [select for diffs], Sat Feb 12 07:15:46 2022 UTC (2 years ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Changes since 1.17: +2 -2 lines
Diff to previous 1.17 (colored)

databases/ruby-awesome_nested_set: update to 3.5.0

3.5.0 (2022-02-08)

* Support Rails 7.0.0
  [Peter Berkenbosch](https://github.com/peterberkenbosch) and
  [Andrew Hampton](https://github.com/andrewhampton)

* Make `order_column` option more flexible by removing explicit `=> :asc`
  [Regis Millet](https://github.com/Kulgar)

* Updated README to use latest migration syntax [Justin
  MacCarthy](https://github.com/macarthy)

Revision 1.17 / (download) - annotate - [select for diffs], Sun Feb 28 13:21:24 2021 UTC (2 years, 11 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1
Changes since 1.16: +2 -2 lines
Diff to previous 1.16 (colored)

databases/ruby-awesome_nested_set: update to 3.4.0

3.4.0 (2021-2-22)

* Keep current scope when calling `roots` [Petrik de Heus](https://github.com/p8)

* STI record now can update counter cache correctly [Issei Murasawa](http://github.com/issei-m)

* [Compare to 3.3.1](https://github.com/collectiveidea/awesome_nested_set/compare/v3.3.1...v3.4.0)

Revision 1.16 / (download) - annotate - [select for diffs], Sun Jan 10 14:15:29 2021 UTC (3 years, 1 month ago) by taca
Branch: MAIN
Changes since 1.15: +4 -7 lines
Diff to previous 1.15 (colored)

databases/ruby-awesome_nested_set: update to 3.3.1

3.3.1
* Add belongs_to :polymorphic key option only when used [Filippo Liverani](https://github.com/filippoliverani)
* [Compare to 3.3.0](https://github.com/collectiveidea/awesome_nested_set/compare/v3.3.0...v3.3.1)

3.3.0
* Update for compatibility with Rails 6.1 which no longer inherits scoping
  (Messages of the form "DEPRECATION WARNING: Class level methods will no longer inherit scoping from ...") [Marc Rohloff](https://github.com/marcrohloff)
* Fix ruby 2.7 keyword parameters deprecation warning [Krisdigital](https://github.com/krisdigital)
* [Compare to 3.2.1](https://github.com/collectiveidea/awesome_nested_set/compare/v3.2.1...v3.3.0)

Revision 1.15 / (download) - annotate - [select for diffs], Sun Aug 9 15:05:22 2020 UTC (3 years, 6 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3
Changes since 1.14: +2 -3 lines
Diff to previous 1.14 (colored)

databases/ruby-awesome_nested_set: update to 3.2.1

Update ruby-awesome_nested_set to 3.2.1.


3.2.1
* Don't reload in after_save callback. [Petrik de Heus](https://github.com/p8)
* Fix deprecation warning "Passing a range to `#in` is deprecated". [Konstantin Mochalov](https://github.com/kolen)
* [Compare to 3.2.0](https://github.com/collectiveidea/awesome_nested_set/compare/v3.2.0...v3.2.1)

Revision 1.14 / (download) - annotate - [select for diffs], Fri Mar 20 15:08:08 2020 UTC (3 years, 11 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1
Changes since 1.13: +4 -1 lines
Diff to previous 1.13 (colored)

Bump PKGREVISION

* Bump PKGREVISION by RUBY_RAILS_DEFAULT change.
* And add "USE_LANGUAGES= #none".

Revision 1.13 / (download) - annotate - [select for diffs], Sat Jan 18 15:11:40 2020 UTC (4 years, 1 month ago) by taca
Branch: MAIN
Changes since 1.12: +3 -3 lines
Diff to previous 1.12 (colored)

databases/ruby-awesome_nested_set: update to 3.2.0

Update ruby-awesome_nested_set to 3.2.0.

pkgsrc change: allow any rails version to depends on.

3.2.0
* Add support for Rails 6.0 [Stefan Andersen](https://github.com/stfnndrsn)
  and [Damian Legawiec](https://github.com/damianlegawiec) and
  [Jonathan Tapia](https://github.com/jtapia) and
  [Alex](https://github.com/a-ta-ta)

Revision 1.12 / (download) - annotate - [select for diffs], Sat Nov 2 15:38:11 2019 UTC (4 years, 3 months ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4
Changes since 1.11: +2 -2 lines
Diff to previous 1.11 (colored)

databases: align variable assignments

pkglint -Wall -F --only aligned -r

No manual corrections.

Revision 1.11 / (download) - annotate - [select for diffs], Mon Dec 17 14:34:16 2018 UTC (5 years, 2 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4
Changes since 1.10: +3 -4 lines
Diff to previous 1.10 (colored)

databases/ruby-awesome_nested_set: update to 3.1.4

pkgsrc change
* Drop support for Ruby on Rails 3.2.
* Support Ruby on Rails 4.2 and 5.1.

Revision 1.10 / (download) - annotate - [select for diffs], Sun Mar 18 14:21:20 2018 UTC (5 years, 11 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1
Changes since 1.9: +2 -2 lines
Diff to previous 1.9 (colored)

lang/ruby: replace RUBY_RAILS_SUPPORTED to RUBY_RAILS_ACCEPTED

Change RUBY_RAILS_SUPPORTED to RUBY_RAILS_ACCEPTED for better wording.

Revision 1.9 / (download) - annotate - [select for diffs], Sat Sep 16 19:26:45 2017 UTC (6 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.8: +2 -2 lines
Diff to previous 1.8 (colored)

Reset maintainer

Revision 1.8 / (download) - annotate - [select for diffs], Sun Jul 30 22:32:11 2017 UTC (6 years, 6 months ago) by wiz
Branch: MAIN
Changes since 1.7: +2 -2 lines
Diff to previous 1.7 (colored)

Switch github HOMEPAGEs to https.

Revision 1.7 / (download) - annotate - [select for diffs], Wed Jun 21 15:42:10 2017 UTC (6 years, 8 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2
Changes since 1.6: +2 -1 lines
Diff to previous 1.6 (colored)

Bump revision due to change of PKGPATH of depending rails components' packages.

Revision 1.6 / (download) - annotate - [select for diffs], Wed Jun 21 13:12:20 2017 UTC (6 years, 8 months ago) by taca
Branch: MAIN
Changes since 1.5: +2 -2 lines
Diff to previous 1.5 (colored)

Switch most of Ruby on Rails related packages to updated frame work.

Revision 1.5 / (download) - annotate - [select for diffs], Thu May 4 15:10:34 2017 UTC (6 years, 9 months ago) by taca
Branch: MAIN
Changes since 1.4: +1 -2 lines
Diff to previous 1.4 (colored)

Do not include "rails.mk" here.

Revision 1.4 / (download) - annotate - [select for diffs], Thu May 4 15:03:59 2017 UTC (6 years, 9 months ago) by taca
Branch: MAIN
Changes since 1.3: +4 -2 lines
Diff to previous 1.3 (colored)

Set RUBY_RAILS_SUPPORTED to 32 and utilize it.

Revision 1.3 / (download) - annotate - [select for diffs], Wed Jul 16 08:37:20 2014 UTC (9 years, 7 months ago) by rodent
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3
Changes since 1.2: +1 -2 lines
Diff to previous 1.2 (colored)

Unbump PKGREVISION on select ruby packages.

Revision 1.2 / (download) - annotate - [select for diffs], Wed Jul 16 07:56:28 2014 UTC (9 years, 7 months ago) by rodent
Branch: MAIN
Changes since 1.1: +2 -1 lines
Diff to previous 1.1 (colored)

Removing .ri entries from PLIST. NFI why this works with/without the
entries on my machine. Seems no other ruby package has them. Bump
PKGREVISION.

Revision 1.1 / (download) - annotate - [select for diffs], Fri Jul 4 00:20:17 2014 UTC (9 years, 7 months ago) by rodent
Branch: MAIN

Import ruby200-awesome_nested_set-2.1.6 as databases/ruby-awesome_nested_set.

An awesome nested set implementation for Active Record.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>