CVS log for pkgsrc/databases/py-pymysql/Makefile
Up to [cvs.NetBSD.org] / pkgsrc / databases / py-pymysql
Request diff between arbitrary revisions
Keyword substitution: kv
Default branch: MAIN
Revision 1.18: download - view: text, markup, annotated - select for diffs
Mon Nov 11 07:27:57 2024 UTC (3 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base,
pkgsrc-2024Q4,
HEAD
Diff to: previous 1.17: preferred, colored
Changes since revision 1.17: +1 -2
lines
py-*: remove unused tool dependency
py-setuptools includes the py-wheel functionality nowadays
Revision 1.17: download - view: text, markup, annotated - select for diffs
Wed May 22 07:18:56 2024 UTC (8 months, 3 weeks ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base,
pkgsrc-2024Q3,
pkgsrc-2024Q2-base,
pkgsrc-2024Q2
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +5 -3
lines
py-pymysql: updated to 1.1.1
v1.1.1
> [!WARNING]
> This release fixes a vulnerability (CVE-2024-36039).
> All users are recommended to update to this version.
>
> If you can not update soon, check the input value from
> untrusted source has an expected type. Only dict input
> from untrusted source can be an attack vector.
* Prohibit dict parameter for `Cursor.execute()`. It didn't produce valid SQL
and might cause SQL injection. (CVE-2024-36039)
Revision 1.16: download - view: text, markup, annotated - select for diffs
Fri Jan 19 13:08:23 2024 UTC (12 months, 3 weeks ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q1-base,
pkgsrc-2024Q1
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +8 -4
lines
py-pymysql: updated to 1.1.0
v1.1.0
* Fixed SSCursor raising OperationalError for query timeouts on wrong statement
* Exposed `Cursor.warning_count` to check for warnings without additional query
* Make Cursor iterator
* Support '_' in key name in my.cnf
* `Cursor.fetchall()` returns empty list instead of tuple
* Deprecate Error classes in Cursor class
* Add `Connection.set_character_set(charset, collation=None)`. This method is compatible with mysqlclient.
* Deprecate `Connection.set_charset(charset)`
* New connection always send "SET NAMES charset [COLLATE collation]" query.
Since collation table is vary on MySQL server versions, collation in handshake is fragile.
* Support `charset="utf8mb3"` option
Revision 1.15: download - view: text, markup, annotated - select for diffs
Thu Apr 21 11:00:00 2022 UTC (2 years, 9 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2023Q4-base,
pkgsrc-2023Q4,
pkgsrc-2023Q3-base,
pkgsrc-2023Q3,
pkgsrc-2023Q2-base,
pkgsrc-2023Q2,
pkgsrc-2023Q1-base,
pkgsrc-2023Q1,
pkgsrc-2022Q4-base,
pkgsrc-2022Q4,
pkgsrc-2022Q3-base,
pkgsrc-2022Q3,
pkgsrc-2022Q2-base,
pkgsrc-2022Q2
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +3 -2
lines
*: convert to versioned_dependencies for py-cryptography
Revision 1.14: download - view: text, markup, annotated - select for diffs
Tue Jan 4 20:52:44 2022 UTC (3 years, 1 month ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2022Q1-base,
pkgsrc-2022Q1
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +2 -1
lines
*: bump PKGREVISION for egg.mk users
They now have a tool dependency on py-setuptools instead of a DEPENDS
Revision 1.13: download - view: text, markup, annotated - select for diffs
Sat Nov 21 22:22:35 2020 UTC (4 years, 2 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base,
pkgsrc-2021Q4,
pkgsrc-2021Q3-base,
pkgsrc-2021Q3,
pkgsrc-2021Q2-base,
pkgsrc-2021Q2,
pkgsrc-2021Q1-base,
pkgsrc-2021Q1,
pkgsrc-2020Q4-base,
pkgsrc-2020Q4
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +2 -2
lines
py-pymysql: updated to 0.10.1
v0.10.1
* Fix missing import of ProgrammingError.
* Fix auth switch request handling.
Revision 1.12: download - view: text, markup, annotated - select for diffs
Thu Aug 6 14:15:28 2020 UTC (4 years, 6 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q3-base,
pkgsrc-2020Q3
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +2 -2
lines
py-pymysql: updated to 0.10.0
v0.10.0
This version is the last version supporting Python 2.7.
* MariaDB ed25519 auth is supported.
* Python 3.4 support is dropped.
* Context manager interface is removed from `Connection`. It will be added
with different meaning.
* MySQL warnings are not shown by default because many user report issue to
PyMySQL issue tracker when they see warning. You need to call "SHOW WARNINGS"
explicitly when you want to see warnings.
* Formatting of float object is changed from "3.14" to "3.14e0".
* Use cp1252 codec for latin1 charset.
* Fix decimal literal.
* TRUNCATED_WRONG_VALUE_FOR_FIELD, and ILLEGAL_VALUE_FOR_TYPE are now
DataError instead of InternalError.
Revision 1.11: download - view: text, markup, annotated - select for diffs
Fri Jul 5 11:08:25 2019 UTC (5 years, 7 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q2-base,
pkgsrc-2020Q2,
pkgsrc-2020Q1-base,
pkgsrc-2020Q1,
pkgsrc-2019Q4-base,
pkgsrc-2019Q4,
pkgsrc-2019Q3-base,
pkgsrc-2019Q3
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +2 -2
lines
py-pymysql: updated to 0.9.3
0.9.3
* cryptography dependency is optional now.
* Fix old_password (used before MySQL 4.1) support.
* Deprecate old_password.
* Stop sending ``sys.argv[0]`` for connection attribute "program_name".
* Close connection when unknown error is happened.
* Deprecate context manager API of Connection object.
Revision 1.10: download - view: text, markup, annotated - select for diffs
Mon Dec 10 17:49:26 2018 UTC (6 years, 2 months ago) by jperkin
Branches: MAIN
CVS tags: pkgsrc-2019Q2-base,
pkgsrc-2019Q2,
pkgsrc-2019Q1-base,
pkgsrc-2019Q1,
pkgsrc-2018Q4-base,
pkgsrc-2018Q4
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +2 -2
lines
py-pymysql: Fix DEPENDS match.
Revision 1.9: download - view: text, markup, annotated - select for diffs
Mon Dec 10 11:34:00 2018 UTC (6 years, 2 months ago) by adam
Branches: MAIN
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +5 -3
lines
py-pymysql: updated to 0.9.2
0.9.2:
* Disalbled unintentinally enabled debug log
* Removed unintentionally installed tests
0.9.1:
* Fixed caching_sha2_password and sha256_password raise TypeError on PY2
0.9.0:
* Change default charset from latin1 to utf8mb4. (because MySQL 8 changed)
* Support sha256_password and caching_sha2_password auth method
* Add cryptography dependency, because it's needed for new auth methods.
* Remove deprecated `no_delay` option
* Support connection attributes
* Map LOCK_DEADLOCK to OperationalError
Revision 1.8: download - view: text, markup, annotated - select for diffs
Wed Jan 24 14:19:34 2018 UTC (7 years ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2018Q3-base,
pkgsrc-2018Q3,
pkgsrc-2018Q2-base,
pkgsrc-2018Q2,
pkgsrc-2018Q1-base,
pkgsrc-2018Q1
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -8
lines
py-pymysql: updated to 0.8.0
0.8:
* **BACKWARD INCOMPATIBLE** binary_prefix option is added and off
by default because of compatibility with mysqlclient.
When you need PyMySQL 0.7 behavior, you have to pass binary_prefix=True.
* **BACKWARD INCOMPATIBLE** MULTI_STATEMENTS client flag is no longer
set by default, while it was on PyMySQL 0.7. You need to pass
client_flag=CLIENT.MULTI_STATEMENTS when you connect to explicitly
enable multi-statement mode.
* Fixed AuthSwitch packet handling.
* Raise OperationalError for MariaDB's constraint error.
* executemany() accepts query without space between VALUES and (.
* Support config file containing option without value.
* Fixed Connection.ping() returned unintended value.
Revision 1.7: download - view: text, markup, annotated - select for diffs
Sun Sep 17 13:31:04 2017 UTC (7 years, 4 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2017Q4-base,
pkgsrc-2017Q4,
pkgsrc-2017Q3-base,
pkgsrc-2017Q3
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +2 -2
lines
py-pymysql: update to 0.7.11
0.7.11
* Fixed Connection.close() failed when failed to send COM_CLOSE packet.
* Cursor.executemany() accepts query ends with semicolon.
* ssl parameters can be read from my.cnf.
Revision 1.6: download - view: text, markup, annotated - select for diffs
Sat Sep 16 19:26:44 2017 UTC (7 years, 4 months ago) by wiz
Branches: MAIN
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -2
lines
Reset maintainer
Revision 1.5: download - view: text, markup, annotated - select for diffs
Wed Jun 8 17:43:22 2016 UTC (8 years, 8 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2017Q2-base,
pkgsrc-2017Q2,
pkgsrc-2017Q1-base,
pkgsrc-2017Q1,
pkgsrc-2016Q4-base,
pkgsrc-2016Q4,
pkgsrc-2016Q3-base,
pkgsrc-2016Q3,
pkgsrc-2016Q2-base,
pkgsrc-2016Q2
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -2
lines
Switch to MASTER_SITES_PYPI.
Revision 1.4: download - view: text, markup, annotated - select for diffs
Mon Apr 13 23:12:40 2015 UTC (9 years, 10 months ago) by rodent
Branches: MAIN
CVS tags: pkgsrc-2016Q1-base,
pkgsrc-2016Q1,
pkgsrc-2015Q4-base,
pkgsrc-2015Q4,
pkgsrc-2015Q3-base,
pkgsrc-2015Q3,
pkgsrc-2015Q2-base,
pkgsrc-2015Q2
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +1 -3
lines
Removing python26. EOL'd quite some ago and discussed a couple times on
tech-pkg@ and pkgsrc-users@.
Revision 1.3: download - view: text, markup, annotated - select for diffs
Wed Apr 1 02:16:26 2015 UTC (9 years, 10 months ago) by rodent
Branches: MAIN
CVS tags: pkgsrc-2015Q1-base,
pkgsrc-2015Q1
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -2
lines
Updated to 0.6.6. From CHANGELOG:
## 0.6.6
* Add context manager to cursor
* Fix can't encode blob that is not utf-8 on PY3. (regression of 0.6.4,
Thanks to @wiggzz)
## 0.6.4
* Support "LOAD LOCAL INFILE". Thanks @wraziens
* Show MySQL warnings after execute query.
* Fix MySQLError may be wrapped with OperationalError while connectiong. (#274)
* SSCursor no longer attempts to expire un-collected rows within __del__,
delaying termination of an interrupted program; cleanup of uncollected
rows is left to the Connection on next execute, which emits a
warning at that time. (#287)
* Support datetime and time with microsecond. (#303)
* Use surrogateescape to format bytes on Python 3.
* OperationalError raised from connect() have information about original
exception. (#304)
* `init_command` now support multi statement.
* `Connection.escape()` method now accepts second argument compatible to
MySQL-Python.
## 0.6.3
* Fixed multiple result sets with SSCursor.
* Fixed connection timeout.
* Fixed literal set syntax to work on Py2.6.
* Allow for mysql negative values with 0 hour timedelta.
* Added Connection.begin().
Revision 1.2: download - view: text, markup, annotated - select for diffs
Wed Aug 13 22:40:19 2014 UTC (10 years, 6 months ago) by joerg
Branches: MAIN
CVS tags: pkgsrc-2014Q4-base,
pkgsrc-2014Q4,
pkgsrc-2014Q3-base,
pkgsrc-2014Q3
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +3 -1
lines
Not compatible with Python 2.6 syntax.
Revision 1.1: download - view: text, markup, annotated - select for diffs
Sat Jun 14 14:03:33 2014 UTC (10 years, 8 months ago) by rodent
Branches: MAIN
CVS tags: pkgsrc-2014Q2-base,
pkgsrc-2014Q2
Import py27-pymysql-0.6.2 as databases/py-pymysql.
This package contains a pure-Python MySQL client library. The goal of PyMySQL is
to be a drop-in replacement for MySQLdb and work on CPython, PyPy, IronPython
and Jython.
CVSweb <webmaster@jp.NetBSD.org>