The NetBSD Project

CVS log for pkgsrc/databases/py-peewee/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / databases / py-peewee

Request diff between arbitrary revisions


Default branch: MAIN
Current tag: pkgsrc-2014Q4


Revision 1.3 / (download) - annotate - [select for diffs], Fri Dec 12 11:42:25 2014 UTC (9 years, 4 months ago) by fhajny
Branch: MAIN
CVS Tags: pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4
Changes since 1.2: +4 -4 lines
Diff to previous 1.2 (unified)

Update py-peewee to 2.4.4.

2.4.4
=====
* Backwards-incompatible changes
  - The argument signature for the SqliteExtDatabase.aggregate() decorator
    changed so that the aggregate name is the first parameter, and
    the number of parameters is the second parameter. If no values are
    specified, peewee will choose the name of the class and an un-specified
    number of arguments (-1).
  - The logic for saving a model with a composite key changed slightly.
    Previously, if a model had a composite primary key and you called save(),
    only the dirty fields would be saved.
* Bugs fixed
  - #462
  - #465, add hook for disabling backref validation.
  - #466, fix case-sensitive table names with migration module.
  - #469, save only dirty fields.
* New features
  - Lots of enhancements and cleanup to the playhouse.apsw_ext module.
  - The playhouse.reflection module now supports introspecting indexes.
  - Added a model option for disabling backref validation.
  - Added support for the SQLite closure table extension.
  - Added support for virtual fields, which act on dynamically-created
    virtual table fields.
  - Added a new example: a virtual table implementation that exposes Redis
    as a relational database table.
  - Added a module playhouse.sqlite_aggregates that contains a handful of
    aggregates you may find useful when developing with SQLite.
  - Small documentation updates here and there.

2.4.3
=====
* Bugs fixed
  - #466, table names are case sensitive in the SQLite migrations module.
  - #465, added option to disable backref validation.
  - #462, use the schema name consistently with postgres reflection.
* New features
  - New model Meta option to disable backref validation. See
    validate_backrefs.
  - Added documentation on ordering by calculated values.
  - Added basic PyPy compatibility.
  - Added logic to close cursors after they have been exhausted.
  - Structured and consolidated database metadata introspection, including
    improvements for introspecting indexes.
  - Added support to prefetch for traversing up the query tree.
  - Added introspection option to skip invalid models while introspecting.
  - Added option to limit the tables introspected.
  - Added closed connection detection to the MySQL connection pool.
  - Enhancements to passing options to creating virtual tables with SQLite.
  - Added factory method for generating Closure tables for use with the
    transitive_closure SQLite extension.
  - Added support for loading SQLite extensions.
  - Numerous test-suite enhancements and new test-cases.

2.4.2
=====
* Bugs fixed
  - #449, typo in the db_url extension, thanks to @malea for the fix.
  - #457 and #458, fixed documentation deficiences.
* New features
  - Added support for importing data when using the DataSet extension.
  - Added an encrypted diary app to the examples.
  - Better index reconstruction when altering columns on SQLite databases
    with the migrate module.
  - Support for multi-column primary keys in the reflection module.
  - Close cursors more aggressively when executing SELECT queries.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>